grub message: 'sparse file not allowed'

Bug #975557 reported by davidetkarine on 2012-04-06
62
This bug affects 14 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Just after grub entry selection done I receive this message: 'sparse file not allowed' and it ask me to press enter to continue then it works. I've got my root partition on a btrfs file system.
I looked at this blog: http://mirkolofio.wordpress.com/2011/05/20/error-sparse-file-not-allowed/
that give a solution that i didn't tried:

I’m running a btrfs on / with (fake)raid1 and grub2, solved by removing line:
if [ -n ${have_grubenv} ]; then save_env recordfail; fi
from /boot/grub/grub.cfg file.
from /etc/grub.d/00_header file, and then running update-grub.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: grub-common 1.99-21ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Date: Sat Apr 7 00:04:59 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

davidetkarine (saveurlinux) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers