grub doesn't find boot

Bug #975061 reported by ZeroBeat on 2012-04-06
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
grub
Unknown
Unknown
grub2 (Ubuntu)
High
Colin Watson

Bug Description

After a fresh installation of ubuntu (ubuntu-12.04-beta2-dvd-amd64) grub doesn't find the boot partition.
grub runs rescue with error: invalid sector size 65535 (maybe grub tries to use a card-reader slot...)
After
sett prefix=(hd4,2)/ boot/grub
set root=(hd4,2)
insmod normal
normal
the system starts correct.
See attached picture.

Standard installation (on one hard disc) causes the same error.
Installation using mbr causes the same error.
Installation using gpt causes the same error.
Disabling efi and using normal bios causes 12.04 to start in non-grafics mode.
Best regards
Mike

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: grub-efi-amd64 1.99-21ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Date: Fri Apr 6 13:30:21 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

ZeroBeat (zerobeat) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Larry Hastings (larry-hastings) wrote :

I'm seeing slightly different behavior. My system is initally bootable, but goes into this mode after some use. (I suspect there is some update that is causing the behavior.)

I'm using a crazy PCI hard disk (an OCZ RevoDrive), but my boot disk is a small vanilla SATA SSD drive. I don't think grub2 recognizes the PCI hard disk at all.

Larry Hastings (larry-hastings) wrote :

More data, fwiw: I installed the machine a month ago, took updates, and had no trouble. I went on the road for a month. When I got back I took updates and saw this behavior. I reinstalled using a fresh nightly (April 5); initially it was fine, but after the second or third updates & reboot I again saw the behavior.

ZeroBeat (zerobeat) wrote :

Hi Larry.
I think ist's in the combination: efi + grub2 in ubuntu 12.04.
If i connect another usb-storage device bevor booting the system, harddisks change from hd4 to hd5.
grub2 doesn't recognise this change and looks for boot device on hd0.
ubuntu 11.10 works fine, using the same efi config.
Im using the following components:
asus P9X79 (asus-efi enabled)
samsung 830series (ssd) as boot
wd 2 TB as home
interal 4 x cardreader connected to the internal usb-port
Best regards Mike

I'm seeing this same problem using an EFI partition for boot too.

Same problem after upgrade from Ubuntu 11.10. Using amd64 + SSD drive for the OS.

Jan Commandeur (jancommandeur) wrote :

I also have the same problem.

asus M5A97 (asus-efi enabled)
ssd disk
HDisk
interal 4 x cardreader connected to the internal usb-port

grub runs rescue with error: invalid sector size 65535

Jan Commandeur (jancommandeur) wrote :

I pulled out the internal usb plug from the cardreader, and now the computer don't give an error and startup.
Now i works without the cardreader.

thanks.

Peter Hawkins (hawkinsp) wrote :

For me, my computer boots fine with no USB devices attached. If I plug in my monitor's USB cable before boot (a Dell U2711, which contains an integrated SD card reader), I receive the "illegal sector size" message. The correct boot device is a SATA SSD disk; it certainly seems like plugging in the SD card reader messes up the device numbering.

I'm using an ASUS P8Z68-V motherboard with a UEFI bios, running an up to date version of Ubuntu Precise.

quequotion (quequotion) wrote :

This bug should have a very high priority.

It is a known bug in GRUB and it is already fixed upstream:
http://savannah.gnu.org/bugs/?35382

This bug prevents (U)EFI systems from booting.

If you know grub really well, and your partition layout really well, you can manually specify all the parameters and commands necessary to boot at the rescue prompt starting with the "prefix" which is probably set to the wrong drive.

Please package the upstream fix for ubuntu before this disasterous bug gets into the wild!

ZeroBeat (zerobeat) wrote :

Thanks for the information. This is exactly the bug. Is it solved in version 2.00 of grub2?
Best regards
Mike

Colin Watson (cjwatson) on 2012-04-17
Changed in grub2 (Ubuntu):
importance: Undecided → High
Colin Watson (cjwatson) on 2012-04-17
Changed in grub2 (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.99-21ubuntu3

---------------
grub2 (1.99-21ubuntu3) precise; urgency=low

  * Backport several upstream EFI device discovery patches to fix boot
    failures (LP: #975061).
 -- Colin Watson <email address hidden> Tue, 17 Apr 2012 16:11:45 +0100

Changed in grub2 (Ubuntu):
status: In Progress → Fix Released
quequotion (quequotion) wrote :

Thank you cjwatson!

Works like a charm!

ZeroBeat (zerobeat) wrote :

You're welcome.
Works fine.
Best regards
Mike

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.