`grub-probe --target=device inaccessible-path` crashes

Bug #938724 reported by Alkis Georgopoulos on 2012-02-22
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Medium
Colin Watson

Bug Description

While running update-grub within a chroot, /usr/sbin/grub-probe --target=device /opt/ltsp/images/fat.img was called (a loop device), but that path wasn't available inside the chroot, and grub-probe crashed.

The attached trace is from a simple `grub-probe --target=device asdf` in my main system, without using any chroots at all.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: grub-common 1.99-14ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
ApportVersion: 1.92-0ubuntu1
Architecture: i386
Date: Wed Feb 22 16:42:31 2012
ExecutablePath: /usr/sbin/grub-probe
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111129.1)
ProcCmdline: /usr/sbin/grub-probe --target=device asdf
SegvAnalysis:
 Segfault happened at: 0x807d567: cmpb $0x0,(%eax)
 PC (0x0807d567) ok
 source "$0x0" ok
 destination "(%eax)" (0x00000000) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: grub2
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip epoptes fuse lpadmin plugdev sambashare sudo vboxusers

Alkis Georgopoulos (alkisg) wrote :

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 __libc_start_main (main=0x8049f50, argc=3, ubp_av=0xbfa48c44, init=0x80853a0, fini=0x8085410, rtld_fini=0xb7714280, stack_end=0xbfa48c3c) at libc-start.c:226

Changed in grub2 (Ubuntu):
status: New → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libdbus-1-3 version 1.4.16-1ubuntu4 required, but 1.4.18-1ubuntu1 is available

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-i386-retrace
Alkis Georgopoulos (alkisg) wrote :

I'm removing the "Invalid" status generated by apport as the whole apport trace isn't needed, the grub developers can reproduce the bug themselves by just issuing

grub-probe --target=device inaccessible-path

Also, the automated comment about updating libdbus-1-3 doesn't make much sense, OK, I updated it and the problem is still there, but Precise is still in development, newer package versions will keep coming all the time, I can't file a new bug report every few hours.

Changed in grub2 (Ubuntu):
status: Invalid → New
Alkis Georgopoulos (alkisg) wrote :

grub-probe just crashed again while updating linux-image-3.2.0-17-generic.
If I just run `touch inaccessible-path`, then grub-probe doesn't crash and apt-get dist-upgrade completes successfully.

Also, about the apport automated answer:
# dpkg-query -W libdbus-1-3
libdbus-1-3 1.4.18-1ubuntu1

visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) on 2012-04-05
Changed in grub2 (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.99-21ubuntu2

---------------
grub2 (1.99-21ubuntu2) precise; urgency=low

  [ Andy Whitcroft ]
  * Only supply vt.handoff=7 when we are using gfxpayload=keep. Do this
    even when the command line is modified before execution. (LP: #942846)

  [ Colin Watson ]
  * Don't crash on inaccessible loop device backing paths (LP: #938724).
 -- Colin Watson <email address hidden> Thu, 05 Apr 2012 13:36:57 +0100

Changed in grub2 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers