Corrupted grub screen in Precise alpha1

Bug #897921 reported by Jane Atkinson on 2011-11-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Medium
Unassigned

Bug Description

I found this during ISO testing. It is somewhat similar to bug #701111 (marked "fix released"), except that I'm using different hardware.

Hardware is
VGA compatible controller [0300]: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] [1106:3371] (rev 01)
Subsystem: ASUSTeK Computer Inc. Device [1043:81ce]

Output of lspci -vn is attached.

When I boot, the grub screen will appear to flash between appearing in the normal position and showing the left edge in the middle of the screen. Sometimes, it flashes backwards and forwards between the two. I've also attached a photo of the screen.

Grub itself behaves normally; it's just the display that's unstable.

Uncommenting the line

GRUB_GFXMODE=640x480

in /etc/default/grub and running "update-grub" fixes the problem, but of course renders the screen in a larger font.

Jane Atkinson (irihapeti) wrote :
Jane Atkinson (irihapeti) wrote :
tags: added: iso-testing
Brian Murray (brian-murray) wrote :

Have you noticed this in any other releases of Ubuntu?

Changed in grub2 (Ubuntu):
importance: Undecided → Medium
Jane Atkinson (irihapeti) wrote :

Brian:

I had the same thing happen with Natty. See my comments (#8 and 9) on bug #701111

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/897921

Jane Atkinson (irihapeti) wrote :

This bug is still present in Precise alpha2

Changed in grub2 (Ubuntu):
status: New → Confirmed
Jane Atkinson (irihapeti) wrote :

This bug is still present in Precise Beta1 iso candidate.

Colin Watson (cjwatson) wrote :

Could you run 'videoinfo' from the GRUB command line and take a photo of that? I'd like to see what mode it's selected by default.

Jane Atkinson (irihapeti) wrote :

Colin:

Photo "videoinfo.jpg" is attached.

However, I think that this may have been fixed in the latest grub update.

I had to run "grub-install /dev/sda" from Precise, because I have been using the Lucid grub for everyday purposes.
The screen on bootup was normal. I've attached a photo of that as well.

I'm not sure why the margin is missing on the right-hand side. I think it may have to do with a slight misalignment in my screen, which doesn't show when the OS is loaded.

Jane Atkinson (irihapeti) wrote :
Jane Atkinson (irihapeti) wrote :

Aaahrgh! The problem is back again as of about 40 minutes ago. Some update may have been the culprit.

Colin Watson (cjwatson) wrote :

Hm, are you sure you didn't run that 'videoinfo' command with some workaround or other in place? Ideally, it would actually be most helpful to get that output when GRUB has started with the screen in this corrupted state.

Jane Atkinson (irihapeti) wrote :

Colin:
I don't know what happened the last time. Any "workaround" would have been accidental.

Anyway, I've taken another shot which I've attached as videoinfo2.jpg

I'm finding it difficult to get a shot in which the numbers are really readable, so if any of them need to be written down and posted, I can do that.

Jane Atkinson (irihapeti) wrote :

This bug is still happening in raring beta2, ubuntu-gnome.

Jane Atkinson (irihapeti) wrote :

And still happening in Trusty alpha-1, xubuntu desktop i386

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers