Ubuntu

UEFI boot broken on asus laptops

Reported by Giuseppe Iannello on 2011-10-21
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

After setting up an USB installer for ubuntu 11.10, I can boot it in both BIOS emulation and UEFI mode.
In BIOS mode, syslinux starts and I can install/run ubuntu. In UEFI mode grub loads correctly but after selecting a boot option, the laptop hangs.
After installing on hdd, the same thing happens. grub can launch the kernel only in BIOS mode.
I tried using the 3.1.0 kernel from precise, but still no luck. I also tried using "acpi=force", "noexec=off" and "nomodeset xdriver=vesa". The only way to boot from UEFI is using "noefi" option, but that breaks almost everything (keyboard sends wrong keycodes).

Miloš Jakovljević (milos-sd) wrote :

Are you trying 32bit or 64bit version of Ubuntu? I ask, because only GRUB2 in 64bit Ubuntu supports UEFI booting. :)

64bit version

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
123RaZoR321 (123razor321) wrote :

Same problem on Asus N53SW and ubuntu 12.04. No matter what I tried, it just won't boot in UEFI mode. Black screen after selecting any boot option from live-cd

123RaZoR321 (123razor321) wrote :

I'm sorry if it is a bit offtopic, but on the same laptop Fedora 17 can't be booted in UEFI mode as well. Symptoms are the same: hang after selecting any boot option.

123RaZoR321 (123razor321) wrote :

trying to boot with "noefi' option does the trick and ubuntu boots, but touchpad and bluetooth(and maybe more) aren't working

summary: - UEFI boot broken on asus k53sc
+ UEFI boot broken on asus laptops
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers