package grub-legacy-ec2 0.6.1-0ubuntu8 failed to install/upgrade: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück

Bug #856828 reported by Harald Okun on 2011-09-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Medium
Unassigned

Bug Description

knoppix on another partition is also installed

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: grub-legacy-ec2 0.6.1-0ubuntu8
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic i686
Architecture: i386
Date: Thu Sep 22 23:25:15 2011
ErrorMessage: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
PackageArchitecture: all
SourcePackage: cloud-init
Title: package grub-legacy-ec2 0.6.1-0ubuntu8 failed to install/upgrade: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
UpgradeStatus: Upgraded to natty on 2011-09-08 (14 days ago)

affects: ubuntu → cloud-init (Ubuntu)
Clint Byrum (clint-fewbar) wrote :

Reassigning to grub2 due to this portion of the DpkgTerminalLog.txt:

linux-image-2.6.38-10-generic (2.6.38-10.46) wird eingerichtet ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.38-10-generic
Not updating initrd symbolic links since we are being updated/reinstalled
(2.6.38-10.46 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(2.6.38-10.46 was configured last, according to dpkg)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 2.6.38-10-generic /boot/vmlinuz-2.6.38-10-generic
run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.38-10-generic /boot/vmlinuz-2.6.38-10-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 2.6.38-10-generic /boot/vmlinuz-2.6.38-10-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 2.6.38-10-generic /boot/vmlinuz-2.6.38-10-generic
run-parts: executing /etc/kernel/postinst.d/x-grub-legacy-ec2 2.6.38-10-generic /boot/vmlinuz-2.6.38-10-generic
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
uuid not supported. update 'groot' in /boot/grub/menu.lst

groot must be grub root device (ie '(hd0)'). not 'f52c4add-0fe3-40cf-b660-3a334d329c45'

run-parts: /etc/kernel/postinst.d/x-grub-legacy-ec2 exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.38-10-generic.postinst line 1010.
dpkg: Fehler beim Bearbeiten von linux-image-2.6.38-10-generic (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 2 zurück
grub-legacy-ec2 (0.6.1-0ubuntu8) wird eingerichtet ...
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
uuid not supported. update 'groot' in /boot/grub/menu.lst

groot must be grub root device (ie '(hd0)'). not 'f52c4add-0fe3-40cf-b660-3a334d329c45'

dpkg: Fehler beim Bearbeiten von grub-legacy-ec2 (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück

affects: cloud-init (Ubuntu) → grub2 (Ubuntu)
Changed in grub2 (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers