Numlock gets deactivated when grub2 loads

Bug #843804 reported by Paul Hoell on 2011-09-07
46
This bug affects 14 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Medium
Colin Watson

Bug Description

I have a desktop machine, and i prefer to have numlock activated at all times, so i set that behavior in the UEFI of my Asus board.

The numlock then activates correctly at start time, but is only active until grub2 loads, at which point it deactivates and stays off until i reactivate it manually. This is very annoying and should not happen. The setting should not be messed with, when there is no way to control the behavior from inside the system.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: grub2 (not installed)
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Wed Sep 7 13:56:07 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64+mac (20110901)
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

Paul Hoell (hoellp) wrote :
affects: grub2 (Ubuntu) → grub (Ubuntu)
affects: grub (Ubuntu) → grub2 (Ubuntu)
dino99 (9d9) wrote :

Oneiric i386 b1

get numlock deactivated at grub2 time then at lightdm time again (setting: numlock=on by default)

Changed in grub2 (Ubuntu):
status: New → Confirmed
Paul Hoell (hoellp) wrote :

I'm a little confused concerning the correct package. because it seems the only package installed on my system is grub2-common.
Out of instinct i reported against grub2 which is a dummy i then found out, grub-pc is also not installed...

Sorry for the confusion, i hope this can be corrected. The report itself is valid regardless of the package.

Paul Hoell (hoellp) wrote :

Hey dino, thanks for confirming, but this not exactly the behavior i see here.

If i activate numlock between grub and lightdm, it stays activated until the next reboot. It only deactivates once, and that is when grub loads.

rjb (ron-buehler) wrote :

i'm having the same "problem" since ubuntu 10.11 at least.
i'd wish it would either use the bios preference or probably even better: last state.

Suky (suky) wrote :

This bug came to me with Ubuntu 12.04 (precise) 64 bit also :-(
Very annoying...

Colin Watson (cjwatson) on 2014-02-03
Changed in grub2 (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Colin Watson (cjwatson)
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02~beta2-7

---------------
grub2 (2.02~beta2-7) experimental; urgency=medium

  * Fix shift-held-down test not to clear other modifier key states
    (LP: #843804).
  * Explicitly pass an appropriate --target to grub-install in the postinst
    (suggested by Jordan Uggla).
  * Backport from upstream:
    - Use bootaa64.efi instead of bootaarch64.efi on arm64 to comply with
      EFI specification. Also use grubaa64.efi for consistency.

 -- Colin Watson <email address hidden> Mon, 10 Mar 2014 13:39:33 +0000

Changed in grub2 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments