Ubuntu

package linux-image-2.6.32-33-386 (not installed) failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Reported by c.cobb on 2011-08-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

System: 10.04 LTS
Last system update via Update Manager on 22-Jun-2011, so lots of updates.
31 of 34 downloads succeeded, but one of the linux-image, or linux-headers, or linux-headers-generic for 2.6.32-33 hung at 90% download
(sorry, I didn't write down which one)

After that, got warning of dependency failure, and "do you want to continue anyway?" Said yes.
Then, received this error notice.

E: linux-image-2.6.32-33-generic: subprocess installed
       post-installation script returned error exit status 2
E: linux-image-generic: dependency problems - leaving unconfigured
E: linux-generic: dependency problems - leaving unconfigured

At this point Update Manager said another 51 packages needed installing.
After this, during config phase, received same error notice as above.

Tried removing, and reinstalling
  linux-headers-2.6.32-33
  linux-headers-2.6.32-33-generic
  linux-image-2.6.32-33-generic

When no new packages were downloaded, tried complete removal and reinstall.
But at this point, SPM does not have an entry for 'linux-image-2.6.32-33-generic' so selected linux-image-2.6.32-33-386 along with the two header packages.

After install received the same errors as before.

Synaptic Package Manager shows no broken dependencies.

I have re-removed completely these three packages.
Update Manager says I have an up-to-date system.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-33-386 (not installed)
ProcVersionSignature: Ubuntu 2.6.32-32.62-generic 2.6.32.38+drm33.16
Uname: Linux 2.6.32-32-generic i686
Architecture: i386
Date: Wed Aug 10 12:49:24 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 2
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
SourcePackage: grub2
Title: package linux-image-2.6.32-33-386 (not installed) failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

c.cobb (chris-a-cobb) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers