Ubuntu

keyboard not working at grub screen

Reported by PoT on 2011-04-26
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

It's impossible to change the default booting OS from grub because the keyboard doesn't work, this bug wasn't there when I just installed the Natty beta 2 .

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: grub-pc 1.99~rc1-13ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Tue Apr 26 19:23:16 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
ProcEnviron:
 LANGUAGE=en
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

PoT (emmanuel-gonzalezcarmona) wrote :
Menocu (public-bitsculptor) wrote :

Issue did not exist for 11.04 beta. Issue manifested immediately after I updated to 11.04 release.

r000t (vistro) wrote :

This affects me too, but now I can't even get the fucker to boot at all. It just sits there. 11.04 wasn't ready for release IMO.

I got this tonight on a computer built around a Gigabyte G31M-S2L mainboard.

I was able to select an entry in the grub screen and continue startup by plugging in an old PS/2 keyboard, another USB keyboard did not work.

Dmitry Andreychuk (and-dmitry) wrote :

I have this problem with PS/2 keyboard.

Dmitry Andreychuk (and-dmitry) wrote :

Ohh, my keyboard was plugged into the mouse port.
So if you have a PS/2 keyboard and it doesn't work in grub but works in Ubuntu, check what port it's plugged in.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
cometdog (ericctharley) wrote :

Just upgraded to Precise. Computer won't complete booting due to nvidia graphics. My grub screen won't respond to keyboard input. Not too helpful.

Phillip Susi (psusi) wrote :

Is your PS/2 keyboard also plugged into the wrong port?

Scott Zorc (zorcman) wrote :

 Why would anybody think that the PS/2 inputs could magically switch during an Ubuntu upgrade??

 I also had a problem of my PS/2 ports becoming dead after I upgraded to 11.04. My PS/2 keyboard and mouse were useless until after the GRUB had started the Ubuntu OS. I had no control over the GRUB and so my other OS was useless.

 I found that switching to a USB keyboard and mouse solved the problem. It appears that the Legacy (PS/2) inputs on some model computers get over looked by the newer Ubuntu upgrades.

 If you have a PS/2 keyboard and/or mouse it/they are dead during the GRUB segment of start up I'd recommend switching over to USB input devices and see if that doesn't solve the GRUB access problems.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers