package linux-image-2.6.32-30-server 2.6.32-30.59 failed to install/upgrade:

Bug #745427 reported by Wilson Chu on 2011-03-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

failed to upgrade from 9.10 to 10.4 lts

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-30-server 2.6.32-30.59
Regression: Yes
Reproducible: No
ProcVersionSignature: Ubuntu 2.6.31-14.48-server
Uname: Linux 2.6.31-14-server x86_64
AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 2: ls: cannot access /dev/snd/: No such file or directory
AplayDevices: Error: [Errno 2] No such file or directory
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory
Date: Tue Mar 29 19:51:25 2011
ErrorMessage:
 ErrorMessage: subprocess installed post-installation script returned error exit status 1
Frequency: This has only happened once.
Lsusb:
 Bus 001 Device 002: ID 8087:0020
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 003: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
 Bus 002 Device 002: ID 8087:0020
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. PowerEdge T110
PciMultimedia:

ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.31-14-server root=UUID=77c9f8d8-fc3b-4555-8e12-d1cbf61fd047 ro quiet splash
SourcePackage: linux
Title: package linux-image-2.6.32-30-server 2.6.32-30.59 failed to install/upgrade:
dmi.bios.date: 09/11/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.0.4
dmi.board.name: 0X744K
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 17
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.0.4:bd09/11/2009:svnDellInc.:pnPowerEdgeT110:pvr:rvnDellInc.:rn0X744K:rvrA00:cvnDellInc.:ct17:cvr:
dmi.product.name: PowerEdge T110
dmi.sys.vendor: Dell Inc.

Wilson Chu (wilson-chu) wrote :
Brian Murray (brian-murray) wrote :

From VarLogDistupgradeAptterlog.gz:

update-initramfs: Generating /boot/initrd.img-2.6.32-30-server^M
Running postinst hook script /sbin/update-grub.^M
Searching for GRUB installation directory ... found: /boot/grub^M
Searching for default file ... found: /boot/grub/default^M
Testing for an existing GRUB menu.lst file ... ^M
^M
Could not find /boot/grub/menu.lst file. Would you like /boot/grub/menu.lst generated for you? (y/N) ^M
^M
Not creating /boot/grub/menu.lst as you wish^M
^M
User postinst hook script [/sbin/update-grub] exited with value 1^M
dpkg: error processing linux-image-2.6.32-30-server (--configure):^M
 subprocess installed post-installation script returned error exit status 1^M
Setting up libmysqlclient16 (5.1.41-3ubuntu12.10) ...^M

Wilson Chu (wilson-chu) wrote :

9.10 is using grub2. It does not use menu.lst. It uses grub.cfg which was generated automatically.
see: https://help.ubuntu.com/community/Grub2
Looks like the upgrade from 9.10 to 10.4 did not consider grub2 used.

I have to manually update grub.cfg to make the server boot to new kernal.

I tried "apt-get dist-upgrade" before. It also failed with looking for menu.lst and no update to grub.cfg

Wilson Chu (wilson-chu) wrote :

oh, i looked at the wrong place. It seems that the real error was:
dpkg: error processing linux-image-2.6.32-30-server
 subprocess installed post-installation script returned error exit status 1

But what caused it? It's a dell server PowerEdgeT110 and no sound card in it so no /dev/snd.

Brad Figg (brad-figg) on 2011-04-07
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: dist-upgrade
affects: linux (Ubuntu) → grub2 (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers