"Error: file not found" when booting, then boots up anyway

Bug #733836 reported by Florian M. on 2011-03-12
110
This bug affects 24 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

After dist-upgrade to development natty I get an error right after choosing the kernel in Grub2 menu.

Error: file not found

It first seems as if it will not be able to boot, but after a short time (>1min) it continues to boot anyway.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: grub2 (not installed)
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic-pae 2.6.38-rc7
Uname: Linux 2.6.38-6-generic-pae i686
Architecture: i386
Date: Sat Mar 12 14:39:40 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: grub2
UpgradeStatus: Upgraded to natty on 2011-03-12 (0 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Michael Egger (michael-egger) wrote :

This bug affects me as well after a distrubution upgrade from 12.10 to 13.04

$ lsb_release -rd
Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04

$ apt-cache show grub2
Package: grub2
Priority: extra
Section: universe/admin
Installed-Size: 32
Maintainer: Ubuntu Developers
Original-Maintainer: GRUB Maintainers
Architecture: amd64
Version: 2.00-12ubuntu1
Depends: grub-pc (= 2.00-12ubuntu1), grub-common
Filename: pool/universe/g/grub2/grub2_2.00-12ubuntu1_amd64.deb
Size: 2538
MD5sum: bd2867e84bb969fa45fa50b9541cbf74
SHA1: 1e47f9816b6ab85d8da612e6ab8ba393b2ccdaa6
SHA256: b31f8f895c8da4ff4fce3b64ce0dc769fc2401aaa117de065c08dfd00fc6bcef
Description-en: GRand Unified Bootloader, version 2 (dummy package)
 This is a dummy transitional package to handle GRUB 2 upgrades. It can be
 safely removed.
Multi-Arch: foreign
Homepage: http://www.gnu.org/software/grub/
Description-md5: bbb470013d1f2450dba730f10fbd09b4
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu

tags: added: raring
Michael Egger (michael-egger) wrote :
Download full text (7.4 KiB)

The error i get after choosing Ubuntu in grub2 is:

error: file not found.
error: file not found.
error: file not found.
Press any key to continue ...

here is my grub.cfg:

$ cat grub.cfg
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="0"

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_msdos
insmod ext2
set root='hd0,msdos2'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2 ea06e8dd-40ce-482a-8dd2-be2b88635892
else
  search --no-floppy --fs-uuid --set=root ea06e8dd-40ce-482a-8dd2-be2b88635892
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_US
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=5
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
if background_color 44,0,30; then
  clear
fi
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
 set gfxpayload="${1}"
 if [ "${1}" = "keep" ]; then
  set vt_handoff=vt.handoff=7
 else
  set vt_handoff=
 fi
}
if [ "${recordfail}" != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
menuentry 'Ubuntu' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-ea06e8dd-40ce-482a-8dd2-be2b88635892' {
recordfail
 load_video
 gfxmode $linux_gfx_mode
 insmod gzio
 insmod part_msdos
 insmod ext2
 set root='hd0,msdos1'
 if [ x$feature_platform_search_hint = xy ]; then
   search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 ...

Read more...

Yep, same here!

Florian M. (flomar) wrote :

I did a fresh install with the daily build of the development branch (Raring 13.04) on 18th of february on a different machine. This ASUS laptop was previously running 12.10 and, to my knockledge, was not affected by this bug. It is still not affected. What machines are you running? I'm on a Thinkpad X200.

Michael Egger (michael-egger) wrote :

Hi Flo!
I'm using a self configurated desktop workstation, but I think the problem is that I have upgraded from precise to quantal and then to the raring dailys. Maybe incompatible old configuration files?

Architecture: amd64
InstallationDate: Installed on 2012-09-19 (142 days ago)
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)

cheers

treizav (treizav) wrote :

Same bug for me (Xubuntu amd64)

Oliver Daudey (4-oliver) wrote :

I had the same problem after upgrading from 12.10 to 13.04 dev. Eventually solved it by manually re-running `grub-install' with the right arguments for my disk. I also noticed that before running this command, my "/boot/grub/"-directory was littered with files and afterwards, only a few remained. Seems like it cleaned up crud from previous installs of Grub and then re-copied and generated the essentials. Hope this helps in debugging this problem.

Lepto (lepto) wrote :

Exact same problem after an upgrade from 12.04 to 12.10.
I was having 3 "Error: file not found" when booting, but it was booting anyway.
After upgrading to 13.04 I had the same 3 errors + "Press any key to continue ..."

And the problem's resolved with Oliver suggestion: run "grub-install" .
Same symptom also, /boot/grub was populated with lots of ".mod" files and few remain after re-running grub-install.

Ross Pert (rosspert) wrote :

I just upgraded to 13.04, same error then loads.

Michael Pentecost (michael-q) wrote :

I just did the upgrade from 12.04 --> 12.10 --> 13.04 and got this issue.

I fixed it by the suggestion here, to run grub-install.
For my system, I did:

> df

I found that my root partition was on sda1 - and as I only have one HDD, I know it's sda now.

> sudo grub-install /dev/sda
> sudo update-grub
> sudo reboot

More info on installing/reinstalling grub: https://help.ubuntu.com/community/Grub2/Installing

Dav Clark (davclark) wrote :

the grub-install fixes those messages for me (though my system is still not initializing graphics properly! after the 12.10->13.04 upgrade).

Diego (gran-diego) wrote :

grub-install solved the bug

David Tombs (dgtombs) wrote :

I also got this on 12.10 -> 13.04 update, and grub-install && update-grub fixed it for me.

Glenn Galfano (ggalfano) wrote :

the grub-install solved the bug for me.

Torsten Casselt (blu2lz) wrote :

The bug report was opened for natty and it seems that a grub-install fixes this for everyone and for later releases, too.

This seems to be an issue only after upgrades and is no real problem because the system continues to boot after a key press.

grub-install also fixes this for me after jumping from 12.04 ( - 12.10 - 13.04 ) - 13.10.

Changed in grub2 (Ubuntu):
status: Confirmed → Invalid
Brant Gardner (brantcgardner) wrote :

The grub-install/update-grub solution fixes this for me, too. I started getting this message after upgrading 12.10 -> 13.04 -> 13.10.

Philippe Le Toquin (ppmt) wrote :

I just did an update from 12.04 to 14.04 and I am now having the same issue

I get the error 3 times and after a few seconds the laptop boot properly

I tried to run grub-install but I get that error

grub-install: error: /usr/lib/grub/i386-pc/modinfo.sh doesn't exist. Please specify --target or --directory.

I have Ubuntu 64 bits so not sure why it refers to i386

in any case that directory is not present on my laptop. Instead I have:

grub-mkconfig_lib
 x86_64-efi

ls-al
total 64
drwxr-xr-x 4 root root 4096 May 30 01:13 .
drwxr-xr-x 187 root root 20480 Aug 15 09:19 ..
lrwxrwxrwx 1 root root 34 May 15 20:03 grub-mkconfig_lib -> ../../share/grub/grub-mkconfig_lib
drwxr-xr-x 2 root root 36864 May 30 01:13 x86_64-efi

Strange thing is that my laptop is not efi

David Tombs (dgtombs) wrote :

Philippe, I'm sorry this reply is so late but your issue seems to be more unique. I recommend trying a support venue like Ubuntu Forums if you haven't found a solution already.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Problem still occuring with fresh install of U 14.04 on 11/14.

George Inman (ghinman) wrote :

            --- Nov 2015 had (Ubuntu 14.04, dual boot Win10 ,Acer Aspire XC-605)
error: file not found.
error: file not found.
error: file not found.
Press any key to continue ...
      Just before boot of Ubuntu

   Found a fix here -
https://www.kubuntuforums.net/showthread.php?63221-Grub-errors-quot-File-Not-Found-quot-repeated-three-times

                                  The Following lines From My /boot/grub/grub.cfg
function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb Not Found
    insmod vbe Not found
    insmod vga Not Found
    insmod video_bochs
    insmod video_cirrus
                Three were not found in /boot/grub/ (using Search in nautilus)
 Used gksudo gedit /etc/grub.d/00_header - And commented them out
 Then sudo update-grub
            This fixed it

Sasa Stamenkovic (umpirsky) wrote :

I have exact same problem after installing 16.04 using this procedure https://gist.github.com/umpirsky/6ee1f870e759815333c8

I guess this line:

grub-install --boot-directory=/boot --bootloader-id=Ubuntu --target=x86_64-efi --efi-directory=/boot/efi --recheck

is critical. If anyone has idea how to fix it, that would be highly appreciated.

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers