Comment 10 for bug 718670

This bug is not related with grub.d scripts nor 'Previous Linux versions' submenu. GRUB does not propagate the superusers variable to any submenu.

I think that is preferable to set a local variable by menu and submenu instead of a global variable. In Debian/Ubuntu, no superusers variable is defined by default, so the administrator must be aware to include autorization rights in all submenus.

In this case, it's needed to modify the "10_linux" script to include superusers variable into 'Previous Linux versions' submenu.