unreadable black-on-black text with details plugin

Bug #700686 reported by ZeroBeat on 2011-01-09
30
This bug affects 11 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
High
Colin Watson
Natty
High
Colin Watson

Bug Description

Binary package hint: plymouth

I dont' know wether it's a bug in plymouth or a bug in grub.
Setting /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to GRUB_CMDLINE_LINUX_DEFAULT=""
or to GRUB_CMDLINE_LINUX_DEFAULT="noplymouth"
causes an unreadable boot-message. Maybe black letters on black background???
Take a look at attached picture
Best regards
Mike

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: plymouth 0.8.2-2ubuntu8
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun Jan 9 16:19:32 2011
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110109)
MachineType: System manufacturer System Product Name
ProcEnviron:
 LANGUAGE=de_DE:de:en_GB:en
 LANG=de_DE.UTF-8
 LC_MESSAGES=de_DE.utf8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic root=UUID=e098c2b6-1a19-43d6-9343-80ffbd843c48 ro vt.handoff=7 noplymouth
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
dmi.bios.date: 02/25/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2208
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5Q
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2208:bd02/25/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5Q:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

ZeroBeat (zerobeat) wrote :
Steve Langasek (vorlon) on 2011-01-09
summary: - plymouth ignores "noplymouth" in grub
+ unreadable black-on-black text with details plugin
Changed in plymouth (Ubuntu):
importance: Undecided → High
Colin Watson (cjwatson) on 2011-01-21
Changed in plymouth (Ubuntu Natty):
status: New → Confirmed
Colin Watson (cjwatson) wrote :

This is a bug in our grub2 packaging; we shouldn't include vt.handoff=7 if splash isn't going to be used.

affects: plymouth (Ubuntu Natty) → grub2 (Ubuntu Natty)
Changed in grub2 (Ubuntu Natty):
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.99~rc1-1ubuntu2

---------------
grub2 (1.99~rc1-1ubuntu2) natty; urgency=low

  * Don't add vt.handoff=7 if splash isn't going to be used (LP: #700686).
 -- Colin Watson <email address hidden> Fri, 21 Jan 2011 14:43:05 +0000

Changed in grub2 (Ubuntu Natty):
status: Triaged → Fix Released
ZeroBeat (zerobeat) wrote :

Well done. Everything works fine. Alle status-messages are shown (white on black).
Best regards
Mike

I seem to still be experiencing this problem. I installed a command-line only system with the Natty amd64 Beta 2 alternate CD, and when I booted up all I saw was a blinking cursor at the upper-left corner of the screen. Ctrl+Alt+Fn where n is in the range 1..6 all gave me usable virtual terminals, but Ctrl+Alt+F7 brought me back to the blank screen with the blinking cursor and no text that was present after booting. I checked the configuration file and found that vt.handoff=7 was still there.

I'm tempted to mark this bug as New, but I'm thinking that perhaps additional information will be requested of me, so I'll wait a bit first to see if anyone requests it and/or marks this as New or Incomplete.

I am now installing the package lubuntu-desktop on that system, so that I can get a Lubuntu 11.04 Natty amd64 Beta 1 system. However, I would be pleased to reproduce this in a virtual machine or, if I cannot, on that same physical machine with a new fresh install, if any additional information that I can gather and provide is necessary or helpful.

Eliah, perhaps you could file a new bug instead of reopening this one.
If you use 'ubuntu-bug grub-pc', it should attach all the necessary
information.

I have filed bug 761830 for this. Please note the strong similarities between that bug and bug 695658 (which is considered to be a duplicate of this bug).

Michael Zhou (zhoumotongxue008) wrote :

Also, if we've followed this solution: http://idyllictux.wordpress.com/2010/04/26/lucidubuntu-10-04-high-resolution-plymouth-virtual-terminal-for-atinvidia-cards-with-proprietaryrestricted-driver/ to get high-resolution boot splash in 10.04 or 10.10, the "vt.handoff=7" will prevent the splash from showing up. Hence it needs to be removed from /etc/grub.d/10_linux.

Greg Williams (greg2lapa) wrote :

This bug is occurring on Vivid Vervet (ubuntu 15.04) installs using the mini.iso. Is this a regression?

1) create CD with mini.iso and boot from CD
2) select the first option: Install
3) select "No automatic updates"
4) select "Manual package selection"
5) first boot yields a blank, black screen.

tags: added: grub2 mini.io
no longer affects: grub (Ubuntu Natty)
Greg Williams (greg2lapa) wrote :

How do you add Vivid under the "Affects" heading at the top?

Colin Watson (cjwatson) on 2015-10-05
no longer affects: grub (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions