natty: memtest86+ fails to run, reboots immediately

Bug #683904 reported by Paul Sladen on 2010-12-01
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
grub2 (Ubuntu)
High
Colin Watson
Natty
High
Colin Watson

Bug Description

Binary package hint: memtest86+

Natty: memtest86+ 4.10-1.1ubuntu1

Selecting 'memtest86+' causes the machine to reboot after a couple of seconds and does not load.

iRon (theoneandonlyron) wrote :

I can confirm this, but I think the bug affects GRUB more than memtest86+, because I can run the natty memtest with an old GRUB version (1.98+20100804-5ubuntu3).

Changed in memtest86+ (Ubuntu):
status: New → Confirmed
Changed in memtest86+ (Ubuntu):
importance: Undecided → High
Brian Murray (brian-murray) wrote :

I was unable to recreate this on a freshly installed Natty virtual machine with only Ubuntu installed. However, on a dual boot system (Windows and Ubuntu) that has been running Natty since December or so I was able to recreate this.

The grub menu entries on both systems look identical except for different root settings.

Changed in memtest86+ (Ubuntu Natty):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Charlie Kravetz (charlie-tca) wrote :

I can reproduce this issue using a fresh Natty Narwhal Beta1 installation on hardware. The system is a 2.8 GHz P4; 768MB RAM; ATI Radeon 9800 w/128MB. Starting the system and selecting Memory test (memtest86+) from the GRUB version 1.99~rc1-6ubuntu1 results in an immediate reboot of the computer. It seems the memory test does not even start.

gohai (gottfried-haider) wrote :

Also happens for me on 64-bit Natty Narwhal Beta1 on a Thinkpad x120e. The system has a AMD Zacate E-350 core and 4 GB of RAM. I get a reboot one or two seconds after selecting memtest86+ from grub menu (no output on screen).

Kurt (kurtbcox) wrote :

This happens for me on a fresh Natty 64-bit install on an Acer Extensa 5620Z with 2G of RAM and an Intel(R) Pentium(R) Dual CPU T2330 @ 1.60GHz

Michael Vogt (mvo) wrote :

This seems to be working quite well in a VM for me, trying it on real HW now.

Michael Vogt (mvo) wrote :

I can confirm comment #1, grub2 from maverick boots into memtest86+ fine, the one in natty does not anymore.

affects: memtest86+ (Ubuntu Natty) → grub2 (Ubuntu Natty)
Michael Vogt (mvo) wrote :

I looked at the code for this and there is quite a bit of churn between the maverick and the natty version. It appears that the whole linux16 command (that is the command that loads memtest86+) got rewriten from assembler to C. The fact that it works fine in qemu/kvm but not on real HW indicates it might be something subtle with the generated assembly.

Colin Watson (cjwatson) wrote :

I've reproduced this in qemu, although only on one machine.

Colin Watson (cjwatson) wrote :

... and on that machine, it fails with qemu but succeeds with 'qemu -no-kvm'. Hmm. That might not be the same bug, then ...

Colin Watson (cjwatson) wrote :

I win.

Changed in grub2 (Ubuntu Natty):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
status: Confirmed → Fix Committed
Colin Watson (cjwatson) on 2011-04-20
Changed in ubuntu-release-notes:
status: New → Invalid
Colin Watson (cjwatson) on 2011-04-20
Changed in grub2 (Ubuntu Natty):
milestone: none → ubuntu-11.04
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.99~rc1-13ubuntu2

---------------
grub2 (1.99~rc1-13ubuntu2) natty; urgency=low

  [ Stéphane Graber ]
  * Update default/grub.md5sum to include maverick's default md5sum to avoid
    prompt during update (LP: #759545).

  [ Colin Watson ]
  * Cherry-pick from upstream:
    - Support huge btrfs chunks.
    - Fix stack pointer handling in 16-bit relocator (LP: #683904).
 -- Colin Watson <email address hidden> Thu, 21 Apr 2011 00:11:40 +0100

Changed in grub2 (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers