10.04.1 LTS Grub gives message error: out of disk

Bug #634639 reported by Bananabob on 2010-09-10
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

I installed 10.04.1 LTS and have been getting "error: out of disk" messages on a "Cold Boot". That is one where you have to switch the PC on. It will boot, however if you push the "restart" button.

Using the information in this post http://ubuntuforums.org/showthread.php?t=1195275 I have been able to get more information about this bug
.
I reinstalled 10.04.1 LTS and tried this http://sourceforge.net/apps/mediawiki/bootinfoscript/index.php?title=Boot_Problems:write
This isn't the problem because the grub.cfg no longer contains those lines
.
So I tried removing the "search --no-floppy" from grub-mkconfig_lib as per http://sourceforge.net/apps/mediawiki/bootinfoscript/index.php?title=Boot_Problems:search

That didn't work. I got the following results:

On a "restart" the system will boot.
On a "Cold Boot" the system still gives the error: "out of disk" message

I am left thinking that the code for a "restart" follows a different path than the code for a "cold boot", hence the reason a "restart" works. The other option is that the hard drive has not reached full speed by the time a read is required during a "cold boot"
.
Either way this is a major bug.

This install was on a system using just SATA drives. I have installed 10.04.1 LTS on a system using IDE drives. Maybe that is another clue to finding out what is causing this bug.

I can not move forward with 10.04.1 LTS until this bug is fixed. Not what one expects from a LTS release.

I have also posted this in an old bug report #477430

wmwmwm (index-html) wrote :

I'm experiencing the EXACTLY same problem with my pc second time.

I'm experiencing this issue with 320GB Seagate 7200 - Sata HDD and 1TB Seagate 7200 Sata HDD. (I've tested with clean install)

But it works with my old 120GB Seagate 7200 Sata HDD on same machine.

Also bios might be causing the problems, i don't really know.

Fabián Rodríguez (magicfab) wrote :

When filing a bug please always try to use:
ubuntu-bug <package>

That way relevant information is attached, otherwise there's only a slim chance someone can help. For this bug:
ubuntu-bug grub2

Now this bug has been opened, you can still submit relevant information, just do:
apport-collect 634639

Can you also reproduce this but with the latest Maverick installer ? That would also help isolate the cause.

Bananabob (bananabob) wrote :

I have reported this with 10.10 RC https://bugs.launchpad.net/bugs/654821

Bananabob (bananabob) wrote :

I have now tried to use Linux Mint Debian Edition to see if this problem is a Ubuntu of a Grub2 problem. I can report that the problem exists with LMDE as well. Therefore I assume this is a Grub2 problem.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Bananabob (bananabob) wrote :

I have had the same problem for ages. I recently updated my bios so that it would recognize the 1TB disk correctly, as per this post
http://comments.gmane.org/gmane.comp.boot-loaders.grub.bugs/8433

The bios now does recognize the 1TB disk correctly but the PC will still not boot from the 1TB disk on a "cold" boot, but after the PC has been booted from another drive, I can do a reboot from the 1TB drive no problems.

It would appear from this that the problem is with GRUB 2 and not with the BIOS.

Why is this taking so long to get fixed?

James

Phillip Susi (psusi) wrote :

Please see the bug report this has been marked as a duplicate of for instructions on how to remove the HPA from the drive.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers