early grub freeze with USB mouse connected (Thinkpad W510)

Bug #631208 reported by Joshua R. Poulson on 2010-09-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub-pc

After upgrading from Lucid to Maverick Beta, if my Razer Orochi USB mouse is connected grub will freeze in early startup (leaving the "Thinkpad" logo on the screen). Removing the mouse and forcing a power down will allow grub to boot normally.

This worked fine with the grub from Lucid, only after upgrading to Maverick beta did this happen.

Long ago I had a similar problem but it was fixed by Thinkpad BIOS. It could be the new grub has surfaced a new BIOS issue for the Thinkpad W510.

$ lsb_release -rd
Description: Ubuntu maverick (development branch)
Release: 10.10

$ apt-cache policy grub-pc
grub-pc:
  Installed: 1.98+20100804-4ubuntu4
  Candidate: 1.98+20100804-4ubuntu4
  Version table:
 *** 1.98+20100804-4ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

dazza5000 (darran-kelinske) wrote :

this is most likely a w510 issue/support question rather than an issue with grub - don't think the lappy is even making it to grub

http://forum.lenovo.com/t5/W-Series-ThinkPad-Laptops/W510-lockup-on-startup/td-p/210630

Joshua R. Poulson (jrp) wrote :

The thread you linked to is an older problem that was solved with a Thinkpad BIOS update months ago for me. It has been working fine, but started happening again when I went from Lucid to Maverick (literally, starting on the boot after downloading and applying the distribution upgrade).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers