Plymouth thinks my display is VGA

Bug #617363 reported by Per Moller on 2010-08-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: plymouth

I'm on an old ThinkPad: R30. Ubuntu 10.04 and previous have shown my full screen (XGA) during boot but since 10.10 the boot sequence only uses VGA (800x600)

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: plymouth 0.8.2-2ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-14.20-generic 2.6.35
Uname: Linux 2.6.35-14-generic i686
Architecture: i386
Date: Fri Aug 13 14:10:16 2010
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: IBM 2656E2G
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-14-generic root=UUID=c328794f-57ff-48e8-ab1f-d9a4436f6050 ro quiet splash
ProcEnviron:
 LANG=da_DK.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
dmi.bios.date: 08/29/2006
dmi.bios.vendor: IBM
dmi.bios.version: 1CETF0WW (1.40)
dmi.board.name: 2656E2G
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information��������������
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnIBM:bvr1CETF0WW(1.40):bd08/29/2006:svnIBM:pn2656E2G:pvrNotAvailable:rvnIBM:rn2656E2G:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
dmi.product.name: 2656E2G
dmi.product.version: Not Available
dmi.sys.vendor: IBM

Per Moller (per-moller) wrote :
Per Moller (per-moller) wrote :

I wrote VGA but I think it is 600*480 (checked /etc/default/grub) - I can see that dmesg og lspci reports a VGA card but the Triden card is XGA and I run Gnome at 1024*768 with no problems

Steve Langasek (vorlon) wrote :

Thank you for taking the time to report this bug and help to improve Ubuntu.

plymouth can only use the framebuffer device that the kernel makes available to it. Since in your case this is shown to be "ProcFB: 0 VESA VGA", the graphics will be rendered accordingly.

There is some work in progress for Ubuntu 10.10 to let plymouth pick up a framebuffer directly from the bootloader, and the behavior change you're seeing may be fallout from this. Reassigning to the grub2 package as a result, the issue will lie either there or with the kernel

affects: plymouth (Ubuntu) → grub2 (Ubuntu)
Changed in grub2 (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Per Moller (per-moller) wrote :

Thanks for explaining - how couls i create a workaround (Sorry I am a Linux newbie)

Fabián Rodríguez (magicfab) wrote :

Hi Per,

Perhaps the startupmanager package may help generate the appropriate splash screen in the right resolution. I lack time to explain this but it's worked for me in several configurations. Perhaps try this on a test VM or system and let us know.

Per Moller (per-moller) wrote :

Thx to Fabián for trying -
I installed the startupmanager and configured it for the proper resolution and splash and text, but it didn't help - yet. I'll try again

Per Moller (per-moller) wrote :

Solved - after installing Natty the problem dissapeared

Per Moller (per-moller) wrote :

Please close this bug - not interresting any more

Clasing the bug.

Changed in grub2 (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers