Ubuntu

Kernel Panic - not syncing: VFS: Unable to mount root fs on Unknown-block(0,0).

Reported by cwsupport on 2010-06-07
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub

Situation
Description
Downloaded Ubuntu Server CD i386. Checked and verified as OK.
After install, reboot. GRUB complains about the floppy risk. (fd0 read error) Clears screen. [~3.4] Kernel Panic - not syncing: VFS: Unable to mount root fs on Unknown-block(0,0).

Install Karmic Koala 9.10. All OK. Install Lucid. Panics on reboot at end of install. Install Karmic Koala 9.10 All OK.

System Information
 Bootable LVM + RAID /md0 - /boot 1GB /md1 - LVM (partitions for root, tmp, swap, home etc) rest of 160GB disk.
 AMD Athlon XP2800+

cwsupport (netsupport) wrote :

I should comment further.
We have tried 3 test systems and the results are the same on all of them eliminating specific hardware as an issue. (Karmic works perfectly on all 3 as well).
As these systems represent test versions of our live servers we are unable to take Lucid Lynx as an operating system unless the install CD is corrected/correctable. We are now planning our long term support for Karmic...
This is incredibly disappointing and we have seen this bug with Jaunty - hence we never took Jaunty. (Hardy worked, Intrepid worked, Karmic works).
Interestingly enough we have one report of Kubuntu Desktop Alternate for 10.04 LTS Lucid *works* on the same hardware. However an install of Ubuntu Server on the same hardware fails.

Steve Langasek (vorlon) on 2010-06-07
affects: grub (Ubuntu) → grub2 (Ubuntu)

Just tried an upgrade from 8.04 to 10.04.1 using do-release-upgrade and the server is unable to boot. I am not running raid, but this is a virtual machine on Enterprise vmware VMX. Getting the same error message: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0).

Loïc Minier (lool) wrote :

I have / on LVM on RAID10 on GPT partitions, and could upgrade from karmic to lucid just fine.

Perhaps you could start by attaching your upgrade logs (/var/log/dist-upgrade) so that we can see where there's a difference?

The subject of this bug:
Kernel Panic - not syncing: VFS: Unable to mount root fs on Unknown-block(0,0).
is a VERY generic one and could happen in a large number of situations; JacobSteelsmith, you probably want to file a distinct bug reports with your logs too.

Roland Dreier (roland.dreier) wrote :

I also have 10.04 running with all filesystems including / on LVM on RAID1 with no problem. There definitely are some things to watch out for, for example the MD superblock is stored at the end of a partition, so if you have an md partition that extends too close to the end of the disk, md might get confused and think your whole disk is part of a RAID array, which could lead to the problems you see. (The solution is to leave the last 64K of your disk out of any md partitions)

To solve this problem we would need more details about the specific config and also full kernel logs would help -- if you can edit out the "quiet" in your kernel command line in grub and capture and post the output, that would help a lot in figuring out what the problem is for you.

korgman (korgie) wrote :

I switched to lilo and it works fine.

I have the impression that the problem is occurred because the installation was not created a initramdisk.

The solution for me was:
1. manually installed lilo
2. manually created /etc/lilo.conf
3. manually created initrd with mkinitramfs
4. run lilo.

Everything with chroot environment. Unfortunately I didn't have the time to test / configure grub with my manually created initrd. I realized that after updating with security patches, the installer normally created the initramdisks.

nicoelba (nicoelba) wrote :

Hi! I've upgraded my Xubuntu 10.04 last evening, and now I've this error.. I've also other error, like :
error: no suitable mode found
error: unknown command 'terminal'
error: couldn't read file [0.973676] Kernel panic .... etc

I've followed the suggestion found in http://ubuntuforums.org/archive/index.php/t-1471399.html but I haven't fixed any problem.. What I've to do? My PC is an old Pentium 3 with a 6 Gb HD.. and before the upgrade was working well..
Thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers