package grub-pc 1.98-1ubuntu6 failed to install/upgrade: subprocess installed post-installation script returned error exit status 10

Bug #576798 reported by Shoaib Mirza on 2010-05-07
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

package grub-pc 1.98-1ubuntu6 failed to install/upgrade: subprocess installed post-installation script returned error exit status 10

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: grub-pc 1.98-1ubuntu6
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
Architecture: i386
Date: Fri May 7 10:16:33 2010
ErrorMessage: subprocess installed post-installation script returned error exit status 10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
SourcePackage: grub2
Title: package grub-pc 1.98-1ubuntu6 failed to install/upgrade: subprocess installed post-installation script returned error exit status 10

Shoaib Mirza (monymirza) wrote :
hilbert (hollycat2000) wrote :

Since the first update after installing Ubuntu 10.04 I have the same exit status 10 with any application I install using Synaptic.
After that same first update I also had a problem booting with the installed grub.cfg with the '30_os-prober'. Every entry after that menuentry wasn't read from grub.cfg. After I removed '30_os-prober' menuentry file from /etc/grub booting went without a problem and all entries were shown.
Every install still gives the status 10 message Everything seems to work all right, but it is disturbing.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Peter Wood (peter-pawood) wrote :

I have the same symptoms as hilbert

10.04 - clean install; everything appears to be working OK but all Synaptic installs or apt-get install, etc

Here's an example installing apg:

Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed
  apg
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0B/53.2kB of archives.
After this operation, 209kB of additional disk space will be used.
Selecting previously deselected package apg.

(Reading database ...

dpkg: warning: files list file for package `gnome-power-manager' missing, assuming package has no files currently installed.

... and so on for many packages from line 12 until line 2332 finally ....

(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 38406 files and directories currently installed.)

Unpacking apg (from .../apg_2.2.3.dfsg.1-2_i386.deb) ...

Processing triggers for man-db ...

Setting up grub-pc (1.98-1ubuntu6) ...

dpkg: error processing grub-pc (--configure):

 subprocess installed post-installation script returned error exit status 10

Setting up apg (2.2.3.dfsg.1-2) ...

Errors were encountered while processing:

 grub-pc

Francisco Maia (amaia) wrote :

I have the same problem here.
I can't "aptitude safe-upgrade" my system because the error always shows up.

Is there a solution for this?

J B (scottie) wrote :

Same here.... Using leeenux v4... (ubuntu netbook edition? 10.04) can't update. Tried purging grub-pc and reinstall, to no avail.

J B (scottie) wrote :

had also updated to all the recent versions.. everything installed... and then i couldnt boot up my computer... ran some commands to update initramfs etc from internet search... finally got into the OS.

now just couldnt update...

maybe would have to purge grub, update and then reinstall grub everytime?

J B (scottie) wrote :

oh yeah it was udev error after the first update (after installation of leeenux) on bootup....

similar to https://bugs.launchpad.net/ubuntu/+source/devmapper/+bug/358654

tried the commands provided on the above link using livecd... now OS boots up, but dpkg / grub-pc error on apt-get and update manager. Same as the title on this launchpad bug.

J B (scottie) wrote :

never mind about reinstalling grub for updates... looks like new updates get installed in spite of the grub error. i'm assuming this since no more updates appear on Update Manager.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers