Ubuntu

Error scanning for fd0 on boot

Reported by Loïc Minier on 2010-04-22
186
This bug affects 35 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

Hi

Since upgrading to lucid and installing the new grub-pc, I get an error on boot before the GRUB screen:
error: fd0 read error.

I don't have a floppy drive, and it's supposedly disabled in the BIOS.

Bye,

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: grub-pc 1.98-1ubuntu5
ProcVersionSignature: Ubuntu 2.6.32-21.32-server 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-server x86_64
Architecture: amd64
Date: Fri Apr 23 00:21:52 2010
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: grub2

Loïc Minier (lool) wrote :
Loïc Minier (lool) wrote :

Steps to debug this:
* edit /usr/sbin/grub-install to land some code in load.cfg
* the code should be "set debug=disk" or "set debug=all"
* also add option to padd -c load.cfg in the case where it's an abstracted device

This should turn on debug in grub2 and should explain why floppy is probed.

Loïc Minier (lool) wrote :

Might also be the BIOS booting the (failed) drive carrying and old mbr.

Simply disabling the floppy in the BIOS fixed it for me.

I also observed the message "error: fd0 read error." on my intel core duo laptop. I was also able to make it go away by disabling legacy FDD emulation in the BIOS. (In my Toshiba QOSMIO BIOS, the entry is "USB-FDD Legacy Emulation". No floppy is connected.)

I confirmed that the message was being generated by grub2 by changing the message string in disk/i386/pc/biosdisk.c and observing that the message changed.

The presence of the message does not appear to delay or interfere with the presentation of the grub2 menu, which appears shortly afterward, and from which booting proceeds normally.

System: Toshiba QOSMIO G35-AV650
Distro: Ubuntu 10.04 RC (upgraded from 9.10)
Package: grub-pc 1.98-1ubuntu5
uname -a: Linux localhost 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 i686 GNU/Linux

On Wed, 2010-04-28 at 20:56 +0000, Sean Sheedy wrote:
>
> The presence of the message does not appear to delay or interfere with
> the presentation of the grub2 menu, which appears shortly afterward, and
> from which booting proceeds normally.

It was delaying it here about 5-10 seconds. Just enough to be annoying
through a number of reboot cycles.

jmp7 (jacobopantoja-yahoo) wrote :

I'm suffering it too. I also suffer the 5-10 seconds delay when the message appears.
- When I disable BIOS option (Legacy FDD), the message dissapears (but due to a bios bug, the system refuses to start sometimes when I disable the option!)
- I've tried grub-install --no-floppy several times, re-created the device.map file without floppy and saw the grub-install debug output, and there is no trace about "fd0" nor "floppy" anywhere.

It seems to be a problem in grub, maybe in the way to search for the grub.cfg file.

Changed in grub2 (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Changed in grub2 (Ubuntu):
assignee: Colin Watson (cjwatson) → nobody
mtu (mtu) wrote :

- grep'ing /etc/grub.d/ for "fd0" yields no results, so the problem probably doesn't lie there.
- disabling my FDD is not an option for me, because I want to _use_ it (just not at boot)

mtu (mtu) wrote :

Apparently, this affects Debian as well and has been recognized about half a year ago, but I can't seem to find out if it's been fixed.

http://<email address hidden>/msg767224.html

Lupe Christoph (lupe) wrote :

The message seems to be generated in /boot/grub/biosdisk.mod from this format string:

%s read error

And it *is* probing an empty floppy drive. I only get this error since I enabled the floppy controller to be able to read some ancient software from floppies. I forgot to test with a medium in the drive. But the message will probably go away.

Does GRUB2 think it is running from that floppy? I see no other reason why GRUB2 would read the floppy except when it thinks it is a hard disk. But then I don't understand why it is referring to fd0 instead of hd<n>.

mtu (mtu) wrote :

@Lupe Christoph:
See the link I posted: http://<email address hidden>/msg767224.html

Vladimir Serbinenko, apparently a grub developer, says there:
> Actually the problem in this bug reports is lvm and mdraid. The problem
> is that some BIOSes expose USB HDD as floppy. So not scanning for them
> may cause to "lose" some lvm or raids. I'm thinking about clean
> solution. Suggestions are welcome

That was in March 2010. It doesn't seem like there's been a solution yet.

Today I did a clean install from the Kubuntu 11.04 DVD on a brand new PC. Custom RAID partitioning of two SATA HDDs, and at startup after BIOS I get a long pause (30s or more) followed by the same error, “error: fd0 read error.” on the screen for many seconds, probably a minute or more, before the system boots. I _do_ have a floppy drive connected! First SATA HDD is configured as first boot device, grub installed on MBR of that drive.

This delay is pretty annoying!

Peter Errity (perrity) wrote :

Same problem on Lucid server but I think I caused it

The boot was clean until I installed 2tb drives and messed up (I think).

I recently set up a Dell Precision 390 (no floppy) with two WD 80Gb disks with three partitions (swap root and userspace) in raid 1 under MD

Everything was fine until tried to upgrade the disks to Samsung 2TB
I cloned the a and b 80GB disks using ddrescue to the new 2TB ones and physically swapped them in (partitions are currently as per the original 80Gb i.e. only using partitions up to 80 of the 2000 Gb available)

On boot there was a serious hiccup re file system that I couldn't capture but it was prompting 'I to ignore' or 'F to fix' so I opted for F and the machine rebooted and came up.

On checking the system after reboot I noticed that mdadm was reporting the sd devices in reverse order to what they were
eg. md1 : active raid1 sdb2[0] sda2[1] when it used to be md1 : active raid1 sda2[0] sdb2[1]

I figured I had mixed up the two devices and decided to simply swap them around again and cross my fingers.

Sure enough the machine hiccuped again on reboot with the same (am assuming) hiccup and with the same options for I or F
I used F again but this time I had to reboot before several times before is sorted itself out.

Machine up again and running and reporting all but one of the MD devices as it used to.
Using mdadm -- manage fail and add I dropped the b drive paritions completely rebooted the machine and it started a rebuild on the two 'normal' partitions automatically when they finished I simply added the third one manually and all appears right now.

Somewhere in all of that the machine started giving 'error: fd0' + 'invalid environment' while booting but I wasn't too bothered because I thought it would go when I got the raids sorted out but it now appears to be a permanent feature though it only flashes up and causes minimal (if any) delay. As the machine is normally headless it wont be noticed but I would like to know if the error could turn critical at some point (before I start using it in earnest as a file server)?

Based on this post
I checked the bios diskette setting which was set to 'USB floppy drives are enabled' and changed it to 'off' but error message still appearing.
I also turned off SMART reporting and the error persists

Hope this helps - if I there are logs that would be of use let me know where I will post them or filtered versions..

Changed in grub2 (Ubuntu):
status: New → Confirmed
Joseph Griffin (overacliff) wrote :

Bought a Zotac Zbox for home internal gateway. Initial install no problems. When attempting to re-install, Zbox will not boot off USB - get the 'error fd0 read error'. Turned off USB legacy support and it ignores USB all together. Order a USB DVD drive as a work around. I have noticed the error on Vmware 7.1 w/ 32 Ubuntu Server 11.10 also, but it loads w/o issues.

rpr nospam (rpr-nospam) wrote :

I had this problem on Ubuntu 11.10 64-bit with grub-pc 1.99-12ubuntu5.
The PC has a Gigabyte board with Award BIOS v 6.00PG.

The workaround suggested above worked -- I disabled FDD in BIOS:
Standard CMOS Features -> Drive A: None

Jason (jasonxh) wrote :

Have the same issue here. In my case though, it's not a floppy drive, it's my USB multi-card reader, which doesn't have any cards in it actually. I guess my BIOS is emulating those card slots as floppy drives, yet I don't see a way to disable it. I would really like to force GRUB or LVM to ignore any such devices. Waiting an extra 10 seconds is not fun.

Felix (qqq) wrote :

I can add a bit of seriousness here:

On booting I'm getting

errors: fd0: read error
errors: fd1: read error

If I remove my "USB 2.0 Card Reader 35 in 1" the read errors on booting disappear. There is only one bootable device in the bios, an SSD drive, on sda. When I set up the system this morning it was asking for a password on bootup as it should, /, /home and swap are all encryped. Now it boots straight on to an encryped disk without asking for a password whether the card reader is attached or not. Had to try it several times before I believed it. 10 second delay on booting?

Ubuntu 12.04 32-bit

Belfry (es4477) wrote :

Same thing on Precise with Grub2 1.99-21ubuntu3.4. This appears to be due to Grub2 searching an lvm partition for unicode.pf2. Here's a workaround for those using a separate, non-lvm /boot partition. Note: I am not sure if this will work with other distributions or Grub2 versions.

1) sudo cp /usr/share/grub/unicode.pf2 /boot
2) cp /etc/grub.d/00_header ~/00_header_backup
3) gksudo gedit /etc/grub.d/00_header: replace all ${GRUB_FONT_PATH} with /boot/unicode.pf2
4) sudo update-grub

the fd0 message disappers after disabling the floppy drive but the ubuntu does not start at all. the pink screen appears for 10 minutesa nd it goes black again..................

Phillip Susi (psusi) wrote :

Loic, are you quite sure you disabled the floppy in the bios, and did you ever collect the debug output?

Changed in grub2 (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for grub2 (Ubuntu) because there has been no activity for 60 days.]

Changed in grub2 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers