Ubuntu

After upgrade grub doesn't work anymore

Reported by Dario Bertini on 2010-04-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

my system is a 64bit lucid wubi install.

Yesterday i upgraded from karmic to lucid...

The upgrade process went wrong ...it's a problem similar to the one these people encountered:
http://ubuntuforums.org/showthread.php?t=1450929
http://ubuntuforums.org/showthread.php?t=1449955
(eventually after having a bootable system again i'll file a bug report)

so i needed to do a partial upgrade...

the grub debconf asked where to install the bootloader (i selected /dev/sda )

at the end i rebooted, and the system booted up fine (except for an unrelated problem with the ati proprietary graphics)

then i rebooted in windows, where i removed the temporary boot.disk i created to workaround this karmic bug: https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/477104 (this wasn't needed anymore, since i only loaded it manually via the grub shell before upgrading to lucid)

now, when i try to boot ubuntu, it starts loading grub2 and grub.cfg fine: it shows the countdown...

but after the countdown, or if i press the ESC button to show the menu, the screen output disappears, and then the system reboots itself

this is quite strange... since grub2 was already booting, but upon trying to show the grub menu it failed...

after this i loaded with a livecd and chrooted into the loopback system, where i tried an update-grub, but it didn't work...

after this i tried again with grub-install (i used `grub-install --force /host/ubuntu/disks/root.disk` ...to obtain /host i manually `mount --bind`ed the windows partition ), but it still doesn't work

the problem seems relatively similar to this bug: https://bugs.launchpad.net/ubuntu/lucid/+source/grub2/+bug/508173
but i'm reporting this a new one because for that bug reinstalling grub solved the issue and it doesn't deal with a wubi system like mine

Dario Bertini (berdario) on 2010-04-11
summary: - After upgrade grub don't work anymore
+ After upgrade grub doesn't work anymore
Dario Bertini (berdario) wrote :
Dario Bertini (berdario) wrote :
Dario Bertini (berdario) wrote :
Dario Bertini (berdario) wrote :
Dario Bertini (berdario) wrote :
Dario Bertini (berdario) wrote :
Dario Bertini (berdario) wrote :
Dario Bertini (berdario) wrote :
Dario Bertini (berdario) wrote :
Dario Bertini (berdario) wrote :
Dario Bertini (berdario) wrote :
Dario Bertini (berdario) wrote :
Dario Bertini (berdario) wrote :

I uploaded some files (booting with a livecd and mounting the loopback disk and fetching the last one from windows) since unfortunately now i won't be able anymore to confirm this bug or get other files: i'm going to reinstall ubuntu

...obviously, if it'll happen again i'll report here any new info

Phillip Susi (psusi) wrote :

If this is still an issue for you, please run the boot info script and attach its results:

http://sourceforge.net/projects/bootinfoscript/

Changed in grub2 (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for grub2 (Ubuntu) because there has been no activity for 60 days.]

Changed in grub2 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers