[grub2] grub fails to load again (in Lucid)

Bug #551721 reported by Miroslav E. Hadzhiev (Хаджиев) on 2010-03-30
66
This bug affects 14 people
Affects Status Importance Assigned to Milestone
grub2 (Debian)
Fix Released
Unknown
grub2 (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by amy
Nominated for Maverick by Miroslav E. Hadzhiev (Хаджиев)

Bug Description

Binary package hint: grub2

ORIGINAL BUG REPORT: https://bugs.launchpad.net/debian/+source/grub2/+bug/441941?comments=all

Maybe the same problem in in Lucid Beta1. After booting Windows my system again was left with useless MBR.

The system message this time is not "GRUB LOADING" as it is in Karmic but:

"no module name found
Aborted. Press any key to exit."

After hitting "Enter" the message: "Non-system disk or disk error replace and strike any key when ready" appears.

The system is totally "unbootable" and there is a need to wipe out or re-install the "correct" (Windows-only) MBR after each boot of Windows (it does not matter if it is XP, Vista or 7, nor if an anti-virus application is used under Windows).

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: grub-pc 1.98-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-17-generic x86_64
Architecture: amd64
Date: Tue Mar 30 14:05:08 2010
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100329)
ProcEnviron:
 LANG=bg_BG.UTF-8
 SHELL=/bin/bash
SourcePackage: grub2

Jeff Lane (bladernr) wrote :

This one just bit me in the ass :-( I'm running Lucid with latest updates as of 2 April 2010. I booted into Windows 7, and after shutting that down, I ended up with the same error as the OP for this bug.

Right now, I'm pulling down a new lucid iso to my other system, hoping I can boot that and restore grub.

This REALLY needs to be addressed somehow. This was never an issue with 9.10, and I've not had this issue at all with Lucid until after the last update... or whenever the last grub2 update was pushed to Lucid.

And if you see the bug listed in post #1, you'll see that this has been an issue with Grub2 intermingling with various things in Windows for dual booters since Ubuntu 9.10.

My hardware is an Alienware M15x (from Dell). I am thinking the offending program on the Windows side is probably going to be the Local Backup software, writing something weird to the first few blocks of the hard disk (It has a 6 block partition that it uses for something) which is interfering with Grub 2.

The older grub, with its smaller footprint at the beginning of the disk did not suffer from this issue... so something needs to be done.

Jeff Lane (bladernr) on 2010-04-05
Changed in grub2 (Ubuntu):
status: New → Confirmed
pippom77 (pippo-nauta) wrote :

Lucid, Dell Studio 1558 with Windows 7 - 64bit

The bug is exaclty the same. I tried the dual boot by Grub 2 with Lucid beta 1 but after antivirus check or sometimes software installation on Windows the message after reboot is "no modue name found" and the computer gets unusable.

I have an HP NX9420 and the bug occurs even when I DO NOT HAVE an anti-virus app, when Windows DO NOT run any updates, it occurs AT EVERY boot-up of Windows and it DOES NOT matter which version of Windows is in use (I have personally tried XP, Vista and 7).

The MBR of the computer and GRUB2 corrupt even when I try to boot Windows with the live-cd of Paragon disk manager (this means that the MBR is corrupted when Windows is not even loaded through GRUB2).

I highly recommend to everybody to install BURG and to overwrite GRUB2 installation.
The bug DOES NOT occur in BURG (which is a re-write of GRUB2). This is the how-to:
http://code.google.com/p/burg/wiki/InstallUbuntu

Kind regards,
Miro Hadzhiev

But you should use this line instead (when installing BURG to the MBR of your system):

sudo burg-install --alt "(hd0)"

I wrote a simple guide in my blog which resembles the aforesaid how-to:
http://syndofyouths.blogspot.com/2010/04/off-topic-i-want-to-address-boot-loader.html

Rich Williamson (spam91403) wrote :

I had the same problem with Beta 1 and Beta 2. Please see:

https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/441941?comments=all

If you found this thread because you are stuck with an unbootable machine like I was, here is what I did to fix it:

Step 1: Restore your MBR:

## boot ubuntu live from CD/USB then do the following:

ALT-F2 gnome-terminal

sudo mount /dev/sda6 /mnt
    <- sda6 on my box. YMMV.
sudo mount --bind /dev /mnt/dev

sudo mount --bind /proc /mnt/proc

sudo mount --bind /sys /mnt/sys

sudo chroot /mnt

sudo grub-mkconfig -o /boot/grub/grub.cfg

sudo grub-install /dev/sda

 ctrl-d

sudo umount /mnt/dev

sudo umount /mnt/proc

sudo umount /mnt/sys

sudo umount /mnt

Step 2: Boot into Windows, run services.msc, and disable the "PC Angel" service.
(This was the root cause on my HP laptop, some people have suggested there are other programs which can cause this problem).

Step 3: Boot computer and repeat Step 1 since booting into Windows on Step 2 re-trashed your MBR.

Sorry for adding one more comment (there is no edit option in Launchpad....) but the guide in my blog is now hosted here:

http://syndofyouths.wordpress.com/2010/04/12/i-want-to-address-the-boot-loader-problem-in-ubuntu-9-10/

Kind regards,
Miro Hadzhiev

I have the same problem, and I would like to add a detail to the previous description: it only happens if I login into Windows.
If I run Windows7 but not login and then reboot, the problem doesn't shows up.

bhoult (bhoult) wrote :

I had the same bug on an alienware (dell) pc. I followed the above link from Giovanni and it seems to be caused by "Dell Datasafe local backup" and "Dell Datasafe local backup support software". I uninstalled those two programs in windows (restored grub again) and have not experienced the issue since.

Sajjad (sajjadkm) wrote :

Confirmed for Lucid.

summary: - [grub2] grub fails to load again (in Lucid Beta1)
+ [grub2] grub fails to load again (in Lucid)
tags: added: i386
wombat (jewett-aij) wrote :

I know two other potential linux users who were put off by this problem.

The people I know both had Dells and were reluctant to uninstall the Dell Datasafe software because we were all worried about losing the ability to reinstall windows 7 later. (These users need windows, and are not willing to erase their entire hard drive and replace the OS with linux.) There is some confusion about whether one must have the datasafe software to reinstall windows on a Dell. I confess, we were all ignorant and also too lazy to google around for the answer and we gave up. (I realize this is an ubuntu forum and not a dell forum.) In any case, there is no question that this problem is a hurdle for new potential linux users.

wombat (jewett-aij) wrote :

(My apologies. The problem I am trying to comment on may in fact be more closely related to bug 441941 or 482757. Possible duplicates.)

mavosaure (mavosaure) wrote :

I experiment the same problem for a few, on may Dell Studio 1558 laptop.

Am friday 20th of august i was working on Windows Seven When a Dell update was applied without I should agree or disagree. After reboot I got also the message :
"no module name found.
Aborted. Press any key to exit"

I wasn't able to get the GRUB menu to launch neither Ubuntu (10.04 +updates , amd64, setted up on dual booth with default options of the live CD) nor Seven.

Using a live-USB, I succeeded to restore the grub install using
sudo mkdir /media/ubuntu
sudo mount /dev/sda5 # sd5 6 is the partition where is my root of Ubuntu
sudo grub-install --root-directory /media/ubuntu /dev/sda

My partitions are
/dev/sda1 Dell Utility
/dev/sda2 * "RECOVERY" [sudo os-prober returns : Windows 7 (loader)]
/dev/sda3 OS [Windows 7 directory]
/dev/sda5 Ubuntu root directory [sudo os-prober returns : Ubuntu 10.04.1 LTS]
/dev/sda6 swap
/dev/sda7 Home directory for Ubuntu
(...)

Each time I'm using Windows I had tio restore grub after rebooting. Even after an hibernation.

Lots of people seem having the same problem as you can read on ubuntuforums http://ubuntuforums.org/showthread.php?t=1343851)

I hope to to find something better as the workaround to remove Dell utility backup or to restore grub2 each time...

Colin Watson (cjwatson) wrote :

If you are experiencing this problem, then please follow these instructions:

 * Save the output of 'fdisk -lu' to a file. In this output, take note of the start sector of the first partition (usually 63, but might also be 2048 on recent installations, or occasionally something else). If this is something other than 63, then replace 63 in the following items with your number.
 * Save the contents of the embedding area to a file (replace '/dev/sda' with your disk device if it's something else): 'dd if=/dev/sda of=sda.1 count=63'
 * Do whatever you do to make GRUB unbootable (presumably starting Windows), then boot into a recovery environment. Before you reinstall GRUB, save the new contents of the embedding area to a different file: 'dd if=/dev/sda of=sda.2 count=63'
 * Follow up to this bug with these three files (the output of 'fdisk -lu', and the embedding area before and after making GRUB unbootable).

mavosaure (mavosaure) wrote :

As reported in bug # 441941:
Note that the warning message was always :
"no module name found
Aborted. Press any key to exit."

I just tried your packages (@Colin Watson) but after rebooting on Seven, it fails again. (I setted up Maverick on an another partition of the same disk).

You'll find the requested files here.

Colin Watson (cjwatson) wrote :

It's only bad news in that the contents of the sector that's been overwritten are almost completely different from what you gave me before. The only similarity I can see is that there's the following sequence of characters in your first dump:

  77DNN88M7100000000WX

... and the following sequence in your second dump:

  XW0000000017M88NND77

The latter is exactly the reverse of the former. Did you receive any Dell updates in the intervening time?

Could you repeat the procedure (say) three more times - reinstall GRUB, record image with dd, reboot to Windows, do whatever you need to do to break things, record image with dd, and repeat? I'd like to try to get an idea of which features of the overwritten sector are stable and can be detected.

OK, I've t many things to do under Windows and Ubuntu, so I can break
my GRUB many times... It's just a question of time :-)

Le 22/09/2010 15:39, Colin Watson a écrit :
> It's only bad news in that the contents of the sector that's been
> overwritten are almost completely different from what you gave me
> before. The only similarity I can see is that there's the following
> sequence of characters in your first dump:
>
> 77DNN88M7100000000WX
>
> ... and the following sequence in your second dump:
>
> XW0000000017M88NND77
>
> The latter is exactly the reverse of the former. Did you receive any
> Dell updates in the intervening time?
>
> Could you repeat the procedure (say) three more times - reinstall GRUB,
> record image with dd, reboot to Windows, do whatever you need to do to
> break things, record image with dd, and repeat? I'd like to try to get
> an idea of which features of the overwritten sector are stable and can
> be detected.
>
>

Thespian (jesse-mundis) wrote :

My wife and I have identical HP(Dell) laptops (Compaq 8710p). We both dual boot XP/ubuntu. I upgraded 8.04->10.04 a number of months back, and all was relatively painless. We tried to do the same to hers and hit a bunch of upgrade problems (not obviously related to this bug) so I decided to "nuke it from orbit" and after backing up her home dir, installed from the current 10.04 iso, reformatting the existing ubuntu partition. Neither of us had any problems like this bug describes under 8.04, and I haven't seen this problem under 10.04 on my machine.

The install went fine, but first thing I tested was booting in to windows to make sure I hadn't messed anything up there. All looked good, restarted, and BAM, hit the "no module" message. It's possible that she has different windows software (Mcaffee seems likely culprit) that is tickling this bug. Also, it looks like back when I upgraded, I still had legacy grub, not grub-pc. As others have said, the smaller footprint may be avoiding the problem for me. My system has never hit this, booting between windows and ubuntu.

Work around that seems to have worked for me:

Following instructions here:

http://sourceforge.net/apps/mediawiki/bootinfoscript/index.php?title=Boot_Problems:Windows_Writes_To_MBR

and here:

http://ubuntuforums.org/showpost.php?p=8068512&postcount=10

I removed grub-pc, installed classic grub, re-installed grub-pc in a "chain-loader" configuration, and removed the Mcafee software from her XP machine, and that combo seems to be working. I'm hesitant to fully install the new grub to the MBR until this issue is fully understood and fixed.

In summation:
There seems to exist various bits of windows software which write to the MBR in such a way as to corrupt the current grub2 style of doing things that don't seem to bother the previous grub install. Removing these from Windows seems to fix the problem, but just sets you up to be bit by it again later. Previous grub seems to avoid these problems, and seems to be the best work-around so far. Looks like it can chain-boot grub2 safely, _so far_.

This isn't Ubuntu or the grub/grub2 maintainers _fault_, but it is their _problem_. Lots of us are dual-boot various flavors of windows and Linux, and if this wasn't a problem with the earlier grub (even with windows misbehaving and writing where it shouldn't) it _needs_ to continue working with grub2.

Staying with older grub and/or removing windows apps are not sustainable solutions long term.
Hope that info helps someone.

Colin Watson (cjwatson) wrote :

On Thu, Sep 30, 2010 at 05:51:43PM -0000, Thespian wrote:
> This isn't Ubuntu or the grub/grub2 maintainers _fault_, but it is their
> _problem_. Lots of us are dual-boot various flavors of windows and
> Linux, and if this wasn't a problem with the earlier grub (even with
> windows misbehaving and writing where it shouldn't) it _needs_ to
> continue working with grub2.

Certainly. In
http://www.chiark.greenend.org.uk/ucgi/~cjwatson/blosxom/debian/2010-08-28-windows-applications-making-grub2-unbootable.html,
I explained why this affects GRUB 2 and not GRUB Legacy, and I asked for
some specific information from people affected. The grub2 package
currently in Maverick already works around this for certain Windows
applications. If you supply the information I asked for in that blog
post (also requested in various bug comments), then I should be able to
extend our dictionary of signatures to cover your case.

Changed in grub2 (Debian):
status: Unknown → New
Thespian (jesse-mundis) wrote :

Colin, thanks for the pointer to the info that could you help with a work-around. Using grub2 in chained boot mode still had a similar problem, so I've reverted back to legacy grub for now. I've got 4 files attached here for you. The fdisk output, the "good" mbr now with legacy grub installed, and two different "bad" mbr dumps. One produces the "module not found" described in this bug" while the other is a different symptom, probably caused by the same problem. Ignore that one if you wish. Looks like I can only add one attachment per post, so next three files in next posts.

After operating with grub2 in chained mode fro a while, wife booted into windows again and next time, the grub bootloader was just gone, and the system booted straight into windows. No idea what's up with that, but figured I'd attach that capture as well.

Also, if you haven't seen it, there was a thread specifically about HP/Compaq laptops having various bits of software that caused this problem. Given that we have Compaq laptops, it might give you some more info to work with. That thread is here: http://ubuntuforums.org/showthread.php?t=1343851&page=2

Thanks for looking in to this.

Thespian (jesse-mundis) wrote :

output of fdisk attached

Thespian (jesse-mundis) wrote :

good mbr

Thespian (jesse-mundis) wrote :

And last, the mbr that just booted straight in to windows, seemingly over-writing the previous grub2 bootloader in some way

Changed in grub2 (Debian):
status: New → Confirmed
Changed in grub2 (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.