lucid grub2 has no /dev/sda but is in grub.cfg

Bug #549980 reported by Ralph Ulrich on 2010-03-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

since grub-pc 1.98-1ubuntu2 menuentries in /boot/grub/grub.cfg look different:
---------------------------------
menuentry "Ubuntu, mit Linux 2.6.32-17-generic noext2" --class ubuntu --class gnu-linux --class gnu --class os {
        insmod ext2
        search --no-floppy --fs-uuid --set 67f844a5-1afd-4265-932f-e57e078c0fdc
        set root='(/dev/sda,3)'
        linux /boot/vmlinuz-2.6.32-17-generic root=/dev/sda3 ro quiet noresume splash nvidia.modeset=1
        initrd /boot/initrd.img-2.6.32-17-generic
}
-------------------------------
If you put command "set root" after command "search", like I did here for testing purpose,
then there is no root any more, boot fails!

And there is now:
" --class ubuntu --class gnu-linux --class gnu --class os"
???

Ralph Ulrich (eulenreich) wrote :

"/dev/sda" is really wrong using with set root ....

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.98-1ubuntu4

---------------
grub2 (1.98-1ubuntu4) lucid; urgency=low

  * Only use the first word of GRUB_DISTRIBUTOR for --class, to avoid
    problems if somebody puts spaces in GRUB_DISTRIBUTOR (LP: #557606).
  * Probe all devices in 'grub-probe --target=drive' if
    /boot/grub/device.map is missing (LP: #549980).
  * Adjust hostdisk id for hard disks, allowing grub-setup to use its
    standard workaround for broken BIOSes (thanks to TJ for detailed
    investigation; LP: #555500).
 -- Colin Watson <email address hidden> Fri, 09 Apr 2010 09:46:44 +0100

Changed in grub2 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers