Boot screen is localized only partially

Bug #537998 reported by Gabor Kelemen on 2010-03-12
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
grub2 (Ubuntu)
Medium
Colin Watson
memtest86+ (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

The explanation on the bottom of the OS selector does not appear localized, even that it is translated in the upstream po file:

https://translations.launchpad.net/ubuntu/lucid/+source/grub2/+pots/grub/hu/+translate?batch=10&show=all&search=highlight
https://translations.launchpad.net/ubuntu/lucid/+source/grub2/+pots/grub/hu/+translate?batch=10&show=all&search=press+enter

The kernel entries are localized correctly, while the Memory test entries are missing from the po file - this is an Ubuntu-specific addition.

Related branches

Gabor Kelemen (kelemeng) wrote :
Gabor Kelemen (kelemeng) wrote :

The strings for Memory test are from the memtest86+ package, so that is affected too.

Also, the /boot/grub/grub.cfg file sets the localedir as ($root)/boot/grub/locale, but simply putting grub.mo under /boot/grub/locale/hu/LC_MESSAGES does not help.

Gabor Kelemen (kelemeng) wrote :

Silly me, just take a look at this:

http://bazaar.launchpad.net/%7Eubuntu-branches/ubuntu/lucid/grub2/lucid/annotate/head%3A/gettext/gettext.c#L280

So, we should place the mo files as /boot/grub/locale/xx.mo

Changed in ubuntu-translations:
status: New → Triaged
Gabor Kelemen (kelemeng) wrote :

On the other hand, the utils that are running under the normal OS, use this function to init i18n:

http://bazaar.launchpad.net/%7Eubuntu-branches/ubuntu/lucid/grub2/lucid/annotate/head%3A/util/misc.c#L600

For these, we need a normal grub.mo in the language packs.

David Planella (dpm) wrote :

I had a chat with Aron this morning about this. We didn't find the cause of the problem, but I thought I'd add it here for the record.

It's on http://logs.ubuntu-eu.org/free/2010/03/18/%23ubuntu-translators.html

Gabor Kelemen (kelemeng) wrote :

Well, to me, it seems that nothing is putting ll.mo files to /boot/grub/locale/ - thus, we should do it. Is that so hard? :)

Or, we can patch this line:

  mo_file = grub_xasprintf ("%s/%s.mo", locale_dir, lang);

so that it does not expect ll.mo, but ll/grub.mo files - not difficult either but even then, we should move some mo files there manually(?).

Colin Watson (cjwatson) wrote :

I'm working on this, and just sent a patch upstream which should help matters.

Changed in grub2 (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Medium
milestone: none → ubuntu-10.04-beta-2
status: New → In Progress
Colin Watson (cjwatson) wrote :

I'm fixing most of this for my next upload. "Memory test" is going to be hard to fix, though, because grub's translation infrastructure is not set up to handle the case of some translations coming from a different domain (it doesn't know which other domains to look at). I queried this upstream in http://lists.gnu.org/archive/html/grub-devel/2010-03/msg00081.html, but it may well not be fixed for Lucid.

Colin Watson (cjwatson) wrote :

BTW, there's no need to exclude grub.mo from language packs.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.98-1ubuntu2

---------------
grub2 (1.98-1ubuntu2) lucid; urgency=low

  * Fix LVM/RAID probing in the absence of /boot/grub/device.map
    (LP: #525085, #527401).
  * Backport my upstream patch to copy .mo files from /usr/share/locale to
    match where 'make install' puts them (LP: #537998).
  * Look for .mo files in /usr/share/locale-langpack as well, in preference
    (LP: #537998).
  * Don't generate /boot/grub/device.map during grub-mkconfig (we already
    suppressed it during grub-install, but then grub-mkconfig generated it
    shortly afterwards, producing confusing results).
  * Don't run /etc/grub.d/README, even if it somehow ended up being
    executable (LP: #537123).
 -- Colin Watson <email address hidden> Mon, 22 Mar 2010 19:57:10 +0000

Changed in grub2 (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-translations:
status: Triaged → Fix Released
Changed in memtest86+ (Ubuntu):
status: New → Invalid
Colin Watson (cjwatson) wrote :

Hendrik, I'm not aware of this having been fixed in memtest86+ yet. See my comment #8. If you believe it has been fixed, please cite a relevant changelog entry.

Changed in memtest86+ (Ubuntu):
status: Invalid → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package memtest86+ - 4.20-1.1ubuntu4

---------------
memtest86+ (4.20-1.1ubuntu4) saucy; urgency=low

  * Support localization of GRUB menu entries (LP: #537998).
 -- Dmitry Shachnev <email address hidden> Mon, 13 May 2013 15:06:15 +0400

Changed in memtest86+ (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers