Operating System not found

Bug #517121 reported by jnns on 2010-02-04
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

After installing Lucid Alpha 2 and restarting, grub is not showing up. Instead a message appears: Operating system not found. Booting the Live CD again and running `grub-install /dev/sda` does not help.

Colin Watson (cjwatson) wrote :

I think this is a message from your BIOS, indicating really that it can't find the boot loader. Could you please describe a bit about how your machine is set up? What disks and partitions do you have? Where did you tell the Ubuntu installer to install GRUB, if you didn't just accept the default?

Changed in grub2 (Ubuntu):
status: New → Incomplete
jnns (jnns) wrote :

Yes, it think grub doesn't install into the disk's MBR correctly. I did a manual partitioning as I wanted to keep the /home drive from the previous install. There's only one disk ( /dev/sda ) and I partitioned it like this:

SCSI1 (0,0,0) (sda) - 320 GB ATA WDC WD3200BEVT-2
   No. 1 primary 4.0 GB F Swap Swap
   No. 2 primary 30.0 GB B F ext4 /
   No. 3 primary 286.1 GB ext4 /home

After running `grub-install /dev/sda` manually it exits with: »Installation finished. No errors reported.«

Grub is version 1.98~20100101-1ubuntu1. I tried the x64 live cd and x64 alternate cd. The system I use is a Fujitsu-Siemens Amilo Si 3655 and after searching around for other people having this issue I found a forum thread [1] suggesting to install to /dev/sda2 additionally. So I did a `grub-install /dev/sda2 --force` despite the warning that installing to a partition instead to MBR is a bad idea. I got the warning »Embedding is not possible. Grub can only be installed in this setup using blocklists. However, blocklists are UNRELIABLE and its use is discouraged.«

Surprisingly, it work's now.

[1] http://www.amilo-forum.de/topic,26887,-No-Operating-System-Found.html

Ole G. Gjelland (gjelland) wrote :

This is definitely a problem with the Fujitsu-Siemens Amilo Si 3655. It seems like the bios (Phoenix, latest version 1.03c of 2008-09-22) in this machine refuses to execute the MBR boot code if the first sector in the active primary partition is blank. And I believe this will always be the case in a common Ubuntu or Debian install.

The grub-installer package seems to be the culprit here, and /usr/bin/grub-installer explains it all:

  # Make sure that there's *some* active partition; some BIOSes
  # reportedly don't like it otherwise.

and if no sensible partition is found for the task:

  # We don't care at this point; just pick the first
  # primary partition that exists.

A workaround would be to switch to console 2 (Alt-F2) and do a 'fdisk /dev/sda' with the five commands 'p-a-2-p-w' (replace '2' with the partition that shows up having the 'Boot' flag set), and then back to the install console with Alt-F1. This can be done just before rebooting (and after configuring grub-pc).

Launchpad Janitor (janitor) wrote :

[Expired for grub2 (Ubuntu) because there has been no activity for 60 days.]

Changed in grub2 (Ubuntu):
status: Incomplete → Expired

I experienced the same problem on my Amilo after upgrading the system. It is true that is occurs with all debian based distributions I tried (mint & ubuntu).

The suggested workaround worked fine for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers