Ubuntu

strange warning about video mode on boot

Reported by Bogdan Butnaru on 2009-11-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

Hello!

I've recently updated to grub2 (by installing grub-pc) and I noticed something new and strange.

In the previous version of grub, I used “# defoptions=vga=0x37d” in /boot/grub/menu.lst to set the video mode. I'm using an nVidia card and this causes 1920x1200 to be used (in 32 bits I think), which is the native resolution of my flat panel. This didn't get passed on automatically to grub2, so I added it in /etc/default/grub under GRUB_CMDLINE_LINUX_DEFAULT. With this setting the boot process is started in the correct resolution.

However, right after the GRUB screen goes away, before anything else is displayed, I see the following warning for a second or so at the top of the screen:

vga=0x37d is deprecated. Mode 893 isn't recognized. Use set gfxpayload=WIDTHxHEIGHT[xDEPTH] before linux command instead.

I'm not sure if it's grub or the linux kernel that displays this message. I'll investigate a bit more.

ProblemType: Bug
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bogdanb 2025 F.... pulseaudio
 /dev/snd/controlC1: bogdanb 2025 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf9ff8000 irq 22'
   Mixer name : 'Realtek ALC1200'
   Components : 'HDA:10ec0888,104382fe,00100101'
   Controls : 40
   Simple ctrls : 22
Card1.Amixer.info:
 Card hw:1 'Headset'/'Logitech Logitech Wireless Headset at usb-0000:00:1d.1-1, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0a12'
   Controls : 4
   Simple ctrls : 2
CurrentDmesg:
 [ 28.077511] ppdev: user-space parallel port driver
 [ 31.823833] eth0: no IPv6 routers present
Date: Tue Nov 10 18:29:44 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=/dev/sdb2
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: System manufacturer P5Q-PRO
NonfreeKernelModules: nvidia
Package: linux-image-2.6.31-15-generic 2.6.31-15.49
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-15-generic root=UUID=f345b250-3225-489c-a2a5-5c7a2b21a0fd ro quiet splash
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-15.49-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-15-generic N/A
 linux-firmware 1.25
RfKill:

SourcePackage: linux
Uname: Linux 2.6.31-15-generic x86_64
UserAsoundrc:
 # ALSA library configuration file

 # Include settings that are under the control of asoundconf(1).
 # (To disable these settings, comment out this line.)
 </home/bogdanb/.asoundrc.asoundconf>
WpaSupplicantLog:

XsessionErrors:
 (gnome-settings-daemon:2166): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2288): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2258): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gnome-panel:2257): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -10 and height 25
 (gnome-panel:2257): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window
dmi.bios.date: 11/04/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1501
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5Q-PRO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1501:bd11/04/2008:svnSystemmanufacturer:pnP5Q-PRO:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5Q-PRO:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5Q-PRO
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bogdanb 1604 F.... pulseaudio
 /dev/snd/controlC1: bogdanb 1604 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf9ff8000 irq 22'
   Mixer name : 'Realtek ALC1200'
   Components : 'HDA:10ec0888,104382fe,00100101'
   Controls : 40
   Simple ctrls : 22
Card1.Amixer.info:
 Card hw:1 'Headset'/'Logitech Logitech Wireless Headset at usb-0000:00:1d.0-2, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0a12'
   Controls : 4
   Simple ctrls : 2
CurrentDmesg:
 [ 33.895657] ppdev: user-space parallel port driver
 [ 38.181288] eth0: no IPv6 routers present
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
HibernationDevice: RESUME=/dev/sdb2
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: System manufacturer P5Q-PRO
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=/dev/sda1 ro nomodeset
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Regression: Yes
RelatedPackageVersions: linux-firmware 1.34
Reproducible: Yes
RfKill:

Tags: lucid graphics regression-potential needs-upstream-testing
Uname: Linux 2.6.32-21-generic x86_64
UserAsoundrc:
 # ALSA library configuration file

 # Include settings that are under the control of asoundconf(1).
 # (To disable these settings, comment out this line.)
 </home/bogdanb/.asoundrc.asoundconf>
UserGroups: adm admin audio cdrom dialout floppy fuse lpadmin netdev plugdev sambashare scanner staff video
WpaSupplicantLog:

dmi.bios.date: 11/04/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1501
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5Q-PRO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1501:bd11/04/2008:svnSystemmanufacturer:pnP5Q-PRO:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5Q-PRO:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5Q-PRO
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Bogdan Butnaru (bogdanb) wrote :
Bogdan Butnaru (bogdanb) wrote :

Hi!

I played a bit more with this. I believe the warning comes from GRUB, because it is displayed in GRUB's video mode instead of the one set for the kernel. (However, it may just be that the kernel prints this before actually changing its mode, I'm not sure.)

Also, I tried doing what it says, i.e. adding "set gfxpayload=1920x1200" before the linux command, and removing the “vga=0x37d” part. (I did this by manually editing the boot command in GRUB's menu, and pressing Ctrl+x, not by changing GRUB's settings, in case it matters.)

This didn't work. I got a mostly blank screen (there were some bright green rectangles displayed on the bottom of the screen for a few seconds), until the GDM progress screen showed up. Switching to a console gets me the same blank screen, but I can switch back to X.

Andy Whitcroft (apw) on 2009-11-30
tags: added: kernel-karmic
Jeremy Foshee (jeremyfoshee) wrote :

Hi Bogdan,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 480153

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.