karmic: missing grub.info install from docs/grub.texi

Bug #453442 reported by Grant Bowman on 2009-10-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Medium
Colin Watson
Karmic
Medium
Colin Watson

Bug Description

Binary package hint: grub2

ran command: `info grub`

expected: should bring up the info file

currently: the info viewer says "No menu item `grub' in node `(dir)Top'."

The grub-common binary package should install grub.info compiled from docs/grub.texi of the grub2-1.97~beta3 source package. I think it should be installed to /usr/share/info/ with other similar files.

ProblemType: Bug
Architecture: i386
Date: Fri Oct 16 12:55:39 2009
DistroRelease: Ubuntu 9.10
Package: grub-common 1.97~beta4-1ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.47-generic
SourcePackage: grub2
Uname: Linux 2.6.31-14-generic i686

Related branches

Grant Bowman (grantbow) wrote :

Am Freitag, den 16.10.2009, 20:04 +0000 schrieb Grant Bowman:
> Public bug reported:
>
> Binary package hint: grub2
>
> ran command: `info grub`
>
> expected: should bring up the info file
>
> currently: the info viewer says "No menu item `grub' in node
> `(dir)Top'."
>
> The grub-common binary package should install grub.info compiled from
> docs/grub.texi of the grub2-1.97~beta3 source package. I think it
> should be installed to /usr/share/info/ with other similar files.
>

Thanks for the report.
The problem is the missing build dependency on texinfo.
I just fixed this in the Debian package but for Ubuntu Colin has to do
it.

--
Felix Zielcke
Proud Debian Maintainer and GNU GRUB developer

Colin Watson (cjwatson) on 2009-10-19
Changed in grub2 (Ubuntu Karmic):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Colin Watson (cjwatson)
milestone: none → ubuntu-9.10
Grant Bowman (grantbow) wrote :

I'm still not seeing grub.info in my karmic installation.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.97~beta4-1ubuntu3

---------------
grub2 (1.97~beta4-1ubuntu3) karmic; urgency=low

  * Backport from Debian (Felix Zielcke):
    - Add a build dependency on texinfo (LP: #453442).
  * debian/patches/968_raid_virtio.diff: Handle RAID devices containing
    virtio components (LP: #457687).

 -- Colin Watson <email address hidden> Fri, 23 Oct 2009 21:58:13 +0100

Changed in grub2 (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers