Ubuntu

tty screen produces garbled graphics when gfxpayload is set

Reported by mabawsa on 2009-10-05
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

~$ lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10
~$ apt-cache policy grub2
grub2:
  Installed: (none)
  Candidate: 1.97~beta3-1ubuntu7
  Version table:
     1.97~beta3-1ubuntu7 0
        500 http://archive.ubuntu.com karmic/universe Packages
~$ sudo hwinfo --framebuffer
02: None 00.0: 11001 VESA Framebuffer
  [Created at bios.464]
  Unique ID: rdCR._t1P2Mk9T7B
  Hardware Class: framebuffer
  Model: "NVIDIA G86 Board - thurman0"
  Vendor: "NVIDIA Corporation"
  Device: "G86 Board - thurman0"
  SubVendor: "NVIDIA"
  SubDevice:
  Revision: "Chip Rev"
  Memory Size: 14 MB
  Memory Range: 0xf3000000-0xf3dfffff (rw)
  Mode 0x0300: 640x400 (+640), 8 bits
  Mode 0x0301: 640x480 (+640), 8 bits
  Mode 0x0303: 800x600 (+800), 8 bits
  Mode 0x0305: 1024x768 (+1024), 8 bits
  Mode 0x0307: 1280x1024 (+1280), 8 bits
  Mode 0x030e: 320x200 (+640), 16 bits
  Mode 0x030f: 320x200 (+1280), 24 bits
  Mode 0x0311: 640x480 (+1280), 16 bits
  Mode 0x0312: 640x480 (+2560), 24 bits
  Mode 0x0314: 800x600 (+1600), 16 bits
  Mode 0x0315: 800x600 (+3200), 24 bits
  Mode 0x0317: 1024x768 (+2048), 16 bits
  Mode 0x0318: 1024x768 (+4096), 24 bits
  Mode 0x031a: 1280x1024 (+2560), 16 bits
  Mode 0x031b: 1280x1024 (+5120), 24 bits
  Mode 0x0330: 320x200 (+320), 8 bits
  Mode 0x0331: 320x400 (+320), 8 bits
  Mode 0x0332: 320x400 (+640), 16 bits
  Mode 0x0333: 320x400 (+1280), 24 bits
  Mode 0x0334: 320x240 (+320), 8 bits
  Mode 0x0335: 320x240 (+640), 16 bits
  Mode 0x0336: 320x240 (+1280), 24 bits
  Mode 0x033d: 640x400 (+1280), 16 bits
  Mode 0x033e: 640x400 (+2560), 24 bits
  Mode 0x0345: 1600x1200 (+1600), 8 bits
  Mode 0x0346: 1600x1200 (+3200), 16 bits
  Mode 0x0347: 1400x1050 (+1400), 8 bits
  Mode 0x0348: 1400x1050 (+2800), 16 bits
  Mode 0x0349: 1400x1050 (+5600), 24 bits
  Mode 0x034a: 1600x1200 (+6400), 24 bits
  Mode 0x0352: 2048x1536 (+8192), 24 bits
  Mode 0x0360: 1280x800 (+1280), 8 bits
  Mode 0x0361: 1280x800 (+5120), 24 bits
  Mode 0x0362: 768x480 (+768), 8 bits
  Mode 0x0364: 1440x900 (+1440), 8 bits
  Mode 0x0365: 1440x900 (+5760), 24 bits
  Mode 0x0368: 1680x1050 (+1680), 8 bits
  Mode 0x0369: 1680x1050 (+6720), 24 bits
  Mode 0x037c: 1920x1200 (+1920), 8 bits
  Mode 0x037d: 1920x1200 (+7680), 24 bits
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Whenever I try to set the gfxpayload to anything greater than 640x480x8 the tty get garbled (the following attachment shows an example). The video card supports the resolution. I have tried in the linux entry in the 10_linux file (just above the "linux ${rel_dirname}/${basename} root=${linux_root_device_thisversion} ro $2" line) and in the 00_header file:
 set gfxmode=${GRUB_GFXMODE}
  set gfxpayload=keep
  insmod gfxterm
  insmod ${GRUB_VIDEO_BACKEND}

mabawsa (mabawsa) wrote :
mabawsa (mabawsa) wrote :

Oh the basic menu for grub2 works at all the above resolutions I have tried. This is only a tty/boot issue

mabawsa (mabawsa) wrote :

Things just got worse. Since yesterdays update all graphic resolutions produce garbled ttys even if I totally remove the gfxpayload. Arrgh no ttys!

mabawsa (mabawsa) wrote :

-remove the gfxpayload
+remove the gfxpayload line

Llama (james-nissel) wrote :

I am having the same issue. Is there a solution?

emarkay (mrk) wrote :

mabawsa, can you clarify that? (#3).
I also have this issue with an old laptop, Dell Latitude C600 with the latest updates.

mabawsa (mabawsa) wrote :

Well before the updates I had ttys at the lowest resolution and the screens were garbled only if I tried to set the resolution using gfxpayload grub command. Now the screens are garbled with any setting, this coincided with the little white ubuntu sign appearing in the boot sequence.

Hopefully this clarifies things...

mabawsa (mabawsa) wrote :

OK the latest round of updates got rid of the garbled terminals at all resolutions. Terminals are back to normal when gfxpayload is not set in the 00_headers file. When gfxpayload is set to keep I just get a flashing cursor in the tty windows. This occurs at GRUB_GFXMODE=1280x800x24, GRUB_GFXMODE=1280x800, GRUB_GFXMODE=1024x768 and GRUB_GFXMODE=800x600. So I guess the bug is still there as I cannot access the tty other than at the lowest resolution.

Llama (james-nissel) wrote :

I got higher resolution terminals working with GRUB_GFXMODE by using vesafb. I roughly followed these instructions: http://community.spiceworks.com/how_to/show/54 ignoring the vga= bit for grub. Also i worked around the no tty at all by removing "quiet" and "splash" from the grub defaults, but if todays update to usplash fixed something (i think it has to give the terminal a chance to load before X else it doesn't work) i might put them back in and see if it still works.

Cedric Schieli (cschieli) wrote :

I confirm this bug on a Dell Vostrto 1710.
With gfxmode=1440x900x32 (my native resolution) and gfxpayload=keep everything work as expected except ttys being blank with fashing cursor.
Without tuning gfxmode/gfxpayload, ttys are functional.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers