Comment 66 for bug 441941

I have a question though. I have a HP s3600 desktop with XP x64 (OS does not come with HP, I own XP). Will this bug affect me? Or maybe I should install 9.04?