Ubuntu

Grub2 fails to boot any kernel initrd is too big

Reported by Alejandro Del Rincón on 2009-09-15
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

HI,
My version was Karmic for 3 days ago, fully updated.
Then, I shutted dwon the machine, and the next day I tried to boot the 2.6.31-10 kernel image and grub2 says that initrd imge is too big...
I also tried to boot 2.6.31-9 image i an can´t.
i only updated the system with the ubuntu repos
I remember that the grub 2 version was the beta2

I tried today to reinstall with the alpha 5 CD and the problem persist...
17 September i´ll try with the alpha 6

Bernhard (b.a.koenig) wrote :

Hope that this fixes it for you:

http://ubuntuforums.org/showthread.php?t=1267093

especially see post #10.

Bernhard (b.a.koenig) on 2009-09-20
Changed in grub2 (Ubuntu):
status: New → Fix Released
Jouni Mettala (jouni-mettala) wrote :

According to https://wiki.ubuntu.com/Bugs/Status this isn't fix released. I am setting this to confirmed because of duplicates.

Changed in grub2 (Ubuntu):
status: Fix Released → Confirmed
johnhowe (johnhowe) wrote :

I see this bug after a fresh install of 9.10-rc. The live cd boots and installs fine, then when I reboot I can not get past grub.

Felix Zielcke (fzielcke) wrote :

For someone on IRC who had this problem recently a BIOS reset fixed it for him.
Maybe also try to update it.
And you can try to use linux16/initrd16 commands in the menu entry instead of the usual linux and initrd.
Calculation of the memory needed for the initrd is a bit different between them.

johnhowe (johnhowe) wrote :

Thanks Felix. Turned out to be an option in the BIOS which was limiting available memory. Disabled that option and it works fine now. Cheers.

johnhowe (johnhowe) wrote :

For anyone else with the same problem, the option I disabled in the bios was
Advanced -> Advanced Chipset Features -> Memory Hole Remapping

Thermaltaker (dennis-benndorf) wrote :

Big thanks to johnhowe, I got the same Problem and this fixed it!

blacktea (neuroflora) wrote :

I have same problem. And have not fix at all cause my bios have no memory hole option. Is there any other way to solve?

zeckenleger (gho-nexgo) wrote :

Same thing as above on a PC in my office. No option to switch off a memory hole.
I updated thy system using a live-CD and chroot. It did not solve the problem.

Sethra (42margaret-clearwire) wrote :

I have installed Ubuntu 9.10, then 9.04 and am stopped at the first boot with this message:
The initrd is too big...

Both work just fine from CD. I have installed from the CD desktop and from the main menu. Same result.

This PC is assembled from gifted parts and pieces... I only installed 512MB because that is all I have right now. The BIOS does not seem to have an option for memory remapping.

What does this message mean, and can I fix it?

Thanks, Susan

Sethra (42margaret-clearwire) wrote :

Complained too soon, went through the BIOS one by one and found the memory remapping setting. I changed it to disabled, and the settings worked.

Thanks for the post...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers