package grub-pc 1.96+20080724-12ubuntu2 failed to install on dmraid (fakeraid) no mapping exists

Bug #392136 reported by Julian Zeidler on 2009-06-25
56
This bug affects 8 people
Affects Status Importance Assigned to Milestone
grub2 (Debian)
Fix Released
Unknown
grub2 (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Danny Wood

Bug Description

Binary package hint: grub-pc

I am running Ubuntu 9.04 x64 on a Dell T3400 and have a dmraid of two HDD

Installation of grub2, as requested in https://wiki.ubuntu.com/KernelTeam/Grub2Testing fails with the following message:
Generating core.img
grub-probe: error: no mapping exists for `isw_ddbdejgibj_Data2 <(system_partition on the raid0)>
Auto-detection of a filesystem module failed.
Please specify the module with the option `--modules' explicitly.

ProblemType: Package
Architecture: amd64
DistroRelease: Ubuntu 9.04
ErrorMessage: Unterprozess post-installation script gab den Fehlerwert 1 zurück
NonfreeKernelModules: nvidia
Package: grub-pc 1.96+20080724-12ubuntu2
SourcePackage: grub2
Title: package grub-pc 1.96+20080724-12ubuntu2 failed to install/upgrade: Unterprozess post-installation script gab den Fehlerwert 1 zurück
Uname: Linux 2.6.28-11-generic x86_64

A dmraid patch went past on the upstream list relatively recently; I
don't think this is there yet, but should be soon.

Steven Harms (sharms) wrote :

Thank you for taking the time to report this bug. Can you try this out on Karmic Alpha 6 and see if it is still an issue?

Changed in grub2 (Ubuntu):
status: New → Incomplete
Jacques L. (jacquesl) wrote :

I can confirm the bug still happens on latest karmic:
...
Generating core.img
grub-probe: error: no mapping exists for `isw_ecjeghdcbi_vaio1'
Auto-detection of a filesystem module failed.
Please specify the module with the option `--modules' explicitly.
...

Danny Wood (danwood76) on 2009-10-01
Changed in grub2 (Ubuntu):
status: Incomplete → Confirmed
Filipe Sousa (natros) wrote :

I'm having the same problem with RAID0 and Intel ICH9

$ sudo apt-get install grub-pc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  desktop-base
The following NEW packages will be installed:
  grub-pc
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/496kB of archives.
After this operation, 1,892kB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously deselected package grub-pc.
(Reading database ... 126796 files and directories currently installed.)
Unpacking grub-pc (from .../grub-pc_1.97~beta3-1ubuntu7_amd64.deb) ...
Replacing files in old package grub ...
Processing triggers for man-db ...
Setting up grub-pc (1.97~beta3-1ubuntu7) ...

Creating config file /etc/default/grub with new version
Generating core.img
grub-probe: error: no mapping exists for `isw_cjdjidedij_Volume01'
Auto-detection of a filesystem module failed.
Please specify the module with the option `--modules' explicitly.
dpkg: error processing grub-pc (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 grub-pc
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu karmic (development branch)
Release: 9.10
Codename: karmic

$ apt-cache policy grub-pc
grub-pc:
  Installed: 1.97~beta3-1ubuntu7
  Candidate: 1.97~beta3-1ubuntu7
  Version table:
 *** 1.97~beta3-1ubuntu7 0
        500 http://archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

$ apt-cache policy dmraid
dmraid:
  Installed: 1.0.0.rc15-11ubuntu1
  Candidate: 1.0.0.rc15-11ubuntu1
  Version table:
 *** 1.0.0.rc15-11ubuntu1 0
        500 http://archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

Harald (haraldboehmecke) wrote :

I am having the same problem on ICH9 (Intel 82801 RAID Controller). During alternate Installation, grub fails to install and the Installation falls back to the Menu. Screenshot of the VTerminal 4 (debug) is attached. I´ll provide any further information. At the moment I have my PC in a non-bootable state!

Harald (haraldboehmecke) wrote :

NOTE: This happened with the daily release from 20.10.2009.

This affects me too.

$ apt-cache show grub-pc
Package: grub-pc
Priority: optional
Section: admin
Installed-Size: 1744
Maintainer: Ubuntu Core Developers <email address hidden>
Original-Maintainer: GRUB Maintainers <email address hidden>
Architecture: amd64
Source: grub2
Version: 1.97~beta4-1ubuntu4

Fails with:

### BEGIN /etc/grub.d/30_os-prober ###
Found Windows 7 (loader) on /dev/mapper/isw_cbibdfdhg_Volume01
menuentry "Windows 7 (loader) (on /dev/mapper/isw_cbibdfdhg_Volume01)" {
grub-probe: error: no mapping exists for `isw_cbibdfdhg_Volume01'
 chainloader +1
}
### END /etc/grub.d/30_os-prober ###

My hardware is a Intel P35 mainboard with ICH9 and a Windows 7 installation on a fakeraid.

Mark Shuttleworth (sabdfl) wrote :

I think I'm affected by this too. At heart, it seems that grub-mkdevicemap fails to handle /dev/mapper/* properly. I'll try editing my devicemap by hand to see how it should work.

Am Montag, den 23.11.2009, 18:49 +0000 schrieb Mark Shuttleworth:
> I think I'm affected by this too. At heart, it seems that grub-
> mkdevicemap fails to handle /dev/mapper/* properly. I'll try editing
> my
> devicemap by hand to see how it should work.
>

The problem with dmraids is more then just the device name.
Our ioctl(HDIO_GETGEO) based method to map Linux devices with the GRUB
ones just doestn't work with non real disk devices.
I made half a year ago a first patch which used blkid to get the UUID of
the filesystem but that was rejected by upstream.
Haven't looked since then much into it.
For me personally this isn't that important. Linux isn't on my dmraid.

--
Felix Zielcke
Proud Debian Maintainer and GNU GRUB developer

Mark Shuttleworth (sabdfl) wrote :

Manually editing the device.map doesn't help. I found some discussion of this on grub-devel, notably http://lists.gnu.org/archive/html/grub-devel/2009-07/msg00099.html which purports to be a good patch.

I tried to rebuild grub-common with the patch applied. It applies (with some hunks moved about) but I got an error during the configuration of the build about grub-emu that I couldn't figure out how to work around. Colin, would you take a look?

Robert Millan (rmh-aybabtu) wrote :

Try with this patch.

Changed in grub2 (Debian):
status: Unknown → New
Robert Millan (rmh-aybabtu) wrote :

Latest trunk includes my fix plus part of Felix', I believe this problem is fixed with those two changes.

If you want to cherry-pick, that's revisions 1870, 1874 and 1875.

Changed in grub2 (Debian):
status: New → Fix Released
Patrick Goetz (pgoetz) wrote :

"Latest trunk includes my fix plus part of Felix'" -- Robert Millan

Can you clarify what this means? Is this the latest trunk of grub2 dev? When can we expect this to show up in the 10.4 daily build? Anyone who dual boots Windows/linux (e.g. gamers) and already has Windows installed is dead in the water without this patch modulo more work than the average user can handle (i.e. reset BIOS and re-raid using software RAID on both sets of partitions).

Felix Zielcke (fzielcke) wrote :

Am Sonntag, den 06.12.2009, 15:30 +0000 schrieb Patrick Goetz:
> "Latest trunk includes my fix plus part of Felix'" -- Robert Millan
>
> Can you clarify what this means? Is this the latest trunk of grub2
> dev?

See the second last message in the linked Debian bug report, for the
Debian changelog entry which closed this report in Debian unstable.
Last one is for Debian experimental.
We create now fake devices. The generated grub.cfg will only work if
you're not affected by that search --fs-uuid bug.
I haven't yet tested how well grub-setup works.

> When can we expect this to show up in the 10.4 daily build?

Because 10.4 will be a LTS release, it mainly gets synced from Debian
testing and not unstable.
And unfortunately due to powerpc and sparc we have problems to get the
recent GRUB 2 builds into testing.
Maybe Colin Watson can make an exception and merge GRUB 2 from unstable
instead of having to wait until we get it into testing.
--
Felix Zielcke
Proud Debian Maintainer and GNU GRUB developer

Colin Watson (cjwatson) wrote :

Yeah, I'm planning to merge this from unstable RSN.

Launchpad Janitor (janitor) wrote :
Download full text (7.7 KiB)

This bug was fixed in the package grub2 - 1.97+20091130-1ubuntu1

---------------
grub2 (1.97+20091130-1ubuntu1) lucid; urgency=low

  * Resynchronise with Debian (LP: #485457). Remaining changes:
    + debian/default/grub:
      - Adjust for default Ubuntu boot options.
      - Use GRUB_CMDLINE_LINUX_DEFAULT option to set "quiet splash" for
        default items only. These options won't be set in single user mode.
      - Default to hiding the menu; holding down Shift at boot will show it.
    + debian/templates.in:
      - Change default value of grub2/linux_cmdline_default to "quiet
        splash".
    + debian/config.in, debian/postinst.in, debian/grub-pc.templates.in:
      - Migrate timeout settings from menu.lst.
    + debian/grub.d/05_debian_theme:
      - Set a monochromatic theme for Ubuntu.
    + debian/legacy/update-grub:
      - Apply Ubuntu branding: title, recovery mode, quiet option, and tweak
        how memtest86+ is displayed.
      - Use UUIDs where appropriate.
    + debian/control:
      - Conflict with grub (<< 0.97-54) as well as grub-legacy.
    + debian/postinst.in:
      - Fix backslash-escaping in merge_debconf_into_conf.
    + debian/patches/03_ubuntu_grub_standards:
      - Remove GNU/Linux from default string.
    + debian/patches/10_crashkernel.patch:
      - Add crashkernel= options if kdump and makedumpfile are available.
    + debian/patches/951_quick_boot.diff:
      - If other operating systems are installed, then automatically unhide
        the menu.
      - Otherwise, if GRUB_HIDDEN_TIMEOUT is 0, then use keystatus if
        available to check whether Shift is pressed. If it is, show the
        menu, otherwise boot immediately. If keystatus is not available,
        then fall back to a short delay interruptible with Escape.
    + debian/patches/952_sleep_shift.diff:
      - Allow Shift to interrupt 'sleep --interruptible'.
    + debian/patches/954_normal_quiet.diff:
      - Don't display introductory message about line editing unless we're
        actually offering a shell prompt. Don't clear the screen just before
        booting if we never drew the menu in the first place.
    + debian/patches/955_really_quiet.diff:
      - Remove some verbose messages printed before reading the
        configuration file.
    + debian/patches/956_linux_quiet.diff:
      - If the environment variable "quiet" is set to something other than
        0, suppress progress messages as the kernel and initrd load. Set
        this for non-recovery kernel menu entries.
    + debian/patches/957_savedefault.diff, debian/rules:
      - Add GRUB_DEFAULT=saved, as well as grub-set-default and grub-reboot
        utilities. Provides functionality essentially equivalent to GRUB
        Legacy's savedefault.
    + debian/patches/959_loopback_root.diff:
      - Keep the loopback file open so that subsequent changes to the "root"
        environment variable don't affect it.
    + debian/patches/961_handle_loopback.diff:
      - Change prepare_grub_to_access_device to handle filesystems
        loop-mounted on file images.
    + debian/patches/963_linux_no_loopmount.diff:
      - Ignore devices loop-mounted from files in 10_linux....

Read more...

Changed in grub2 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.