grub2 is not quiet enough

Bug #386922 reported by Andrew on 2009-06-14
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Wishlist
Unassigned
initramfs-tools (Ubuntu)
Undecided
Colin Watson

Bug Description

Binary package hint: grub2

grub2 currently outputs too much needless information during the boot. This merely confuses the user & makes the boot look untidy.

1) First it says 'GRUB loading..'

2) Then 'Welcome to GRUB'

3) Then it flashes up a large irrelevent piece of information:
"[ Minimal BASH-like line editing is supported. For the first word, TAB
lists possible command completions. Anywhere else TAB lists the possible
completions of a device/filename. ]"

4) Then it says 'Booting Ubuntu, linux [kernel version]'

5) Then "Linux=bzImage [random letters & stuff]"

6) And finally 'Loading please wait'

To be honest we only really NEED 6) . The rest is just more flashing on the boot and it needs to be sorted out. Attached is a video of the untidy boot process.

Related branches

Andrew (and471) wrote :
Hernando Torque (htorque) wrote :

Couldn't agree more.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Tormod Volden (tormodvolden) wrote :

Actually (6) 'Loading please wait' comes from the initrd and not from grub.

Felix Zielcke (fzielcke) wrote :

6) comes from the kernel and not the initrd
The problem with a bootloader is, that if you remove all of it's output and it hangs then it's too late to print out an error message.
So in case it fails it's much harder if not even impossible to debug if there is absolutely no output

I'm not sure 3) can be only shown when the menu doestn't get drawn or if you press c to go to command line.

Hernando Torque (htorque) wrote :

Well, they are _misused_ for debugging. You're programs don't come with debug mode enabled by default so why should GRUB2?

One fix would be to make it possible to install GRUB2 in two verbose modes. The default verbose mode would print messages iff they are errors or warnings while a verbose mode could be more chatty to help debugging.

Everyone able to fix a hanging bootloader should be able to install the bootloader anyway so that shouldn't be an issue.

Tormod Volden (tormodvolden) wrote :

> 6) comes from the kernel and not the initrd

See the top of /usr/share/initramfs-tools/init

Andrew (and471) wrote :

Here is the locations of some of the text (in the source package):

2) kern/main.c: grub_printf ("Welcome to GRUB!\n\n");

4) normal/menu_text.c: grub_printf (" Booting \'%s\'\n\n", entry->title);

Changed in grub2 (Ubuntu):
importance: Undecided → Wishlist
Colin Watson (cjwatson) wrote :

6) is disabled now except for recovery-mode boots:

initramfs-tools (0.92bubuntu42) karmic; urgency=low

  * Don't display "Loading, please wait..." message when 'quiet' is in
    /proc/cmdline.

 -- Colin Watson <email address hidden> Thu, 03 Sep 2009 23:31:28 +0100

Changed in initramfs-tools (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: New → Fix Released
Colin Watson (cjwatson) wrote :

1) is tricky as it's in the assembly bootstrap right at the start, so I'll have to think about that.

2) I'm just going to patch out unconditionally for now although I'm not sure I'm entirely happy about that.

3) is a bug, although I may work around it in our packaging for now; see http://lists.gnu.org/archive/html/grub-devel/2009-09/msg00056.html and thread.

4) and 5) I'm going to disable outside recovery mode.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.97~beta1-1ubuntu2

---------------
grub2 (1.97~beta1-1ubuntu2) karmic; urgency=low

  * debian/patches/953_no_eh_frame.diff: Build with -fno-dwarf2-cfi-asm to
    stop gcc-4.4 generating .eh_frame sections that cause core.img to be too
    big to embed in some common cases (LP: #423412).
  * debian/patches/954_normal_quiet.diff: Don't display introductory message
    about line editing unless we're actually offering a shell prompt.
  * debian/patches/955_really_quiet.diff: Remove some verbose messages
    printed before reading the configuration file. In some ways this is
    awkward because it makes debugging harder, but it's a requirement for a
    smooth-looking boot process; we may be able to do better in future (LP:
    #386922).
  * debian/patches/956_linux_quiet.diff: If the environment variable "quiet"
    is set to something other than 1, suppress progress messages as the
    kernel and initrd load. Set this for non-recovery kernel menu entries
    (LP: #386922).
  * debian/patches/957_savedefault.diff: Add GRUB_DEFAULT=saved, as well as
    grub-set-default and grub-reboot utilities. Provides functionality
    essentially equivalent to GRUB Legacy's savedefault (LP: #216178).
  * debian/rules, debian/grub-pc.install.in: Install grub-reboot and
    grub-set-default only in grub-common.
  * Add tag information to old Ubuntu patches.

 -- Colin Watson <email address hidden> Fri, 04 Sep 2009 15:02:36 +0100

Changed in grub2 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers