grub2 boot from lvm Auto-detection of a filesystem module failed

Bug #385428 reported by Cameron Braid on 2009-06-10
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

root@beast:~# lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

root@beast:~# apt-cache policy grub2
grub2:
  Installed: 1.96+20080724-12ubuntu2
  Candidate: 1.96+20080724-12ubuntu2
  Version table:
 *** 1.96+20080724-12ubuntu2 0
        500 http://au.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

I'm tested grub2 on jaunty as per https://wiki.ubuntu.com/KernelTeam/Grub2Testing

I started with a separate hdd (ext3 partition) for /boot and managed to get grub2 going via both a chainloading and a native setup.

Next I want to remove my /boot hard drive (since its an old noisy slow drive) so I wish to boot from my root ext4 partition on LVM . Its volume name is Ubuntu-jaunty

First I unmounted /boot and remounted it as /media/oldboot
Then I coppied everything from from /media/oldboot to /boot

I then tried to install grub2 into my first hard drive

root@beast:~# grub-install /dev/sda
error: Unknown metadata header
error: Unknown metadata header
grub-probe: error: no mapping exists for `Ubuntu-jaunty'
Auto-detection of a filesystem module failed.
Please specify the module with the option `--modules' explicitly.

Felix Zielcke (fzielcke) wrote :

I just installed jaunty in a vm with the alternate installer and choose to use LVM for the partitions.
grub-probe worked fine with it.
Unfortunately I don't know anything about LVM internals.
Do you remember how/when exactly your LVM was created?

Cameron Braid (cameron-braid) wrote :

I can't remember exactly. It was a long time ago, probably around the good old Warthog or Hedgehog times.

Kamilion (kamilion) wrote :

Just a note, I ran into a similar problem, and I fixed it by running "grub-mkdevicemap" then "update-grub" again.

Something may be amiss with the way the grub2 scripts operate versus the grub legacy scripts.

Steven Harms (sharms) wrote :

Please confirm that this happens with grub2 in Karmic Alpha 6 or greater.

Changed in grub2 (Ubuntu):
status: New → Incomplete

Am Sonntag, den 27.09.2009, 17:15 +0000 schrieb Steven Harms:
> Please confirm that this happens with grub2 in Karmic Alpha 6 or
> greater.
>
> ** Changed in: grub2 (Ubuntu)
> Status: New => Incomplete

No need to.
Regarding `Unknown metadata header' nothing was changed in the LVM code.
The problem is probable that the LVM was created with version 1 instead
of current 2, which has a different metadate.
Unfortunately I don't know anything about LVM internals so I'm not able
to implement support for this. And honourly I don't think it's wort
because LVM 1 is pretty old now.

--
Felix Zielcke
Proud Debian Maintainer

It still happens in lucid, and using lvm2. Kamilion solution worked for me.

Launchpad Janitor (janitor) wrote :

[Expired for grub2 (Ubuntu) because there has been no activity for 60 days.]

Changed in grub2 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers