intermittent boot failure dell inspiron 3593

Bug #1883785 reported by Sandy Patterson
This bug affects 12 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
grub2 (Ubuntu)

Bug Description

Sometimes on reboots and quick cold boots (poweroff then hit power immediately) I get

error: Command failed. -repeated a number of times then
error: you need to load the kernel first.

Press any key to continue...

* cold booting usually fixes this and I'm able to boot normally.
* I have three identical laptops and have seen the issue on 2 (i've only installed 20.04 on two).
* I don't see the problem on 18.04.
* If I go into the grub> menu many commands fail "true" "cat" but some don't "ls" "false."
* Once i'm in grub> menu I can fix things by running "rmmod tpm" then subsequent commands start working again and I can exit and continue.

The source for grub points to tpm.c when I search for "Command failed." I also notice that there's no such file in 2.02 version of grub so maybe that's related to why it doesn't work.

I haven't been able to find a combination of BIOS settings that mitigates this. I have tried disabling everything I could think of.

This laptop has Intel PTT which I think is baked into the BIOS (which I upgraded to the newest).

* Once the system fails to boot:
* enter grub> by pressing 'c'
* type 'rmmod tmp'
* press 'esc' to go back to menu and select desired option and system boots again.

sudo cp /etc/grub.d/40_custom /etc/grub.d/06_notpm
sudo bash -c 'echo "rmmod tpm" >> /etc/grub.d/06_notpm'
sudo update-grub

I will have these laptops for some time but won't be able to test much beyond a week or two most likely.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: grub2-common 2.04-1ubuntu26
ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
Uname: Linux 5.4.0-37-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.2
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Tue Jun 16 16:33:42 2020
InstallationDate: Installed on 2020-06-08 (8 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
 PATH=(custom, no user)
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Sandy Patterson (xandey) wrote :
Revision history for this message
Sandy Patterson (xandey) wrote :

Upon some further research, it looks like this bug is similar:
However, that bug seems to happen all the time where as for me it's intermittent.

I tried the workaround from the linked bug and can confirm that when I experience the issue I can boot successfully by:
* 'c'
* grub> rmmod tpm
* 'esc'
* 'enter' to select normal boot menu entry.

description: updated
Sandy Patterson (xandey)
description: updated
Sandy Patterson (xandey)
description: updated
Revision history for this message
Emil (nostormo) wrote :

Exacly the same issue on same Dell 3593, issue persist also on Linux Mint 20.04 (guess because it is based on Ubunu 20.04). Latest kernel.

Sometimes solved by enabling / disabling secure boot. Other times boot order Ubuntu/SSD, SSD/Ubuntu, unchecking SSD. Using recover kernel 5.40 mode/update grub.

On reboot it works every time.
On shut down....sometimes does not load OS after day/two or 4/5 days.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Revision history for this message
Pablo Pedemonte (ppedemon) wrote :

*Exactly* the same error here. Dell 3593, Ubuntu 20.04. Never tried the "rmmod tpm" fix, will do next time it happens. Two questions:

  - Can anyone affected confirm this doesn't happen with Ubuntu 18?
  - Does WORKAROUND 2 in original post lead to permanent solution? Looks like it should.


Revision history for this message
Sandy Patterson (xandey) wrote :

@ppedemon Well, I'm the OP so WORKAROUND 2 does work for me (obviously). I deployed these laptops with it after testing that it was stable so I don't have access to them anymore. I did look into the git history of grub and it seems to be related to some patches around TPM where it fails to perform some sort of tracing if the tpm chip isn't happy. This happens regardless of whether you've installed using secure boot or not. Anyway, It wasn't happening for me on 18.

I had a forum posting here where oldfred got me on the right track. I tried to include all the information in this bug report though.

Revision history for this message
Rafael Jesus Alcantara Perez (rafa-dedaloingenieros) wrote :

I have installed Kubuntu 20.04 on a Dell Inspiron 15 5593 and I have the same problem. I've used the workaround 2 and it seems that solves the issue. Thanks.

Revision history for this message
Milann Malla (itsmilann) wrote :

Dell Inspiron 3593 Ubuntu 21.04 (same issue in 20.04). Tried complete data wipe, Boot Repair nothing working.

Revision history for this message
Milann Malla (itsmilann) wrote :

WORKAROUND 1 outputs:

command failed
no such module

Revision history for this message
David (duffski) wrote :

Same for me on the same machine - Dell Inspiron 3593 (on Mint 20.1)

Revision history for this message
Johann Gail (johann-gail) wrote :

Same here on a Dell Inspiron 3593, Bios never updated, version V1.1.0, ubuntu 18.04. It started suddenly one or two weeks ago, previously running without problems.

Reboot always works, complete shutdown and boot within some seconds by power button mostly fails.

On 2021-05-14 there was some updates, one of them probably causing this:
 grub-common:amd64 (2.02-2ubuntu8.21, 2.02-2ubuntu8.23)
 grub2-common:amd64 (2.02-2ubuntu8.21, 2.02-2ubuntu8.23)
 grub-pc-bin:amd64 (2.02-2ubuntu8.21, 2.02-2ubuntu8.23)
 grub-efi-amd64-bin:amd64 (2.02-2ubuntu8.21, 2.04-1ubuntu44)
 grub-efi-amd64-signed:amd64 (1.93.24+2.02-2ubuntu8.21, 1.167~18.04.1+2.04-1ubuntu44)

Revision history for this message
Johann Gail (johann-gail) wrote :

Could this be a version mismatch?
All updates has changed from 2.02-2ubuntu8.21 to 2.02-2ubuntu8.23, except the grub-efi-amd64-bin:amd64, whgich has been upgraded to 2.04-1ubuntu44.

The version numbers of the packages differ. Could this cause the problem?

Revision history for this message
Julian Andres Klode (juliank) wrote :

We upgraded all EFI systems to the 2.04 EFI binaries. That does not look like a version mismatch problem, although we had some of those too. Might just be a fragile tpm.

Revision history for this message
Paul Henshaw (paul-sl-henshaw) wrote :

Same problem on Dell Inspiron 3593 with dual boot Windows 10 and Ubuntu 18.04.
As Johann Gail writes, this was previously working without problem until a few weeks ago.

I have not tried the tpm fix.
I have tried changing boot order, enabling/disabling secure boot - neither of these appear to solve the problem.

Typing "reboot" at the grub prompt sometimes works immediately, other times I need to reboot again before booting successfully.

Revision history for this message
Johann Gail (johann-gail) wrote :

The Inspiron 3593 does not have a dedicated Trusted Platform Module (TPM 2.0), but instead the successor Intel® Platform Trust Technology (Intel® PTT). Disabling this PTT in BIOS security settings has *NOT* improved anything.

Workaround #1 does not work for me.
Entering 'rmmod tpm' leads to 'command failed', like most of other commands too.

For me workaround #2 (unloading tpm module) seems to work. Boot never failed since the last 2 days and around 20 cold and warm reboots.

I suspect the root cause in my case was the automatic the update of the grub-efi-amd64-bin from 2.02 (bionic-security) to 2.04 (bionic-updates). I have not yet tried a downgrade of the packages due to limited access to the device.

Revision history for this message
Steve Gilbert (sg23) wrote :

I have had this same problem with my Dell Inspiron 5593 since January 2020 when I was on 18.04. Upgrading to 20.04 in June 2020 resulted in no change of the behavior.

Neither workaround works for me. "rmmod tpm" in grub results in an error due to the module not being present.

Rebooting resolves the issue, usually within 3 attempts, however I have had to reboot 7 times more than once to get past the "you need to load the kernel first".

Waiting a few seconds before hitting enter when the grub boot selection screen appears seems to improve the chances of the boot working, but this is anecdotal and could be completely random.

Revision history for this message
Krisztian VASAS (ironiq) wrote :

Actually i have an Inspiron 5593 with 18.04, but at some time i upgraded the kernel to 5.4.0 instead of original 5.0. I suspect that 20.04 has also 5.4.0 kernel, so i think the issue should be somewhere between grub and kernel. I will try those workarounds today

Yao Wei (medicalwei)
tags: added: oem-priority originate-from-1991863 somerville
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.