upgrade-from-grub-legacy: environment variable DPKG_MAINTSCRIPT_NAME is required

Bug #1879496 reported by Rolf Leggewie on 2020-05-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
grub2 (Debian)
Fix Released
Unknown
grub2 (Ubuntu)
Medium
Unassigned
Groovy
Medium
Unassigned

Bug Description

I just ran into this when upgrading a xenial system to grub2. Problem is known and fixed in grub2 2.04-4 in Debian. Patch needs to be backported to groovy, focal, bionic and xenial.

This is what it looks like (or visit the Debian bug):

# upgrade-from-grub-legacy
[...]
Found initrd image: /boot/initrd.img-3.13.0-169-generic
done
dpkg-maintscript-helper: error: environment variable DPKG_MAINTSCRIPT_NAME is required
# echo $?
1

Rolf Leggewie (r0lf) on 2020-05-19
Changed in grub2 (Ubuntu):
status: New → Confirmed
Changed in grub2 (Debian):
status: Unknown → Fix Released
tags: added: rls-gg-incoming
tags: added: groovy
removed: groo rls-gg-incoming
Changed in grub2 (Ubuntu Groovy):
importance: Undecided → Medium
tags: added: id-5ecfd87ce9f3fa3572b3c5ad
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.