eoan boot hides grub menu

Bug #1836934 reported by Alan Griffiths on 2019-07-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

I dual boot several Ubuntu versions and have edited /etc/default/grub to show them on boot (and default to the last used).

When eoan installs grub I no longer see the grub menu listing them during boot.

Holding the shift key doesn't help.

Although not displayed the menu seems to be active as I can select another install by using the cursor keys and enter.

Reinstalling and updating grub from 18.04 restores normality - once I've found 18.04 by guessing where it is on the (hidden) boot menu.
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu5
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 19.10
InstallationDate: Installed on 2019-05-22 (56 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Alpha amd64 (20190522)
Package: grub2 (not installed)
ProcVersionSignature: Ubuntu 5.2.0-8.9-generic 5.2.0
Tags: wayland-session eoan
Uname: Linux 5.2.0-8-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu5
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 19.10
InstallationDate: Installed on 2019-05-22 (56 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Alpha amd64 (20190522)
Package: grub-common 2.04-1ubuntu1
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 5.2.0-8.9-generic 5.2.0
Tags: wayland-session eoan
Uname: Linux 5.2.0-8-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

affects: initramfs-tools (Ubuntu) → grub (Ubuntu)
Steve Langasek (vorlon) wrote :

please run apport-collect 1836934.

affects: grub (Ubuntu) → grub2 (Ubuntu)
Changed in grub2 (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected eoan wayland-session
description: updated

apport information

Steve Langasek (vorlon) wrote :

Uh, ok, apparently apport-collect needs to be told the binary package name to collect against instead of the source package? apport-collect -p grub-common 1836934, please

apport information

description: updated

apport information

apport information

What are the contents of /etc/default/grub now?

Setting a GRUB_TIMEOUT to -1 should be sufficient to always show the menu, I'd expect, or is that what is not working?

Alan Griffiths (alan-griffiths) wrote :

>Setting a GRUB_TIMEOUT to -1 should be sufficient to always show the menu, I'd expect, or is that what is not working?

I'm setting it to 10 (attached) but, yes, that's what is not working: I can use the menu (up/down/enter) but can't see it - just the "Lenovo" logo.

Juraj (ojura) wrote :

I can confirm seeing this on Thinkpad W550s. Grub menu is there, but not visible on screen, which is stuck on previous bios output. Installing 18.04 grub fixes the problem.

tom (gcvl) wrote :

Happening to me on HP EliteBook 8460p UEFI install and Ubuntu MATE 20.04!
Tried all sorts of GRUB_TIMEOUT and GRUB_TIMEOUT_STYLE settings to no avail.

GRUB menu *IS* actually there but it won't show up: it just freezes on a black screen until the timeout expires or a key is pressed.

tom (gcvl) wrote :

Manually downgrading to GRUB 2.02 from Bionic "solves" the issue.
Grub-efi 2.04 seems to be broken, then.

tom (gcvl) wrote :

grub-efi version 2.04-5 installed from Debian archives does not have this issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers