Add "dis_ucode_ldr" to linux boot options for Recovery Mode

Bug #1831789 reported by Jeroen Bobbeldijk
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
High
Unassigned
grubzfs-testsuite (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
Undecided
Unassigned

Bug Description

[Impact]
Due to some recent problems with a microcode update which broke booting of some laptops I suggest adding "dis_ucode_ldr" to recovery mode boot options to allow booting after a bad microcode update.

See the following topics that describe the problems:
 - https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1829620
 - https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files/issues/1

When such problems occur it's very hard to see that the microcode loading is the issue, the booting just hangs at the purple screen, even removing "quiet splash" or using the recovery option will not show the error.

We'll need to double check that dis_ucode_ldr works as expected across all architectures.
According to the kernel docs (Documentation/admin-guide/kernel-parameters.txt), dis_ucode_ldr is x86 only, so my guess is that it will be ignored for other architectures. According to the kernel code (arch/x86/kernel/cpu/microcode/core.c), dis_ucode_ldr works for both AMD and Intel.
I have some time tomorrow on test this on a ARM device.

This was also discussed Ubuntu Developer mailing list where it was suggested to post this here, see: https://lists.ubuntu.com/archives/ubuntu-devel/2019-June/040725.html

[Test case]
Check that dis_ucode_ldr is present on Linux entries (zsys support in focal+ is verified by grubzfs-testsuite changes)

[Regression potential]
If you actually require microcode updates to get into userspace, your recovery option won't work anymore. Does this happen? Seems unlikely.

For grubzfs-testsuite, given that it is not installed, the only regression could be failing tests.

Related branches

Revision history for this message
Jeroen Bobbeldijk (jerbob92) wrote :

Related to #1829620

description: updated
description: updated
description: updated
description: updated
description: updated
Tyler Hicks (tyhicks)
Changed in grub2 (Ubuntu):
status: New → Triaged
importance: Undecided → High
Tyler Hicks (tyhicks)
Changed in grub2 (Ubuntu):
assignee: nobody → Tyler Hicks (tyhicks)
Revision history for this message
Tom Reynolds (tomreyn) wrote :

Will this likely make it into 20.04?

Changed in grub2 (Ubuntu):
assignee: Tyler Hicks (tyhicks) → nobody
tags: added: rls-gg-incoming
tags: removed: rls-gg-incoming
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu Focal):
status: New → Confirmed
tags: added: id-5ee24b2690d5d64dee0494d9
Changed in grub2 (Ubuntu Groovy):
status: Triaged → In Progress
Revision history for this message
Julian Andres Klode (juliank) wrote :
Changed in grub2 (Ubuntu Focal):
status: Confirmed → In Progress
Changed in grub2 (Ubuntu Groovy):
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.04-1ubuntu28

---------------
grub2 (2.04-1ubuntu28) groovy; urgency=medium

  * Ensure that grub-multi-install can always find templates (LP: #1879948)
  * Fix changelog entries for security update

 -- Julian Andres Klode <email address hidden> Mon, 10 Aug 2020 15:07:29 +0200

Changed in grub2 (Ubuntu Groovy):
status: In Progress → Fix Released
description: updated
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Jeroen, or anyone else affected,

Accepted grub2 into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2/2.04-1ubuntu26.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in grub2 (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Jeroen Bobbeldijk (jerbob92) wrote :

Thanks Łukasz!
It might be a bit problematic for me to test this in the same situation as I already upgraded my BIOS version, so I'm not having this issue anymore.
Of course I can still test it in my current setup, but that does not hang while booting because the latest microcode is already loaded by BIOS.

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (grub2/2.04-1ubuntu26.3)

All autopkgtests for the newly accepted grub2 (2.04-1ubuntu26.3) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

ubuntu-image/1.9+20.04ubuntu1 (arm64)
grubzfs-testsuite/0.4.10 (amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#grub2

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Changed in grub2 (Ubuntu Bionic):
status: New → Fix Committed
Changed in grub2 (Ubuntu Xenial):
status: New → Fix Committed
Changed in grub2 (Ubuntu Xenial):
status: Fix Committed → In Progress
Changed in grub2 (Ubuntu Bionic):
status: Fix Committed → In Progress
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Jeroen, or anyone else affected,

Accepted grub2 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2/2.02-2ubuntu8.18 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in grub2 (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Jeroen, or anyone else affected,

Accepted grub2 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2/2.02~beta2-36ubuntu3.28 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in grub2 (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Changed in grubzfs-testsuite (Ubuntu Groovy):
status: New → Fix Released
no longer affects: grubzfs-testsuite (Ubuntu Xenial)
no longer affects: grubzfs-testsuite (Ubuntu Bionic)
description: updated
Changed in grubzfs-testsuite (Ubuntu Focal):
status: New → In Progress
description: updated
Revision history for this message
Julian Andres Klode (juliank) wrote :

Upgraded focal's grub to ubuntu26.3 release from proposed, and dis_ucode_ldr is now present in grub.cfg for recovery entries, as intended.

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Julian Andres Klode (juliank) wrote :

Upgraded bionic to ubuntu8.18 and verified that dis_ucode_ldr appeared in grub.cfg afterwards.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Revision history for this message
Julian Andres Klode (juliank) wrote :

Upgraded xenial to ubuntu3.28 and verified that dis_ucode_ldr appeared in grub.cfg afterwards ✓

tags: added: verification-done-xenial
removed: verification-needed-xenial
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Jeroen, or anyone else affected,

Accepted grubzfs-testsuite into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grubzfs-testsuite/0.4.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in grubzfs-testsuite (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed-focal
removed: verification-done-focal
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (grubzfs-testsuite/0.4.10.1)

All autopkgtests for the newly accepted grubzfs-testsuite (0.4.10.1) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

grubzfs-testsuite/0.4.10.1 (amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#grubzfs-testsuite

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Julian Andres Klode (juliank) wrote :

grubzfs-testsuite 0.4.10.1 has passed its autopkgtest, hence verified

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for grub2 has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.04-1ubuntu26.3

---------------
grub2 (2.04-1ubuntu26.3) focal; urgency=medium

  * 2.04-1ubuntu27 and 2.04-1ubuntu28 folded together for focal
  * debian/patches/ubuntu-flavour-order.patch:
    - Add a (hidden) GRUB_FLAVOUR_ORDER setting that can mark certain kernel
      flavours as preferred, and specify an order between those preferred
      flavours (LP: #1882663)
  * debian/patches/ubuntu-zfs-enhance-support.patch:
    - Use version_find_latest for ordering kernels, so it also supports
      the GRUB_FLAVOUR_ORDER setting.
  * debian/patches/ubuntu-dont-verify-loopback-images.patch:
    - disk/loopback: Don't verify loopback images (LP: #1878541),
      Thanks to Chris Coulson for the patch
  * debian/patches/ubuntu-recovery-dis_ucode_ldr.patch
    - Pass dis_ucode_ldr to kernel for recovery mode (LP: #1831789)
  * debian/patches/ubuntu-add-initrd-less-boot-fallback.patch:
    - Merge changes from xnox to fix multiple initrds support (LP: #1878705)
  * debian/patches/ubuntu-clear-invalid-initrd-spacing.patch:
    - Remove, no longer needed thanks to xnox's patch
  * Ensure that grub-multi-install can always find templates (LP: #1879948)

 -- Julian Andres Klode <email address hidden> Mon, 17 Aug 2020 16:04:31 +0200

Changed in grub2 (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02-2ubuntu8.18

---------------
grub2 (2.02-2ubuntu8.18) bionic; urgency=medium

  * debian/patches/ubuntu-flavour-order.patch:
    - Add a (hidden) GRUB_FLAVOUR_ORDER setting that can mark certain kernel
      flavours as preferred, and specify an order between those preferred
      flavours (LP: #1882663)
  * debian/patches/ubuntu-recovery-dis_ucode_ldr.patch:
    - Pass dis_ucode_ldr to kernel for recovery mode (LP: #1831789)

 -- Julian Andres Klode <email address hidden> Mon, 24 Aug 2020 10:45:45 +0200

Changed in grub2 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02~beta2-36ubuntu3.28

---------------
grub2 (2.02~beta2-36ubuntu3.28) xenial; urgency=medium

  * debian/patches/ubuntu-flavour-order.patch:
    - Add a (hidden) GRUB_FLAVOUR_ORDER setting that can mark certain kernel
      flavours as preferred, and specify an order between those preferred
      flavours (LP: #1882663)
  * debian/patches/ubuntu-recovery-dis_ucode_ldr.patch:
    - Pass dis_ucode_ldr to kernel for recovery mode (LP: #1831789)

 -- Julian Andres Klode <email address hidden> Mon, 24 Aug 2020 10:54:59 +0200

Changed in grub2 (Ubuntu Xenial):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

grubzfs-testsuite did not build for s390x, riscv and armhf due to a depwait on zsys (?). Julian, can you take a look? I don't think I can release this with missing arches.

Revision history for this message
Julian Andres Klode (juliank) wrote :

It's not built for those architectures in release pocket either.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grubzfs-testsuite - 0.4.10.1

---------------
grubzfs-testsuite (0.4.10.1) focal; urgency=medium

  * Update for grub dis_ucode_ldr change (LP: #1831789)

 -- Julian Andres Klode <email address hidden> Wed, 12 Aug 2020 10:40:40 +0200

Changed in grubzfs-testsuite (Ubuntu Focal):
status: Fix Committed → Fix Released
tags: added: fr-166
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers