failure in fsck option of advanced boot

Bug #1807537 reported by Kevin O'Gorman on 2018-12-08
78
This bug affects 16 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

I ran into this first on a 16.04.5 install I have. I just retried it on a new laptop with 18.04.1 with the same result.

When booting, I chose the advanced form, the rescue variant, and tried to use its fsck option. This failed almost immediately. I'm attaching a photo of the screen showing the error, but the text is

/lib/recovery-mode/recovery-menu: line 80: /etc/default/rcS: No such file or directory

/dev/nvme0n1p5 is mounted.

e2fsck: Cannot continue, aborting.

--------------------------------------------------------
Thus there seems to be no point in having this fsck option because it is doomed to fail. Well, at least in the absence of further guidance about how to use this.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: grub-common 2.02-2ubuntu8.9
ProcVersionSignature: Ubuntu 4.15.0-42.45-generic 4.15.18
Uname: Linux 4.15.0-42-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
Date: Sat Dec 8 13:52:47 2018
InstallationDate: Installed on 2018-10-18 (51 days ago)
InstallationMedia: Xubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Kevin O'Gorman (kogorman-pacbell) wrote :
Revision history for this message
Tim Passingham (tim-8aw3u04umo) wrote :

I had exactly the same problem. I'm running 18.10, grub2-common 2.02+dfsg1-5ubuntu8

If I go to root from the recovery menu, my root disk is already mounted, and umount says it is busy, so I can't fsck from there either.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Revision history for this message
Belen Guaranda (bellengc) wrote :

Same issue with Ubuntu 18.04 and kernel version 4.20.0, Asus zenbook ux533fd

Revision history for this message
Chris Guiver (guiverc) wrote :

I had a look at the recovery-fsck option on this in exploring https://askubuntu.com/questions/1153259/problem-with-grub-recovery-menu-on-xubuntu-18-04-2 and had this issue.

This install is pretty fresh with almost no use as it was Xubuntu 19.10 (daily) QA-Test install of only a few days ago (manual partitioning on single partition; ext4)

guiverc@d780-xub:~$ apt-cache policy grub2
grub2:
  Installed: (none)
  Candidate: 2.02+dfsg1-12ubuntu3
  Version table:
     2.02+dfsg1-12ubuntu3 500
        500 http://ftp.iinet.net.au/pub/ubuntu eoan/universe amd64 Packages

Revision history for this message
Michael Ferris (ferrism) wrote :

Same issue with Ubuntu 20.04 kernel 4.19.13

Revision history for this message
Michael Ferris (ferrism) wrote :

Also failed with kernel 5.6.7 on Ubuntu 20.04

Revision history for this message
Hubba Zoot (z0rti) wrote :

Same with Ubuntu 20.04 LTS kernel 5.4.0-39-generic

Revision history for this message
Yutaro Yoshii (martian17) wrote :

Same with Ubuntu 20.04 LTS kernel 5.4.0-40-generic

Revision history for this message
henrique klein pedroso (hkleinp) wrote :

Same with peppermint 10-amd-64

Revision history for this message
Marcos Nascimento (wstlmn) wrote :

We are on 2021-02-04, I am using ubuntu 20.04 and we have the same problem.

Changed in grub2 (Ubuntu):
assignee: nobody → Marcos Nascimento (wstlmn)
Phillip Susi (psusi) on 2021-02-04
Changed in grub2 (Ubuntu):
assignee: Marcos Nascimento (wstlmn) → nobody
Revision history for this message
Marcos Nascimento (wstlmn) wrote :

???

Revision history for this message
Jerry Lee (jerry-lee-tpe) wrote :

In recovery mode, the root file system is still mounted.

My suggestions for this issue:

* Remove this `fsck` item in the recovery mode
* Modify the “friendly-recovery” package: /lib/recovery-mode/recovery-menu
    Let fsck to skip the root file system by the option -R.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers