System fails to boot with \EFI\BOOT\mmx64.efi - Not Found

Bug #1798171 reported by Jean-Baptiste Lallement on 2018-10-16
106
This bug affects 22 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
High
Mathieu Trudel-Lapierre
Disco
High
Mathieu Trudel-Lapierre
grub2 (Ubuntu)
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

System: Dell Inspiron 11 3137 - BIOS A05 Phoenix SecureCore Technology

Cosmic desktop installation on UEFI system with secure boot enabled, third party drivers checked, installation on entire disk.

On boot the system fails with:

Failed to open \EFI\BOOT\mmx64.efi - Not Found
Failed to load image \EFI\BOOT\mmx64.efi - Not Found
Failed to start MokManager: Not Found
Something has gone seriously wrong: import_mok_state() failed
: Not Found

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-8-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
Date: Tue Oct 16 19:26:56 2018
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper --
InstallationDate: Installed on 2013-09-03 (1868 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130902)
ProcEnviron:
 LANG=C.UTF-8
 TERM=xterm-256color
 SHELL=/bin/bash
 PATH=(custom, no user)
SourcePackage: ubiquity
UpgradeStatus: Upgraded to cosmic on 2018-01-26 (263 days ago)

Jean-Baptiste Lallement (jibel) wrote :
description: updated

Can you please boot on a live CD and run "sudo efibootmgr -v"?

Jean-Baptiste Lallement (jibel) wrote :

installer logs from the affected system

Jean-Baptiste Lallement (jibel) wrote :

I cannot reproduce on any other machine, setting to incomplete for now.

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Pau Ronda Bolta (pauronda) wrote :

I have the same problem, I updated some packages yesterday and I have to run in NON-SECURE option in UEFI. I have the NVIDIA up to date (before I could use the graphic card)

Changed in mokutil (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
tags: added: rls-dd-incoming
Jean-Baptiste Lallement (jibel) wrote :

@Pau, could you boot your system (with secure boot disable), then from a terminal run the command in command #3:

sudo efibootmgr -v

and paste the output.

Thanks

I think we'll also need to see what's in /boot/efi in general:

sudo ls -latrR /boot/efi

There is absolutely no reason for mmx64.efi to be missing, ever -- it's the indication of an incomplete install, or at the very least an issue with the firmware of the system. We always install mmx64.efi.

Clearly not a bug in mokutil if we're having issues with booting -- I'm removing the task.

no longer affects: mokutil (Ubuntu)
Steve Langasek (vorlon) wrote :

> I cannot reproduce on any other machine, setting to incomplete for now.

Please include in the bug description what machine this is happening on (and firmware revision also, please).

Adam Conrad (adconrad) wrote :

Note from the subject line, mmx64 isn't missing, but the firmware is looking for it in /BOOT/ while it lives in /ubuntu/ ... Not sure why this is, however.

This is the output on the Inspiron 11 with secure boot off

BootCurrent: 0013
Timeout: 0 seconds
BootOrder: 0000,0010,0011,0012,0013,0014,0015,0016,0017,0018,0019,001A,001B
Boot0000* ubuntu HD(1,GPT,efb1a75e-ea53-471c-a21d-17bad475f131,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0010 Setup FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0011 Boot Menu FvFile(86488440-41bb-42c7-93ac-450fbf7766bf)
Boot0012* Removable Drive VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,20699b27e1a34f488e97534d40523c1d)
Boot0013* Hard Drive VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,f5b01cc8ce8e9841b3a8fb94b6dfefee)
Boot0014* USB Storage Device VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6895f49a99882e4bb0da03ec784d2828)
Boot0015* CD/DVD/CD-RW Drive VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,3750dce1249e1748876bee5d3f25ebfb)
Boot0016* Network VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6567de8ee595634d842b325e6a43510b)
Boot0017* Onboard NIC VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,1b7f7356e3475744a9a6ed8e91832083)
Boot0018* Onboard NIC VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,b4a054dda1fa7043abf832c5a88367a6)
Boot0019 Diagnostics FvFile(be77e3c1-eb5a-4a5d-897f-536e8b3c74c0)
Boot001A Peripheral Device setting (OPROM setting) FvFile(be77e3c1-eb5a-4a5d-897f-536e8b3c74c0)
Boot001B Change boot mode setting FvFile(be77e3c1-eb5a-4a5d-897f-536e8b3c74c0)

ls -altrR /boot/efi/

/boot/efi/:
total 12
drwx------ 3 root root 4096 Dec 31 1969 .
drwx------ 4 root root 4096 Oct 16 13:30 EFI
drwxr-xr-x 4 root root 4096 Oct 17 12:51 ..

/boot/efi/EFI:
total 16
drwx------ 3 root root 4096 Dec 31 1969 ..
drwx------ 2 root root 4096 Oct 16 13:30 BOOT
drwx------ 4 root root 4096 Oct 16 13:30 .
drwx------ 3 root root 4096 Oct 17 12:12 ubuntu

/boot/efi/EFI/BOOT:
total 2500
drwx------ 4 root root 4096 Oct 16 13:30 ..
drwx------ 2 root root 4096 Oct 16 13:30 .
-rwx------ 1 root root 1213032 Oct 17 12:49 fbx64.efi
-rwx------ 1 root root 1334816 Oct 17 12:49 BOOTX64.EFI

/boot/efi/EFI/ubuntu:
total 3716
drwx------ 4 root root 4096 Oct 16 13:30 ..
-rwx------ 1 root root 71400 Oct 17 12:12 fwupx64.efi
drwx------ 2 root root 4096 Oct 17 12:12 fw
drwx------ 3 root root 4096 Oct 17 12:12 .
-rwx------ 1 root root 1334816 Oct 17 12:49 shimx64.efi
-rwx------ 1 root root 1269496 Oct 17 12:49 mmx64.efi
-rwx------ 1 root root 1105784 Oct 17 12:49 grubx64.efi
-rwx------ 1 root root 126 Oct 17 12:49 grub.cfg
-rwx------ 1 root root 108 Oct 17 12:49 BOOTX64.CSV

/boot/efi/EFI/ubuntu/fw:
total 8
drwx------ 3 root root 4096 Oct 17 12:12 ..
drwx------ 2 root root 4096 Oct 17 12:12 .

description: updated
Pau Ronda Bolta (pauronda) wrote :
Download full text (35.7 KiB)

Sorry, I have a lot of old efi entries (OEM/WINDOWS)

BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0001,0050,0003,0002,0004,2001,2002,2003
Boot0000* ubuntu HD(2,GPT,ea852bc6-160a-4d85-b643-54fefb672533,0x12c800,0x96000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* LINUXmint PciRoot(0x0)/Pci(0x1f,0x2)/Sata(1,0,0)/HD(2,GPT,ea852bc6-160a-4d85-b643-54fefb672533,0x12c800,0x96000)/File(\EFI\ubuntu\grubx64.efi)A01 ..
Boot0002* prova PciRoot(0x0)/Pci(0x1f,0x2)/Sata(1,0,0)/HD(2,GPT,ea852bc6-160a-4d85-b643-54fefb672533,0x12c800,0x96000)/File(\EFI\Boot2\bootx64.efi)A01 ).
Boot0003* ubuntu PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,ea122195-44ef-4422-829e-418f899c895e,0xfa000,0x31800)/File(\EFI\ubuntu\grubx64.efi)A01 ..
Boot0004* prova2 PciRoot(0x0)/Pci(0x1f,0x2)/Sata(1,0,0)/HD(2,GPT,ea852bc6-160a-4d85-b643-54fefb672533,0x12c800,0x96000)/File(\EFI\Boot\bootx64.efi)A01 9.
Boot0005* Unknown Device: HD(2,GPT,ea852bc6-160a-4d85-b643-54fefb672533,0x12c800,0x96000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0050* Windows Boot Manager HD(2,GPT,ea852bc6-160a-4d85-b643-54fefb672533,0x12c800,0x96000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot2001* EFI USB Device RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC

/boot/efi/:
total 20
drwx------ 4 root root 4096 de ge 1 1970 .
-r-x------ 1 root root 512 d’ag. 22 2015 BOOTSECT.BAK
drwx------ 2 root root 4096 de de 14 2015 'System Volume Information'
drwx------ 7 root root 4096 de se 16 14:44 EFI
drwxr-xr-x 4 root root 4096 d’oct 16 21:31 ..

'/boot/efi/System Volume Information':
total 12
drwx------ 4 root root 4096 de ge 1 1970 ..
-rwx------ 1 root root 76 de de 14 2015 IndexerVolumeGuid
drwx------ 2 root root 4096 de de 14 2015 .

/boot/efi/EFI:
total 28
drwx------ 4 root root 4096 de ge 1 1970 ..
drwx------ 4 root root 4096 de fe 7 2015 Microsoft
drwx------ 2 root root 4096 de fe 7 2015 Boot2
drwx------ 3 root root 4096 de fe 7 2015 OEM
drwx------ 7 root root 4096 de se 16 14:44 .
drwx------ 3 root root 4096 de se 16 14:45 ubuntu
drwx------ 2 root root 4096 de se 16 14:45 Boot

/boot/efi/EFI/Microsoft:
total 20
drwx------ 42 root root 8192 de fe 7 2015 Boot
drwx------ 4 root root 4096 de fe 7 2015 .
drwx------ 2 root root 4096 d’ag. 22 2015 Recovery
drwx------ 7 root root 4096 de se 16 14:44 ..

/boot/efi/EFI/Microsoft/Boot:
total 5300
drwx------ 2 root root 4096 de fe 7 2015 zh-TW
drwx------ 2 root root 4096 de fe 7 2015 zh-HK
drwx------ 2 root root 4096 de fe 7 2015 zh-CN
drwx------ 2 root root 4096 de fe 7 2015 uk-UA
drwx------ 2 root root 4096 de fe 7 2015 tr-TR
drwx------ 2 root root 4096 de fe 7 2015 sv-SE
drwx------ 2 root root 4096 de fe 7 2015 sr-Latn-RS
drwx------ 2 root root 4096 de fe 7 2015 sr-Latn-CS
drwx------ 2 root root 4096 de fe 7 2015 sl-SI
drwx------ 2 root root 4096 de fe 7 2015 sk-SK
drwx------ 2 root root 4096 de fe 7 2015 ru-RU
drwx------ 2 root root 4096 de fe 7 2015 ro-RO
drwx------ 4 root root 4096 de fe 7 2015 Resources
drwx------ 2 root roo...

Pau Ronda Bolta (pauronda) wrote :

Using an ACER Aspire v3-572G-70Q8, NVIDIA GEFORCE 840M

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1798171

tags: added: iso-testing
Steve Langasek (vorlon) on 2018-10-17
affects: ubiquity (Ubuntu) → grub2 (Ubuntu)
Steve Langasek (vorlon) on 2018-10-17
Changed in grub2 (Ubuntu):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02+dfsg1-5ubuntu8

---------------
grub2 (2.02+dfsg1-5ubuntu8) cosmic; urgency=medium

  * debian/patches/grub-install-extra-removable.patch: install mmx64.efi to
    the EFI removable path to avoid boot failures after install when certs
    need to be enrolled and the system's firmware is confused. (LP: #1798171)

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 17 Oct 2018 14:44:49 -0400

Changed in grub2 (Ubuntu):
status: Fix Committed → Fix Released
Tuomas Jaakola (iqqmut) wrote :

I was about to install Ubuntu 18.10 into laptop (MSI GT62VR 7RE Dominator Pro) using USB installation media. It was able to boot up and start installation until the installation halted with a black screen. After I rebooted I got the same error about missing mmx64.efi.

Windows 10 boots up fine without Ubuntu installation USB stick, but when I try to boot up using the stick, it fails every time giving me the same error. So I can't even start installation or use a command line from USB stick anymore. In /EFI/BOOT/ there are only BOOTx64.EFI and grubx64.efi files, mmx64.efi file is missing there (should it be there?).

The installation USB stick is created in another machine, using Startup Disk Creator from Ubuntu 18.04.

Thank you for fixing grub2! How can I use patched grub2 and create a new Ubuntu installation USB stick which would work? Or what should I do?

Tuomas Jaakola (iqqmut) wrote :

However, using the same usb-creator-gtk (version 0.3.5) in Ubuntu 18.04, I created an installation USB stick from Ubuntu 18.04. That works without any problem in MSI laptop. There is no /EFI/BOOT/mmx64.efi file either in that USB stick, but it works anyway.

The result is that I am not able to install Ubuntu 18.10 at all.

Tuomas Jaakola (iqqmut) wrote :

Even though Ubuntu 18.04 installation USB stick works fine, I see same kind of mmx64.efi error flashing quickly. However it does not halt there unlike in Ubuntu 18.10 installation media.

The error I see when booting up with Ubuntu 18.04 installation media:

Failed to open \EFI\BOOT\mmx64.efi - Not Found
Failed to load image \EFI\BOOT\mmx64.efi: Not Found
Failed to start MokManager: Not Found
error: file `/boot' not found.

After this error it loads grub nicely and starts Ubuntu 18.04 installation.

Tuomas Jaakola (iqqmut) wrote :

Now I have Ubuntu 18.10 installed.

Workaround is to use a working grub2 (for example booting up with Ubuntu 18.04 installation media) and move to grub command line. There I created a new menuentry for loading Ubuntu 18.10 installer from another USB stick.

https://askubuntu.com/questions/436519/boot-efi-files-from-grub2

Jack Zhang (jackz314) wrote :

I am facing the same problem now with Ubuntu 18.10. I entered the live environment once after creating the bootable USB disk, then after a reboot, it shows the error message as described as above. Is this a bug or is there something wrong with my system?

Here the same issue. I try to do a fresh install of Ubuntu 18.10
After stopping the isnstallation and rebooting from a 18.10 bootable USB-stick:

ailed to open \EFI\BOOT\mmx64.efi - Not Found
Failed to load image \EFI\BOOT\mmx64.efi - Not Found
Failed to start MokManager: Not Found
Something has gone seriously wrong: import_mok_state() failed
: Not Found

I tried to repartition and recreate the boot USB stick from scratch but still the same error message.
machine is Intel NUC 8i5BEK. No other OSs.
Any idea what is going wrong?

Hello, I have the same problem with my Ace aspire A515-51G, when starting by USB it can not load the mmx64.efi file. As additional information, the problem occurred in the installation, when the installer asked me to enter a password for UEFI. The system was stuck a few moments and then it was restarted, the installation was not finished. From that moment I can not see the message reported in the Bug.

The USB Live installer was created from win10 with Rufus (v3.3)

TJ (tj) wrote :

I've been helping a user on IRC #ubuntu reporting this problem using the 18.10 ISO installer. In this case during the (first) installer run the PC crashed and rebooted before completing the install.

From then on trying to boot the installer is failing with these error messages:

Failed to open \EFI\BOOT\mmx64.efi - Not Found
Failed to load image \EFI\BOOT\mmx64.efi - Not Found
Failed to start MokManager: Not Found
Something has gone seriously wrong: import_mok_state() failed

"Failed to start MokManager" is reported by the shim's shim.c::check_mok_request().

The cause is the system's EFI NVRAM contains variable names starting "Mok*" - added by the failed installer run.

As a result of theses variables being present shimx64.efi tries to load "mmx64.efi" and due to it not being in the installer's EFI system partition it fails with this report.

The problem now is that there is no easy way to remove these stray variables.

Kasper Petersen (fantyzz) wrote :

I appear to have the same issue as described by comment #24/#25.

The installer didn't crash on me though. I also typed in a password and continued, but it didn't crash on me. I aborted the installation when picking where to install to due to needing to change settings in my BIOS for Ubuntu to be able to detect my HDD.

Currently I'm unable to even boot the bootable Ubuntu USB I made without this happening. I can boot the USB if I disable EFI entirely and boot using legacy. I still have Windows installed on it and this boots normally.

I would really appreciate help resolving this asap.

If you are seeing this issue, what image are you using? Have you tried booting to Ubuntu without the ISO connected?

Kasper Petersen (fantyzz) wrote :

I don't have Ubuntu installed. The incomplete installation is what put me in this situation to begin with.

I use a fresh Ubuntu 18.10 ISO I just downloaded today.

Kasper Petersen (fantyzz) wrote :

ubuntu-18.10-desktop-amd64.iso to be exact.

Eli (eli456) wrote :

Hello
I have been having the issue described by Jean in the original description. Same exact error message when trying to boot Ubuntu 18.04, seems like Grub isn't being installed correctly.
This issue is new after a Windows update and I wasn't being given the option to boot into Linux.
I reinstalled (from mint to Ubuntu), and now am seeing the error message as above.
I'm running a Lenovo Thinkpad 13, and everything has been working fine until this Windows update.
I'm a bit of a noob, so any help/advice would be very appreciated.

Exactly same problem like #25. I found MokAuth and MokNew in efivars, but was unable to remove them. Other distros are able to boot.

Thomas Bjurlof (tbjurlof) wrote :

Same problem: Initial boot from Ubuntu 18.10 USB worked but the installation crashed while I was inputting information (black screen). Was then able to boot from Windows 10 USB stick and install. Windows works fine. But still not able to boot from Ubuntu USB with message:

Failed to open \EFI\BOOT\mmx64.efi - Not Found
Failed to load image \EFI\BOOT\mmx64.efi: Not Found
Failed to start MokManager: Not Found
Somethinghas gone seriously wrong: import_mok_state() failed : Not Found

Tried both secure and not secure boot. I am not an expert so I am lost at this point.

Thomas Bjurlof (tbjurlof) wrote :

Forgot to mention hardware = Intel NUC Kit NUC8i7HVK.

Finally, I managed to find workaround. I had made a copy of /EFI/BOOT/grubx64.efi with the name mmx64.efi on the bootable medium. After this, the USB disc was able to boot again and I was able to continue with installation process. After successful instalation wverything was OK.

Thomas Bjurlof (tbjurlof) wrote :

Ondrej would you be able to step me through this. I am a novice and want to make sure I do not mess anything up. Thx!

Eli (eli456) wrote :

Ondrej Was there already a file named mmx64.efi in the /EFI/BOOT/ folder?
This seems strange as I already have a file by that name so I don't want to write over it!

After weeks of searching like Ondrej, the problem was that in the bootable USB dint't exist the file mmx64.efi so the workaround was to copy de existing file grubx64.efi and rename to mmx64.efi in the bootable USB drive (so USB Drive folder /EFI/BOOT now i have three files BOOTx64.EFI, grubx64.efi and mmx64.efi). Then, reboot and the installation should work.
As an context, i created the USB bootable drive from win10 with rufus

Akeo (b-pete-r) wrote :

Rufus developer here. I am indeed seeing sporadic reports from users running into the bug above after they created installation media from the Ubuntu ISO (NB: For most UEFI bootable media generation, what Rufus does is simply copy the ISO content to a FAT32 file system on the USB), and the root of the appears to be be that, even if a Ubuntu GRUB installation does generate mmx64.efi on system install, there is no trace of any mmx64.efi anywhere in the ISO for the initial boot (even in /boot/grub/efi.img).

So I think you guys should make sure that you do include mmx64.efi in /efi/boot/ on the installation ISOs you generate.

Also note that I am seeing similar reports from people who aren't using Rufus at all and are simply copying content to a FAT32 media they created themselves.

Eli (eli456) wrote :

Update:

I copied mmx64.efi from /efi/boot on my hard drive to the same location in the iso.
I now receive the below warning and system attempts to bootloop forever:

System BootOrder not found. Initializing defaults.
Creating Boot entry "Boot0002" with label "ubuntu" for file "\EFI\ubuntu\shim64.efi"
Reset System

I searched this error message and found this:
https://askubuntu.com/questions/1042747/system-bootorder-not-found

but since I have a Lenovo this BIOS looks different and I am unable to find "Select an UEFI file as trusted for executing"

Once again, if anybody has any solutions it'd be great :)

Hi, yes i've tried with unetbootin and there was the same problem. Akeo (b-pete-r)
The iso image don't have the mmx64.efi file and i don't know if that should be auto generated on install or not.
For example, i've have no problem with Rufus and Unetbootin with the ubuntu 18.08.1.. so i thik is the iso of the 18.10 image that have the problem
Iv'e hope that helps

  // , Just downloaded the latest Ubuntu (18.10), and created an image with the Ubuntu Startup Disk Creator for it.

The first time I ran the disk on my laptop, I was able to start up Ubuntu.

The second time I ran this bootdisk, though, I had no luck.

The only difference between the first and the second time is that, before the second time, I completely shut down Windows on my X1 Carbon laptop.

SoulTaker (abbyssoul) wrote :

Exactly the same problem here as ScarySquirrel described above.
A new X1 carbon, updated windows 10.
Was able to boot from a live USB once. Decided to restart laptop to install Ubuntu later.
```Failed to open \EFI\BOOT\mmx64.efi - Not Found
Failed to load image \EFI\BOOT\mmx64.efi - Not Found
Failed to start MokManager: Not Found
Something has gone seriously wrong: import_mok_state() failed
: Not Found
```
From there on. No luck booting live USB.
Please help.

Miguel Alcaide (migalc) wrote :

I think I got a download this way, thank you.

Changed in grub2 (Ubuntu):
assignee: nobody → Miguel Alcaide (migalc)

Same issue on an ASUS ROG G751-VT.
Installation media made with Rufus v3.4.
ISO downloaded 2019-01-15
Only difference for me was, the graphical install hung right after I setup secure boot password and then tried to proceed to the next screen. I assumed it was related to that when I saw the error complaining about MokManager. Created a new bootable usb using Startup Disk Creator on my working Ubuntu Desktop. Still no luck.

Error:

```Failed to open \EFI\BOOT\mmx64.efi - Not Found
Failed to load image \EFI\BOOT\mmx64.efi - Not Found
Failed to start MokManager: Not Found
Something has gone seriously wrong: import_mok_state() failed
: Not Found
```

Nexus (nexus321) wrote :

The proposed workaround to create the mmx64.efi in /EFI/BOOT/ doesn't work for me.

Does anybody know, which efi variable has been created by the installer, that triggers the wrong boot process in the usb drive? In this case, deleting or editing it, would be an option to try.

T0beus (t0beus) wrote :

It looks like the Ubuntu default installation ISOs (18.10 and 18.04.1) from Ubuntu.com are still missing /EFI/BOOT/mmx64.efi. Getting the same error on Asus Sabertooth S170 Mark 1 motherboard on fresh install. Can’t install Ubuntu due to missing mmx64.efi error.

Ubuntu 18.10 - Lenovo IdeaPad 700-15

It's working for me ):
1. Create installation USB with Unetbootin.
2. Copy /EFI/BOOT/grubx64.efi to /EFI/BOOT/mmx64.efi
3. Boot with UEFI and install...
:-) Thanks.

benj (benj12) wrote :

Comment #47 seems to have worked for me as well :), though step 1 is varied

1. Created Ubuntu 18.10 installation USB with Dell Media Creation Utility Tool

steps 2 and 3 the same

Chuck Keely (train-nerd) wrote :

Same error message as reported above.

Ubuntu Studio 18.10 - Lenovo M700, Windows 10 Pro

1) Created installation USB with Rufus
2) Open installation USB with W10 File Explorer
3) Navigate to /EFI/BOOT/grubx64.efi
4) Right click file grubx64.efi
5) Rename file to mmx64.efi
6) Proceed with Ubuntu installation
7) Success!
8) Lots to learn about Ubuntu ;-)

Mk4UmHa (mk4umha) wrote :

Yea, i'm stuck stuck on my Lenovo P1 just like #45, even after copying over.

/EFI/BOOT/grubx64.efi to /EFI/BOOT/mmx64.efi

This time the Lenovo Logo doesn't disappear and I don't have those errors but it's just sitting there and the grub doesn't show up. I tried setting the Video to Discrete and Hybrid mode and nothing changes.

Panu Kalliokoski (pkalliok) wrote :

I was able to solve this with the information from comment #25.

I booted my system with a separate system rescue CD stick (see http://www.system-rescue-cd.org/). Then, in rootshell, I did:

# chattr -i /sys/firmware/efi/efivars/Mok*
# rm /sys/firmware/efi/efivars/Mok*

After this, the Ubuntu installer is able to boot from stick.

Note that the actual error is *not* this:
Failed to open \EFI\BOOT\mmx64.efi - Not Found
Failed to load image \EFI\BOOT\mmx64.efi - Not Found

But this:
Failed to start MokManager: Not Found
Something has gone seriously wrong: import_mok_state() failed
: Not Found

Mk4UmHa (mk4umha) wrote :

That worked!!!! Thanks!!

dundir (dundir) wrote :

I can confirm this issue impacts the current ISO for the 18.04.2 LTS release.

Impacted installation was on a Dell Inspiron 3668 with firmware version 1.3.4.

Ubuntu LiveUSB has the above error and is unable to boot after a failed installation with the Secure Boot configuration checked in the installer. After disabling SupportAssist it shows the error in #51;

Clonezilla booting into EFI doesn't enumerate as a boot option; I'm finding it difficult to get access to efibootmgr/efivars to fix this.

I'll be trying system-rescue-cd next in my next attempt to make the proposed changes mentioned in #51.

Any help or suggestions is much appreciated. Anyone happen to know a way of accessing efibootmgr/efivars from a legacy boot?

dundir (dundir) wrote :

Additional Information:

system-rescue-cd was able to boot in EFI mode. Other ubuntu/debian based usb sticks either could not be enumerated; or failed with the previously mentioned error. Once I was able to boot up into EFI mode it was a simple fix thanks to Panu.

An observation:
The Secure Boot Configuration Option for the installer asks you to enter a password prior to installing, and then repeat that password at the next boot. There is no prompt at the next boot or place to enter a password, and failure at this point, I'm guessing, is what caused the installation to fail, and the various USB sticks to not boot/not enumerate.

Changed in grub2 (Ubuntu):
assignee: Miguel Alcaide (migalc) → nobody

Disabling Secure Boot temporarily in order to finish the installation (mmx64.efi is supposed to be installed on disk at the end of the install), or editing an installation image on USB to copy

grubx64.efi in a new file called mmx64.efi

Should be good workarounds for this.

Please don't run a system-rescue-cd or such custom "rescue" images to manually remove files from /sys/firmware/efi/efivars -- it *can* be done, but it's quite dangerous, likely to brick you system in a way that *can't* be recovered. As per the above, the right fix is to finish the installation and run the real mmx64.efi either by disabling Secure Boot in your firmware (but NOT switching to Legacy boot) or making the mmx64.efi available as a copy of grub.

Changed in debian-installer (Ubuntu):
importance: Undecided → High
Changed in debian-installer (Ubuntu):
status: New → Fix Committed
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
tags: removed: rls-dd-incoming
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu567

---------------
debian-installer (20101020ubuntu567) disco; urgency=medium

  * build/util/efi-image: make MokManager available in EFI images.
    (LP: #1798171)

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 20 Mar 2019 15:57:02 -0400

Changed in debian-installer (Ubuntu Disco):
status: Fix Committed → Fix Released
Max Gaukler (mgmax) wrote :

Would it be possible to backport the fix from 19.04 to 18.04 LTS? The bug is quite difficult to work around, and easy to trigger - just abort the setup some time after checking the third-party-drivers box.

For anyone who still needs a workaround for 18.04, because you for some reason don't want to install a newer version:

I am assuming you are installing Ubuntu from a USB stick, which was created from the dowloaded ISO file.
The problem with most previous suggested workarounds is that the stick shows up "read-only" because of the iso9660 filesystem), so you can't just copy the file as suggested.

Use a second USB stick, format it with GPT partition table and FAT32 filesystem.
Copy the folder <Ubuntu install stick>/EFI to <your new stick>/EFI.
Copy <your new stick>/EFI/grubx64.efi to <your new stick>/EFI/mmx64.efi
Plug both sticks into the PC to be installed, boot from the new stick.
Now you are in the GRUB bootloader, but on the "new" stick which is missing the rest of the Ubuntu setup files.
Press c (commandline)
set root=(hd1)
Note: (hd1) is the "old" Ubuntu install stick. In your system, the number may be different, e.g. (hd2). Press "Tab" twice to see information about the drive; the right one will show up as "Ubuntu 18.04"
Press Enter, Press ESC
Select "Install ubuntu". Install ubuntu as usual.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers