Xubuntu 18.10 daily image install; grub installed to non-system-boot-drive

Bug #1795229 reported by Chris Guiver on 2018-09-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Testing Xubuntu 18.10 (x86 or 32bit) image...

After install first boot pulls up a non-Ubuntu version of grub that was already on system (including an option for an OS that was replaced by Xubuntu 18.10 install), so Xubuntu 18.10 on first boot post-install didn't complete.

This system has more than a single hdd; GRUB was installed to a different drive to that which the BIOS treats as the first HDD, requiring me to change BIOS to boot a different (non-SATA in this case) hdd first before Xubuntu grub appeared.

There was no question asking me on which drive to install GRUB (stage 0 or MBR), it guessed wrong.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: grub2-common 2.02+dfsg1-5ubuntu4
ProcVersionSignature: Ubuntu 4.18.0-7.8-generic 4.18.5
Uname: Linux 4.18.0-7-generic i686
ApportVersion: 2.20.10-0ubuntu11
Architecture: i386
CurrentDesktop: XFCE
Date: Sun Sep 30 21:58:52 2018
InstallationDate: Installed on 2018-09-30 (0 days ago)
InstallationMedia: Xubuntu 18.10 "Cosmic Cuttlefish" - Beta i386 (20180929)
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

Chris Guiver (guiverc) wrote :
description: updated
tags: added: iso-testing

Thanks for taking the time to file a bug and helping to make Ubuntu better! Could you please answer the following questions to help us better understand the problem?

What system model are you installing on? Is this the i386 or the amd64 image (your bug says it's a i386 image, but have you tested both?)

What kind of disks are installed in this system?

Is this system booting in UEFI mode at install? (do you see a text box with entries, or an Ubuntu logo and a pretty menu when you boot the CD to install?)

Changed in grub2 (Ubuntu):
status: New → Incomplete
Chris Guiver (guiverc) wrote :

Sorry - some of this info is on QA-tracker, and I hadn't realized I'd omitted to put it here also

HP DX6120MT (mini-tower, pentium 4 dual core, 1.5gb ram, nvidia 7600gt)
`lshw` output already attached, ~2003-2004 hp

It's a x86 image, and I just tried a randomly chosen (16.04.3 LTS) x86_64 image which gave me
"This kernel requires a x86_64 CPU, but only detected an i686 CPU.
Unable to boot - please use a kernel appropriate for your CPU"

Machine doesn't have UEFI, the bios seems to treat PATA disks as higher priority than SATA; the bios is awkward. I have two SATA (80gb) drives enclosed, plus a single PATA (32gb). All are old spinning-rust.

On booting the Xubuntu image, I get the common (legos in box = guy in circle bottom centre), then a xubuntu plymouth screen (circling) before the Xubuntu 18.10 background wallpaper giving me the choice of "try xubuntu" or "install xubuntu" (with language selection on left). All GUI.

Launchpad Janitor (janitor) wrote :

[Expired for grub2 (Ubuntu) because there has been no activity for 60 days.]

Changed in grub2 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers