High delay when booting (grub waits with a blank purple screen for 10 seconds before booting the kernel)

Bug #1784363 reported by Vitaliy Kanev on 2018-07-30
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
High
Mathieu Trudel-Lapierre
Bionic
High
Mathieu Trudel-Lapierre
grub2-signed (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Test case]
1. Install grub-pc 2.02-2ubuntu8.7 from bionic-updates.
2. Reboot
3. Observe there is a 10 second delay before the kernel boots.
4. Install grub-pc 2.02-2ubuntu8.9 from bionic-proposed.
5. Reboot
6. Observer that the 10 second delay has disappeared.

External information
--------------------

vitalkanev@<hostname>:~$ lsb_release -rd && echo && LANG=C apt policy grub-pc && echo && uname -a
Description: Ubuntu 18.04.1 LTS
Release: 18.04

grub-pc:
  Installed: 2.02-2ubuntu8.2
  Candidate: 2.02-2ubuntu8.2
  Version table:
 *** 2.02-2ubuntu8.2 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2.02-2ubuntu8 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Linux <hostname> 4.15.0-29-generic #31-Ubuntu SMP Tue Jul 17 15:39:52 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

ProblemType: BugDistroRelease: Ubuntu 18.04
Package: grub-pc 2.02-2ubuntu8.2
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: XFCE
Date: Mon Jul 30 14:00:47 2018
InstallationDate: Installed on 2018-07-15 (14 days ago)
InstallationMedia: Xubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

Vitaliy Kanev (vitalkanev) wrote :
Vitaliy Kanev (vitalkanev) wrote :

Well... I think syslog is important

Phillip Susi (psusi) wrote :

Please attach your /boot/grub/grub.cfg. Also the 15 seconds you are counting are with the grub menu visible? If you hit enter to boot right away is there still a significant delay after that?

Changed in grub2 (Ubuntu):
status: New → Incomplete
Daniel van Vugt (vanvugt) wrote :

WORKAROUND:

1. Edit /etc/default/grub and change GRUB_TIMEOUT to 0 or 1.

2. sudo update-grub

3. Your machine now boots 9-10 seconds faster, which is a big deal for modern machines that took 15-20 seconds before. Now it's around only 5-11 seconds :)

summary: - High delay when booting
+ High delay when booting (grub waits 10 seconds before booting the
+ kernel)
Changed in grub2 (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
tags: added: cosmic
tags: added: performance
summary: - High delay when booting (grub waits 10 seconds before booting the
- kernel)
+ High delay when booting (grub waits with a blank purple screen for 10
+ seconds before booting the kernel)
Changed in grub2 (Ubuntu):
status: Confirmed → Triaged
Daniel van Vugt (vanvugt) wrote :

Verified on several cosmic machines that the above workaround does reduce the boot time by 10 seconds.

no longer affects: ubuntu-meta (Ubuntu)
tags: added: rls-cc-incoming
Iain Lane (laney) wrote :

I think when we changed to using GRUB_TIMEOUT_STYLE=hidden in

  https://launchpad.net/ubuntu/+source/grub2/2.02-2ubuntu8.2

instead of GRUB_HIDDEN_TIMEOUT, we missed updating GRUB_TIMEOUT=0. In GRUB_TIMEOUT_STYLE=hidden, GRUB_TIMEOUT is what is used.

tags: added: regression-update rls-bb-incoming
Changed in grub2 (Ubuntu):
importance: Medium → High
Steve Langasek (vorlon) on 2018-10-09
Changed in grub2 (Ubuntu Bionic):
importance: Undecided → Critical
importance: Critical → High
status: New → Triaged
tags: added: id-5bbd06e3267d904d818612ac
Changed in grub2 (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
Changed in grub2 (Ubuntu Bionic):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02+dfsg1-5ubuntu7

---------------
grub2 (2.02+dfsg1-5ubuntu7) cosmic; urgency=medium

  [ Steve Langasek ]
  * debian/grub-common.install.in: install the systemd unit that's part of
    initrd fallback handling, missed when the feature landed.

  [ Mathieu Trudel-Lapierre ]
  * debian/rules: set DEFAULT_TIMEOUT to 0 if we've enabled FLICKER_FREE_BOOT,
    to avoid unnecessary delay at boot time. (LP: #1784363)

 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 12 Oct 2018 11:10:10 -0400

Changed in grub2 (Ubuntu):
status: In Progress → Fix Released

Hello Vitaliy, or anyone else affected,

Accepted grub2 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2/2.02-2ubuntu8.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in grub2 (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Steve Langasek (vorlon) wrote :

Hello Vitaliy, or anyone else affected,

Accepted grub2-signed into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2-signed/1.93.9 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Steve Langasek (vorlon) on 2018-11-01
Changed in grub2-signed (Ubuntu):
status: New → Fix Released
Changed in grub2-signed (Ubuntu Bionic):
status: New → Fix Committed
Steve Langasek (vorlon) on 2018-11-05
description: updated
description: updated
Will Cooke (willcooke) wrote :

I have enabled proposed on a new VM install and updated everything.
grub-pc version installed is 2.02-2ubuntu8.8
I rebooted and observed the same 10 second delay.
I logged back in and ran update-grub for good measure and rebooted - I observed the same 10 second delay.
I edited the grub config and commented out the GRUB_TIMEOUT_STYLE, updated grub and rebooted. I was presented with the menu and a 10 second timer counting down.

I /think/ this means the problem isn't fixed, so marking as failed.

tags: added: verification-failed-bionic
removed: verification-needed-bionic
Will Cooke (willcooke) wrote :

GRUB_TIMEOUT is still set to 10.

Brian Murray (brian-murray) wrote :

Hello Vitaliy, or anyone else affected,

Accepted grub2 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2/2.02-2ubuntu8.9 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

description: updated
tags: added: verification-needed-bionic
removed: verification-failed-bionic
Brian Murray (brian-murray) wrote :

Hello Vitaliy, or anyone else affected,

Accepted grub2-signed into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2-signed/1.93.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers