package grub-common 2.02~beta3-4ubuntu7.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1747681 reported by Tom Thumbstone on 2018-02-06
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

grub-common (2.02~beta3-4ubuntu7.1) wird eingerichtet ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Job for grub-common.service failed because a timeout was exceeded.
See "systemctl status grub-common.service" and "journalctl -xe" for details.
invoke-rc.d: initscript grub-common, action "start" failed.
● grub-common.service - LSB: Record successful boot for GRUB
   Loaded: loaded (/etc/init.d/grub-common; generated; vendor preset: enabled)
   Active: failed (Result: timeout) since Tue 2018-02-06 15:06:15 CET; 13ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 11931 ExecStart=/etc/init.d/grub-common start (code=killed, signal=TERM)
    Tasks: 4 (limit: 4915)
   CGroup: /system.slice/grub-common.service
           ├─10178 plymouth --ping
           ├─11935 plymouth --ping
           └─18080 plymouth --ping

Feb 06 15:01:14 Prometheus systemd[1]: Starting LSB: Record successful boot for GRUB...
Feb 06 15:06:15 Prometheus systemd[1]: grub-common.service: Start operation timed out. Terminating.
Feb 06 15:06:15 Prometheus systemd[1]: Failed to start LSB: Record successful boot for GRUB.
Feb 06 15:06:15 Prometheus systemd[1]: grub-common.service: Unit entered failed state.
Feb 06 15:06:15 Prometheus systemd[1]: grub-common.service: Failed with result 'timeout'.
dpkg: Fehler beim Bearbeiten des Paketes grub-common (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von grub-pc-bin:
 grub-pc-bin hängt ab von grub-common (= 2.02~beta3-4ubuntu7.1); aber:
  Paket grub-common ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes grub-pc-bin (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von grub-pc:
 grub-pc hängt ab von grub-common (= 2.02~beta3-4ubuntu7.1); aber:
  Paket grub-common ist noch nicht konfiguriert.
 grub-pc hängt ab von grub-pc-bin (= 2.02~beta3-4ubuntu7.1); aber:
  Paket grub-pc-bin ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes grub-pc (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von grub2-common:
 grub2-cEs wurde kein Apport-Bericht verfasst, da die Fehlermeldung darauf hindeutet, dass dies lediglich ein Folgefehler eines vorherigen Problems ist.
                                                                        Es wurde kein Apport-Bericht verfasst, da die Fehlermeldung darauf hindeutet, dass dies lediglich ein Folgefehler eines vorherigen Problems ist.
                                                        Es wurde kein Apport-Bericht verfasst, da das Limit MaxReports bereits erreicht ist.
                                                            ommon hängt ab von grub-common (= 2.02~beta3-4ubuntu7.1); aber:
  Paket grub-common ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes grub2-common (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 grub-common
 grub-pc-bin
 grub-pc
 grub2-common
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 17.10
Package: grub-common 2.02~beta3-4ubuntu7.1
ProcVersionSignature: Ubuntu 4.13.0-31.34-generic 4.13.13
Uname: Linux 4.13.0-31-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
Date: Tue Feb 6 14:51:57 2018
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2016-04-23 (654 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-31-generic root=UUID=88ea44ba-206d-4d98-b5d0-142e6d878e62 ro quiet splash vt.handoff=7
Python3Details: /usr/bin/python3.6, Python 3.6.3, python3-minimal, 3.6.3-0ubuntu2
PythonDetails: /usr/bin/python2.7, Python 2.7.14, python-minimal, 2.7.14-2ubuntu1
RelatedPackageVersions:
 dpkg 1.18.24ubuntu1
 apt 1.5.1
SourcePackage: grub2
Title: package grub-common 2.02~beta3-4ubuntu7.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Tom Thumbstone (tom-thumbstone) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers