package grub-pc 2.02~beta2-36ubuntu3.9 failed to install/upgrade: подпроцесс новый сценарий pre-removal возвратил код ошибки 1

Bug #1698922 reported by Andrey Kuznetsov on 2017-06-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

Error after start update the MS fonts.
The update was finished with the error. Any install tried with this error.

sudo apt-get install google-chrome-stableЧтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Уже установлен пакет google-chrome-stable самой новой версии (59.0.3071.86-1).
Пакеты, которые будут обновлены:
  grub-pc
обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 11 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 0 B/197 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Предварительная настройка пакетов ...
dpkg: предупреждение: список файлов пакета «samba-common-bin» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
(Чтение базы данных … на данный момент установлено 277478 файлов и каталогов.)
Подготовка к замене пакета grub-pc 2.02~beta2-36ubuntu3.9 (используется файл …/grub-pc_2.02~beta2-36ubuntu3.11_amd64.deb) …
dpkg-maintscript-helper: error: command dir_to_symlink is unknown
Hint: upgrading dpkg to a newer version might help.

Usage: dpkg-maintscript-helper <command> <parameter>... -- <maintainer-script-parameter>...

Commands:
  supports <command>
 Returns 0 (success) if the given command is supported, 1 otherwise.
  rm_conffile <conffile> [<last-version> [<package>]]
 Remove obsolete conffile. Must be called in preinst, postinst and
 postrm.
  mv_conffile <old-conf> <new-conf> [<last-version> [<package>]]
 Rename a conffile. Must be called in preinst, postinst and postrm.
  help
 Display this usage information.
dpkg: предупреждение: подпроцесс старый сценарий pre-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета …
dpkg-maintscript-helper: error: command dir_to_symlink is unknown
Hint: upgrading dpkg to a newer version might help.

Usage: dpkg-maintscript-helper <command> <parameter>... -- <maintainer-script-parameter>...

Commands:
  supports <command>
 Returns 0 (success) if the given command is supported, 1 otherwise.
  rm_conffile <conffile> [<last-version> [<package>]]
 Remove obsolete conffile. Must be called in preinst, postinst and
 postrm.
  mv_conffile <old-conf> <new-conf> [<last-version> [<package>]]
 Rename a conffile. Must be called in preinst, postinst and postrm.
  help
 Display this usage information.
dpkg: ошибка при обработке параметра /var/cache/apt/archives/grub-pc_2.02~beta2-36ubuntu3.11_amd64.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 1
dpkg-maintscript-helper: error: command dir_to_symlink is unknown
Hint: upgrading dpkg to a newer version might help.

Usage: dpkg-maintscript-helper <command> <parameter>... -- <maintainer-script-parameter>...

Commands:
  supports <command>
 Returns 0 (success) if the given command is supported, 1 otherwise.
  rm_conffile <conffile> [<last-version> [<package>]]
 Remove obsolete conffile. Must be called in preinst, postinst and
 postrm.
  mv_conffile <old-conf> <new-conf> [<last-version> [<package>]]
 Rename a conffile. Must be called in preinst, postinst and postrm.
  help
 Display this usage information.
dpkg: ошибка при очистке:
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/grub-pc_2.02~beta2-36ubuntu3.11_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: grub-pc 2.02~beta2-36ubuntu3.9
ProcVersionSignature: Ubuntu 4.8.0-54.57~16.04.1-generic 4.8.17
Uname: Linux 4.8.0-54-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.6
Architecture: amd64
Date: Mon Jun 19 21:52:24 2017
ErrorMessage: подпроцесс новый сценарий pre-removal возвратил код ошибки 1
InstallationDate: Installed on 2017-06-07 (11 days ago)
InstallationMedia: Ubuntu 16.04.2 LTS "Xenial Xerus" - Release amd64 (20170215.2)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-54-generic root=UUID=8fd3f51e-eaef-497f-9fdf-dd726f763db5 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.2
 apt 1.2.20
SourcePackage: grub2
Title: package grub-pc 2.02~beta2-36ubuntu3.9 failed to install/upgrade: подпроцесс новый сценарий pre-removal возвратил код ошибки 1
UpgradeStatus: No upgrade log present (probably fresh install)

Andrey Kuznetsov (andrew209) wrote :
Phillip Susi (psusi) wrote :

Your system says it has dpkg 1.18 installed as it should, but somehow it appears that your dpkg-maintscript-helper program is from an older version. You might be able to fix it by running apt-get install --reinstall dpkg.

Changed in grub2 (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers