Ubuntu

Please sync grub2 1.95+20071101-1 from Debian unstable main

Reported by Shirish Agarwal on 2007-10-28
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Wishlist
Martin Pitt

Bug Description

Binary package hint: grub2

The grub2 package which we have is 1.95+20070604-1ubuntu1 while in debian the latest version is 1.95+20071004-2

http://packages.debian.org/changelogs/pool/main/g/grub2/grub2_1.95+20071004-2/changelog

http://packages.debian.org/sid/grub2/i386/download

Can something be done about it for Hardy perhaps?

William Grant (wgrant) wrote :

It will be merged when somebody gets around to it, as I'm sure you well know.

Changed in grub2:
status: New → Invalid
Tormod Volden (tormodvolden) wrote :

The debdiff is based on the merge from http://dad.dunnewind.net/grub2/

Changed in grub2:
status: Invalid → Confirmed

The patch looks good, but can you check with Jeff Bailey <email address hidden> if we still have to carry over the ubuntu change (disabling of the stack protector)?
Please resubscribe u-u-s when you have a confirmation (or otherwise).

Thanks!

Changed in grub2:
assignee: nobody → tormodvolden
status: Confirmed → Incomplete
importance: Undecided → Wishlist
Tormod Volden (tormodvolden) wrote :

Jeff answered:
>> Hi Jeff,
>> Do you know if grub2 still needs the -fno-stack-protector ?
>
>As of gcc-4.2 (4.2.1-5ubuntu2) gutsy, this should no longer be needed.

In which case, we can just sync the package.

For the sync request:
The only Ubuntu change was the debian/patches/10_disable-stack-protector.patch which is no longer needed.

Changed in grub2:
assignee: tormodvolden → nobody
status: Incomplete → Confirmed
Cesare Tirabassi (norsetto) wrote :

Sync request ack'ed to Archive.

Martin Pitt (pitti) wrote :

Synced.

Changed in grub2:
assignee: nobody → pitti
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers