Continued TFTP timeouts when PXE booting via grub

Bug #1521612 reported by Andrew Cloke on 2015-12-01
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
High
Mathieu Trudel-Lapierre
Trusty
High
dann frazier
Vivid
High
dann frazier
Wily
High
dann frazier
Xenial
High
Mathieu Trudel-Lapierre
grub2-signed (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Vivid
Undecided
Unassigned
Wily
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[Impact]
While the Grub2 patches described in LP#1508893 reduce the TFTP time-out, HP ProLiant m400 servers when booting via UEFI, may still experience TFTP timeouts.

[Test Case]
PXE boot a UEFI-based system (d-i or MAAS) and monitor the time it takes for GRUB to download the kernel/initrd. tcpdump will show TFTP timeouts and packet retries, and it can take on the order of minutes to begin running the kernel.

[Regression Risk]
The fix is restricted to UEFI-based systems.

Andrew Cloke (andrew-cloke) wrote :

From comment #11 of LP#1508893:

Looks only the commit 49426e9fd2( efinet: open Simple Network Protocol exclusively) isn't enough, and the
following three commits are required too for grub working well on HP m400 ARM64 server:

      7b386b703154c0901c4616(efidisk: move device path helpers in core for efinet)
      c52ae40570c3bfbcca22d21(efinet: skip virtual IPv4 and IPv6 devices when enumerating cards)
     f348aee7b33dd85e7da62b(efinet: enable hardware filters when opening interface)

Steve Langasek (vorlon) on 2015-12-02
Changed in grub2 (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02~beta2-32ubuntu1

---------------
grub2 (2.02~beta2-32ubuntu1) xenial; urgency=medium

  * Cherry-picks to better handle TFTP timeouts on some arches: (LP: #1521612)
    - (7b386b7) efidisk: move device path helpers in core for efinet
    - (c52ae40) efinet: skip virtual IP devices when enumerating cards
    - (f348aee) efinet: enable hardware filters when opening interface

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 03 Dec 2015 15:03:46 -0500

Changed in grub2 (Ubuntu):
status: New → Fix Released
Ming Lei (tom-leiming) wrote :

Now grub2 for Xenial just works fine on mcdivitt in case of netboot, especially during loading kernel image
via tftp.

Changed in grub2 (Ubuntu Trusty):
status: New → In Progress
Changed in grub2 (Ubuntu Vivid):
status: New → In Progress
Changed in grub2 (Ubuntu Wily):
status: New → In Progress
Changed in grub2 (Ubuntu Trusty):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in grub2 (Ubuntu Vivid):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in grub2 (Ubuntu Wily):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
dann frazier (dannf) on 2015-12-16
Changed in grub2 (Ubuntu Trusty):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → dann frazier (dannf)
Changed in grub2 (Ubuntu Vivid):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → dann frazier (dannf)
Changed in grub2 (Ubuntu Wily):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → dann frazier (dannf)
Changed in grub2 (Ubuntu Trusty):
importance: Undecided → High
Changed in grub2 (Ubuntu Wily):
importance: Undecided → High
Changed in grub2 (Ubuntu Vivid):
importance: Undecided → High

Hello Andrew, or anyone else affected,

Accepted grub2 into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2/2.02~beta2-9ubuntu1.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in grub2 (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Chris J Arges (arges) wrote :

Hello Andrew, or anyone else affected,

Accepted grub2 into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2/2.02~beta2-22ubuntu1.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in grub2 (Ubuntu Vivid):
status: In Progress → Fix Committed
Changed in grub2 (Ubuntu Wily):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello Andrew, or anyone else affected,

Accepted grub2 into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2/2.02~beta2-29ubuntu0.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in grub2-signed (Ubuntu Xenial):
status: New → Fix Released
Changed in grub2-signed (Ubuntu Trusty):
status: New → Fix Committed
Chris J Arges (arges) wrote :

Hello Andrew, or anyone else affected,

Accepted grub2-signed into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2-signed/1.34.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in grub2-signed (Ubuntu Vivid):
status: New → Fix Committed
Chris J Arges (arges) wrote :

Hello Andrew, or anyone else affected,

Accepted grub2-signed into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2-signed/1.46.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Chris J Arges (arges) wrote :

Hello Andrew, or anyone else affected,

Accepted grub2-signed into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2-signed/1.55.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in grub2-signed (Ubuntu Wily):
status: New → Fix Committed
Ming Lei (tom-leiming) wrote :

The three grub changes have been tested fine on both APM arm64 board and HP m400, looks
all works fine.

tags: added: verification-done
removed: verification-needed
dann frazier (dannf) wrote :

@Ming can you clarify which build(s) you tested (trusty, vivid, and/or wily)? It isn't clear to me if "three grub changes" means you tested all 3 builds, or if you tested one build comprising 3 source changes.

Hi Dann,

On Mon, Dec 21, 2015 at 11:59 PM, dann frazier
<email address hidden> wrote:
> @Ming can you clarify which build(s) you tested (trusty, vivid, and/or
> wily)? It isn't clear to me if "three grub changes" means you tested all

All three have been tested on both two kinds of arm64.

thanks,

> 3 builds, or if you tested one build comprising 3 source changes.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1521612
>
> Title:
> Continued TFTP timeouts when PXE booting via grub
>
> Status in grub2 package in Ubuntu:
> Fix Released
> Status in grub2-signed package in Ubuntu:
> Fix Released
> Status in grub2 source package in Trusty:
> Fix Committed
> Status in grub2-signed source package in Trusty:
> Fix Committed
> Status in grub2 source package in Vivid:
> Fix Committed
> Status in grub2-signed source package in Vivid:
> Fix Committed
> Status in grub2 source package in Wily:
> Fix Committed
> Status in grub2-signed source package in Wily:
> Fix Committed
> Status in grub2 source package in Xenial:
> Fix Released
> Status in grub2-signed source package in Xenial:
> Fix Released
>
> Bug description:
> [Impact]
> While the Grub2 patches described in LP#1508893 reduce the TFTP time-out, HP ProLiant m400 servers when booting via UEFI, may still experience TFTP timeouts.
>
> [Test Case]
> PXE boot a UEFI-based system (d-i or MAAS) and monitor the time it takes for GRUB to download the kernel/initrd. tcpdump will show TFTP timeouts and packet retries, and it can take on the order of minutes to begin running the kernel.
>
> [Regression Risk]
> The fix is restricted to UEFI-based systems.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1521612/+subscriptions

Newell Jensen (newell-jensen) wrote :

I tested this as well as I did not see that Ming had done it. No issues seen.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02~beta2-9ubuntu1.7

---------------
grub2 (2.02~beta2-9ubuntu1.7) trusty; urgency=medium

  * Cherry-picks to better handle TFTP timeouts on some arches: (LP: #1521612)
    - (7b386b7) efidisk: move device path helpers in core for efinet
    - (c52ae40) efinet: skip virtual IP devices when enumerating cards
    - (f348aee) efinet: enable hardware filters when opening interface
  * Update quick boot logic to handle abstractions for which there is no
    write support. (LP: #1274320)

 -- dann frazier <email address hidden> Wed, 16 Dec 2015 14:03:48 -0700

Changed in grub2 (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for grub2 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2-signed - 1.34.8

---------------
grub2-signed (1.34.8) trusty; urgency=medium

  * Rebuild against grub-efi-amd64 2.02~beta2-9ubuntu1.7 (LP: #1521612,
    LP: #1274320).

 -- dann frazier <email address hidden> Wed, 16 Dec 2015 14:23:00 -0700

Changed in grub2-signed (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02~beta2-22ubuntu1.5

---------------
grub2 (2.02~beta2-22ubuntu1.5) vivid; urgency=medium

  * Merge in changes from 2.02~beta2-22ubuntu1.3:
    - d/p/arm64-set-correct-length-of-device-path-end-entry.patch: Fixes
      booting arm64 kernels on certain UEFI implementations. (LP: #1476882)
    - progress: avoid NULL dereference for net files. (LP: #1459872)
    - arm64/setjmp: Add missing license macro. (LP: #1459871)
    - Cherry-pick patch to add SAS disks to the device list from the ofdisk
      module. (LP: #1517586)
    - Cherry-pick patch to open Simple Network Protocol exclusively.
      (LP: #1508893)
  * Cherry-picks to better handle TFTP timeouts on some arches: (LP: #1521612)
    - (7b386b7) efidisk: move device path helpers in core for efinet
    - (c52ae40) efinet: skip virtual IP devices when enumerating cards
    - (f348aee) efinet: enable hardware filters when opening interface
  * Update quick boot logic to handle abstractions for which there is no
    write support. (LP: #1274320)

 -- dann frazier <email address hidden> Wed, 16 Dec 2015 13:31:15 -0700

Changed in grub2 (Ubuntu Vivid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2-signed - 1.46.5

---------------
grub2-signed (1.46.5) vivid; urgency=medium

  * Rebuild against grub2 2.02~beta2-22ubuntu1.5 (LP: #1476882, LP: #1459872,
    LP: 1459871, LP: #1517586, LP:#1508893, LP: #1521612, LP: #1274320).

 -- dann frazier <email address hidden> Wed, 16 Dec 2015 14:18:28 -0700

Changed in grub2-signed (Ubuntu Vivid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02~beta2-29ubuntu0.3

---------------
grub2 (2.02~beta2-29ubuntu0.3) wily; urgency=medium

  * Merge in changes from 2.02~beta2-29ubuntu0.1:
    - arm64/setjmp: Add missing license macro. (LP: #1459871)
    - Cherry-pick patch to add SAS disks to the device list from the ofdisk
      module. (LP: #1517586)
    - Cherry-pick patch to open Simple Network Protocol exclusively.
      (LP: #1508893)
  * Cherry-picks to better handle TFTP timeouts on some arches: (LP: #1521612)
    - (7b386b7) efidisk: move device path helpers in core for efinet
    - (c52ae40) efinet: skip virtual IP devices when enumerating cards
    - (f348aee) efinet: enable hardware filters when opening interface

 -- dann frazier <email address hidden> Wed, 16 Dec 2015 10:05:39 -0700

Changed in grub2 (Ubuntu Wily):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2-signed - 1.55.3

---------------
grub2-signed (1.55.3) wily; urgency=medium

  * Rebuild against grub2 2.02~beta2-29ubuntu0.3. (LP: #1521612, #1517586)

 -- dann frazier <email address hidden> Wed, 16 Dec 2015 14:16:14 -0700

Changed in grub2-signed (Ubuntu Wily):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers