Grub menu hangs on down arrow press with USB keyboard on cold boot

Bug #1448668 reported by Mattias Johnsson on 2015-04-26
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Medium
Unassigned

Bug Description

I installed Windows 8.1 64-bit, then installed Ubuntu 15.04 bit, both in UEFI mode.

When booting, I am presented with the usual GRUB menu, with Ubuntu preselected at the top. If I press enter, Ubuntu loads. If I press arrow down (just once) to move down the menu toward the Windows entry, the highlighted entry skips rapidly to the bottom of the list and GRUB hangs and becomes completely non-responsive. Cycling the power or pressing reset is required.

This only happens on a cold boot, i.e. if the computer was off prior to going to the GRUB menu. If I get to the GRUB menu via pressing the "reset" button, or booting into Ubuntu and choosing "restart", the arrow keys work fine in the GRUB menu.

In addition, this bug only occurs with my USB keyboard (Logitech K120), not with my PS/2 keyboard (Logitech Deluxe 250). Trying different USB ports doesn't help.

Summary:

What happened: GRUB hangs if I press cursor down when using a USB keyboard after a cold boot
What should happen: I should be able to use arrow down to move down the GRUB boot menu to the entry I require
To reproduce: Install Windows 8, then install Ubuntu 15.04. Turn off power. Turn on power, boot computer, at GRUB menu press arrow down.

Presumably all hardware info is attached to report, but just to be sure: I'm trying to boot off a GPT partitioned 500GB SSD, and have a GA-Z97-D3H motherboard.

If you need any further information, just ask!

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: grub2 (not installed)
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Apr 26 22:34:35 2015
InstallationDate: Installed on 2015-04-25 (1 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

Mattias Johnsson (m-t-johnsson) wrote :
Mattias Johnsson (m-t-johnsson) wrote :

Here are the GRUB configuration files from /etc/grub.d

Mattias Johnsson (m-t-johnsson) wrote :

Further information: This bug is present regardless of the "Legacy USB devices" setting in the UEFI menu. I've tried "Disabled", "Enabled" and "Auto" with no luck.

I'm not quite sure why this would happen. I also use a USB keyboard, without seeing this issue.

Does the same happen if you use a different USB keyboard, assuming you can have access to another?

Thanks!

Changed in grub2 (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
Mattias Johnsson (m-t-johnsson) wrote :

Hi Mathieu,

Okay, I tried another USB keyboard (an Acer of some type) and the problem is still present.

So it does look like a USB problem of some sort, rather than a problem with the specific keyboard I was using.

Launchpad Janitor (janitor) wrote :

[Expired for grub2 (Ubuntu) because there has been no activity for 60 days.]

Changed in grub2 (Ubuntu):
status: Incomplete → Expired
A.R.NARESH (naresh14334) wrote :

it also affects me

Changed in grub2 (Ubuntu):
status: Expired → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Kojo (rmvirut) wrote :

Been facing this issue for a while myself. I have Ubuntu and Windows on two different hdds and used bit repair to make sure Grub was setup well.
But now it just hangs when I try to select any OS part from Ununtu

arm-c (arickmcniel) wrote :

Not sure if it is the same issue, but sounds very similar.

Situation: GRUB freezes on my laptop at countdown 10 with not ability to move anything. Currently, this happens everytime my external keyboard is attached.

Equipment: HP X360 i7 configured dual boot. USB 3.1 (USB-A), USB 3.1 (USB-C) and Thunderbolt (USB-C). UEFI Boot.

This is an issue because I want to leave my computer docked and survive a reboot without having to unplug the keyboard all the time. I've googled solutions and "legacy boot" would disable my installed OSs. There is not bios option for "legacy USB" support and none of the GRUB-2 configurations to enable USB, usb-keyboard, etc... have worked.

MY KEYBOARD works before and after grub.... meaning, that at power-on, I can press F10 on usb-keyboard and get to BIOS. Plugging in the keyboard after GRUB boot, keyboard works.

I have tried three separate keyboard... all of which I know are working.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers