grub's prerm script fails, preventing installation of vivid Ubuntu-MATE

Bug #1426905 reported by rolmops on 2015-03-01
66
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ubuntu MATE
High
Unassigned
grub2 (Ubuntu)
High
Unassigned
Vivid
High
Unassigned

Bug Description

the collapse of the installation Ubuntu mate 15.04

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: ubiquity 2.21.13
ProcVersionSignature: Ubuntu 3.18.0-13.14-generic 3.18.5
Uname: Linux 3.18.0-13-generic x86_64
ApportVersion: 2.16.1-0ubuntu2
Architecture: amd64
CasperVersion: 1.351
Date: Sun Mar 1 18:41:07 2015
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu-mate.seed boot=casper quiet splash --
LiveMediaBuild: Ubuntu-MATE 15.04 "Vivid Vervet" - Alpha amd64 (20150225)
ProcEnviron:
 LANGUAGE=ru_RU.UTF-8
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: grub-installer
UpgradeStatus: No upgrade log present (probably fresh install)

rolmops (dr150259) wrote :
Phillip Susi (psusi) wrote :

It appears that grub-pc's prerm is failing for some reason.

affects: grub-installer (Ubuntu) → grub2 (Ubuntu)
Changed in grub2 (Ubuntu):
importance: Undecided → High
status: New → Triaged
Phillip Susi (psusi) on 2015-03-05
summary: - the collapse of the installation Ubuntu mate 15.04
+ grub's prerm script fails, preventing installation of vivid
Phillip Susi (psusi) on 2015-03-23
Changed in grub2 (Ubuntu):
importance: High → Critical
milestone: none → ubuntu-15.04

Well, it seems likely that it maybe MATE specific.

[ 3:22PM ] [ bdmurray@impulse:~ ]
 $ lp-bug-dupe-properties -b 1426905 -D "LiveMediaBuild"
LP: #1426905 has 5 duplicates
  Ubuntu-MATE 15.04 "Vivid Vervet" - Alpha amd64 (20150225): 1428159 1428482 1429385 1433332 1435096

Changed in grub2 (Ubuntu Vivid):
importance: Critical → High
summary: - grub's prerm script fails, preventing installation of vivid
+ grub's prerm script fails, preventing installation of vivid Ubuntu-MATE

Hi
I had this bug 2 years ago with ubuntu Unity. Since UEFI wasn't well supported (and documented) at that time, I tought it was the reason.

It appears that on my asus UX32VD, the fake RAID was the biggest trouble maker.
I get rid of it 3 weeks ago and was able to install ubuntu MATE 14.04 and 15.04 normally .

<div>-------- Message d'origine --------</div><div>De : Brian Murray <email address hidden> </div><div>Date :25/03/2015 23:38 (GMT+01:00) </div><div>A : <email address hidden> </div><div>Cc : </div><div>Objet : [Bug 1426905] Re: grub's prerm script fails,
  preventing installation of vivid Ubuntu-MATE </div><div>
</div>** Summary changed:

- grub's prerm script fails, preventing installation of vivid
+ grub's prerm script fails, preventing installation of vivid Ubuntu-MATE

--
You received this bug notification because you are subscribed to a
duplicate bug report (1429385).
https://bugs.launchpad.net/bugs/1426905

Title:
  grub's prerm script fails, preventing installation of vivid Ubuntu-
  MATE

Status in Ubuntu MATE:
  New
Status in grub2 package in Ubuntu:
  Triaged
Status in grub2 source package in Vivid:
  Triaged

Bug description:
  the collapse of the installation Ubuntu mate 15.04

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: ubiquity 2.21.13
  ProcVersionSignature: Ubuntu 3.18.0-13.14-generic 3.18.5
  Uname: Linux 3.18.0-13-generic x86_64
  ApportVersion: 2.16.1-0ubuntu2
  Architecture: amd64
  CasperVersion: 1.351
  Date: Sun Mar 1 18:41:07 2015
  InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu-mate.seed boot=casper quiet splash --
  LiveMediaBuild: Ubuntu-MATE 15.04 "Vivid Vervet" - Alpha amd64 (20150225)
  ProcEnviron:
   LANGUAGE=ru_RU.UTF-8
   PATH=(custom, no user)
   LANG=ru_RU.UTF-8
   SHELL=/bin/bash
  SourcePackage: grub-installer
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-mate/+bug/1426905/+subscriptions

sambolinux (sambolinux) wrote :

 I was able to install unity then add mate to the installation. The problem is mate specific. I don't know what the difference would be ,except ubiquity.

Changed in ubuntu-mate:
importance: Undecided → High
Martin Wimpress (flexiondotorg) wrote :

Please try the Ubuntu MATE current daily image to confirm this issue is resolved.

  * http://cdimage.ubuntu.com/ubuntu-mate/daily-live/current/

Changed in ubuntu-mate:
status: New → Fix Committed
sambolinux (sambolinux) wrote :

3-31-2015-just tried the new mate iso and same thing. Though time time, I did it in virtual reality(virtual box) and used the iso from my hard drive. The first time was from a usb key and installing in reality -- I don't want to mess up my current install because I have it tweaked and peaked for my hardware.

Martin Wimpress (flexiondotorg) wrote :

Can you please attach the files in '/var/log/installer' from your failed install attempt in a VM. I am unable to reproduce this issue.

Changed in ubuntu-mate:
status: Fix Committed → Incomplete
MR (disposeaccount) wrote :

Dunno if my bug is the same. It was from an Ubuntu Gnome install.

https://bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/1446459

When installing to /sdb/, installer encounters fatal error when attempting to run grub-installer

I tired altering the drive to /sda/ through UEFI priorities but to no avail.

So I unplugged the second storage drive which was getting defined as sda.

RESOLUTION
With only one drive plugged in, it was forced as sda

grub-installer ran without issue
installer completed successfully

Martin Pitt (pitti) wrote :

Martin Wimpress says this issue isn't reproducible on current images and didn't come up during final candidate image testing, so un-milestoning for now.

Changed in grub2 (Ubuntu Vivid):
milestone: ubuntu-15.04 → none

I believe this issue is fixed.

Changed in ubuntu-mate:
status: Incomplete → Fix Released

@rolmops, @sambolinux,

Are any of you still seeing this issue when installing MATE?

Changed in grub2 (Ubuntu Vivid):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers