network stack never yields control on busy networks

Bug #1314134 reported by Colin Watson on 2014-04-29
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
High
Colin Watson
Trusty
High
Colin Watson
grub2-signed (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact] GRUB's network stack tries to process all incoming packets, and thus never or rarely yields control back to other parts of GRUB when the network is busy with e.g. lots of ARP traffic.
[Test Case] Use GRUB to netboot a system on a busy network; ensure that it is responsive. (I've had reports of 90-minute delays in interactive response on some systems, so in those cases the difference should be dramatic and easily observable.)
[Regression Potential] Confined to netbooting.

These upstream patches should fix this:

  https://lists.gnu.org/archive/html/grub-devel/2014-01/msg00119.html
  https://lists.gnu.org/archive/html/grub-devel/2014-01/msg00118.html

I plan to backport these for 14.04.1.

Colin Watson (cjwatson) on 2014-04-29
Changed in grub2 (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Changed in grub2 (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Changed in grub2 (Ubuntu Trusty):
milestone: none → ubuntu-14.04.1
Colin Watson (cjwatson) on 2014-04-29
Changed in grub2 (Ubuntu):
status: Triaged → Fix Committed
Colin Watson (cjwatson) on 2014-04-29
Changed in grub2 (Ubuntu Trusty):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02~beta2-10

---------------
grub2 (2.02~beta2-10) unstable; urgency=medium

  [ Colin Watson ]
  * Add the true module to the signed image, since 05_debian_theme uses it.
    Thanks to Dimitri John Ledkov for the report.
  * Limit test suite parallelisation to 1; the test suite seems to have some
    isolation problems at higher levels at the moment (closes: #746856).
  * Simplify override_dh_install a bit.
  * Backport patches from upstream to make the network stack more responsive
    on busy networks (LP: #1314134).

  [ Dimitri John Ledkov ]
  * Add support for nvme device in grub-mkdevicemap (closes: #746396,
    LP: #1275162).

  [ Debconf translations ]
  * Korean (Changwoo Ryu, closes: #745559).

 -- Colin Watson <email address hidden> Thu, 08 May 2014 11:13:48 +0100

Changed in grub2 (Ubuntu):
status: Fix Committed → Fix Released

Hello Colin, or anyone else affected,

Accepted grub2 into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/grub2/2.02~beta2-9ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in grub2 (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) on 2014-05-19
Changed in grub2-signed (Ubuntu):
status: New → Fix Released
Changed in grub2-signed (Ubuntu Trusty):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02~beta2-9ubuntu1

---------------
grub2 (2.02~beta2-9ubuntu1) trusty; urgency=medium

  * Backport patches from upstream to make the network stack more responsive
    on busy networks (LP: #1314134).
  * Add support for nvme device in grub-mkdevicemap (thanks, Dimitri John
    Ledkov; closes: #746396, LP: #1275162).
 -- Colin Watson <email address hidden> Thu, 08 May 2014 13:09:46 +0100

Changed in grub2 (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2-signed - 1.34.1

---------------
grub2-signed (1.34.1) trusty; urgency=medium

  * Rebuild against grub-efi-amd64 2.02~beta2-9ubuntu1 (LP: #1314134)
 -- Adam Conrad <email address hidden> Mon, 19 May 2014 02:47:42 -0600

Changed in grub2-signed (Ubuntu Trusty):
status: Fix Committed → Fix Released
tags: removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers