The "--disk-module=MODULE" option of "grub-install" works wrong in Grub 2.02~beta2-9

Bug #1309735 reported by Asuna
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
grub2 (Debian)
Fix Released
Unknown
grub2 (Ubuntu)
Medium
Mathieu Trudel-Lapierre

Bug Description

My OS is ubuntu14.04 LTS.
And the command "grub-install -V" shows that the grub version is Grub 2.02~beta2-9.

Since I have two disk on my laptop, and one of them is not bootable, I have to use nativedisk mode.

But the "--disk-module=MODULE" option of grub-install can not work normaly.
Command like:
sudo grub-install --disk-module=native /dev/sda

returns me the following message:
"
 --disk-module: (PROGRAM ERROR) Option should have been recognized!?
Try 'grub-install --help' or 'grub-install --usage' for more information.
"

What's the meaning of "should have been recognized", not unrecognized?

Grub(-install)2.00 in ubuntu13.10 don't have this bug. Everything goes well.

The following attachment is the output of `sudo fdisk -l`. /dev/sda is SSD, /dev/sdb is HDD and because of the bios problem, it's not bootable.

Related branches

Asuna (811197881-8)
description: updated
Revision history for this message
Asuna (811197881-8) wrote :
description: updated
Asuna (811197881-8)
description: updated
description: updated
Asuna (811197881-8)
description: updated
Asuna (811197881-8)
summary: - The --disk-module=MODULE option of grub-install don't work
+ The "--disk-module=MODULE" option of "grub-install" works wrong in Grub
+ 2.02~beta2-9
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Revision history for this message
Asuna (811197881-8) wrote :

Is there any way to fix it?
Or I have to wait't for the stable version of grub2.02?

Revision history for this message
apport hater (g112) wrote :
Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

Let's use the right upstream commit (at http://git.savannah.gnu.org/cgit/grub.git/commit/?id=fa33530870839e303354ff2660baeff5356ea736), but the change is the same; I'll push the patch to Debian so we can sync it to Ubuntu.

Changed in grub2 (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Revision history for this message
apport hater (g112) wrote :

Thanks

Revision history for this message
Asuna (811197881-8) wrote :

Thanks for your reply.

Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

I've pushed this to a branch that will have to be merged for Debian; then we'll merge and upload there; once that's done it will be simple to sync to Ubuntu. In other words, this should be fixed soonish.

Changed in grub2 (Debian):
status: Unknown → New
Changed in grub2 (Debian):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02~beta2-25

---------------
grub2 (2.02~beta2-25) unstable; urgency=medium

  * Build-depend on dosfstools and mtools on arm64 as well as amd64.

 -- Colin Watson <email address hidden> Fri, 12 Jun 2015 12:29:19 +0100

Changed in grub2 (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
apport hater (g112) wrote :

Is Vivid going to see the fix eventually?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.