grub2-2.02 has wrong build-deps

Bug #1299041 reported by Valentijn Sessink on 2014-03-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Medium
Colin Watson

Bug Description

after "apt-get build-dep grub-efi-amd64", many packages are missing. The ones I tracked so far:
automake1.10 (another automake is probably somewhere in the dependencies, but building complained that 1.10 is needed); to be able to run the tests, dependencies seem to be: lzop; hfsplus; squashfs-tools; attr; reiserfsprogs
I might have missed a package - currently rebuilding grub and it seems to work.
---
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
DistroRelease: Ubuntu 14.04
Package: grub2 (not installed)
ProcVersionSignature: Ubuntu 3.13.0-19.40-generic 3.13.6
Tags: trusty
Uname: Linux 3.13.0-19-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

_MarkForUpload: True

Jörg Frings-Fürst (jff-de) wrote :

Hi,

we need some more information. From a terminal window please run:

sudo apport-collect 1299041

and then change the status of the bug to 'Confirmed'.

Jörg

Changed in grub2 (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected trusty
description: updated
Changed in grub2 (Ubuntu):
status: Incomplete → Confirmed
Valentijn Sessink (valentijn) wrote :

Jörg, I don't think the "ProcEnviron.txt" is the information you were looking for. However, apt-get install apport; apt-get install python-apport; apport-collect 1299041 did just that (on 14.04).

Now on a freshly installed 14.04, I ran the following:
# apt-get build-dep grub; apt-get build-dep grub-efi-amd64; apt-get source grub-efi-amd64
 cd grub2-2.02~beta2/; debian/rules build

After which an error pops up (among other make information):
configure.ac:48: require Automake 1.10.1, but have 1.9.6

If you only install automake1.10, more errors will pop up. Now after issuing:
apt-get install lzop hfsplus squashfs-tools attr reiserfsprogs automake1.10
debian/rules build
... things work fine. (As a side note: I have to export LANG=C; LC_ALL=C but that could be due to wrongly setup locale and is unrelated to this bug).

Jörg Frings-Fürst (jff-de) wrote :

Hallo Valentijn,

the trusty automake version is 1.14.1 and in quantal 1.11.6.

Do you have your version manually installed?

Jörg

Jörg Frings-Fürst (jff-de) wrote :

Hallo Valentijn,

v 1.9.6 was from 2005: http://lists.gnu.org/archive/html/info-gnu/2005-07/msg00003.html

Jörg

Valentijn Sessink (valentijn) wrote :

That's why "apt-get build-dep grub" matters. Grub (not grub2) has a "Build-Depends: debhelper (>= 4.0.0), automake1.9". Thus, automake1.9 gets installed. "Grub2" doesn't even have a build-depend on automake - there might be a lower dependency on automake but I did not check that. So it's not a system from 2005, it's just that I typed "apt-get build-dep grub" - as stated above.

The bottom line is: the build-dependencies of grub2 (which is in beta) aren't fully up to date, and my list might be of help.

Valentijn Sessink (valentijn) wrote :

s/grub2/grub2-2.02/ - the version that was added to 14.04 recently.

Colin Watson (cjwatson) wrote :

The tests shouldn't fail without the various other packages you list; it just causes some tests to be skipped. I don't think those ones are really worth build-dependencies. I agree that we should explicitly build-depend on automake (>= 1.10.1), though, so I'll do that for the next upload. Thanks.

Changed in grub2 (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Medium
Valentijn Sessink (valentijn) wrote :

Thanks - I'll recheck my build - problems after automake1.10 could be due to wrong language settings.

I know that it's possible to build grub2 with only its
build-dependencies, because all Debian and Ubuntu builds happen inside
sbuild, which starts from a clean chroot and installs only the
build-dependencies.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02~beta2-8

---------------
grub2 (2.02~beta2-8) unstable; urgency=medium

  [ Colin Watson ]
  * Backport from upstream:
    - ieee1275: check for IBM pseries emulated machine.
    - Fix partmap, cryptodisk, and abstraction handling in grub-mkconfig
      (closes: #735935).
    - btrfs: fix get_root key comparison failures due to endianness.
  * Build-depend on automake (>= 1.10.1) to ensure that it meets configure's
    requirements (LP: #1299041).
  * When installing an image for use with UEFI Secure Boot, generate a
    load.cfg even if there are no device abstractions in use (LP: #1298399).

  [ Jon Severinsson ]
  * Add Tanglu support, as in Debian except:
    - Enable splash screen by default (as Ubuntu)
    - Enable quiet and quick boot (as Ubuntu)
    - Enable the grub-common init script (as Ubuntu)
    - Enable dynamic gfxpayload (as Ubuntu)
    - Enable vt handover (as Ubuntu)
    - Use monochromatic theme by default (as Ubuntu)
    - Use Tanglu GRUB wallpaper by default.

 -- Colin Watson <email address hidden> Mon, 31 Mar 2014 16:30:37 +0100

Changed in grub2 (Ubuntu):
status: Fix Committed → Fix Released
Valentijn Sessink (valentijn) wrote :

Thanks for the >= 1.10 addition.
Still, if you install "ntfs-3g" but not "attr", then the "ntfs_test" FAILS - not skips - with an error "./grub-fs-tester: line 895: setfattr: command not found". It probably tests the availability of mkfs.ntfs somewhere without testing setfattr. You could argue that this is an upstream bug all by itself and has nothing to do with the build-deps. However, if there's a quick fix (and, in fact, why not let all tests succeed instead of skip?) it could be worth fixing this.

Colin Watson (cjwatson) wrote :

The reason this is failing for you is that you're running the build as
root. You really shouldn't do that - the build phase of Debian source
packages is supposed to run as non-root.

I intentionally haven't added build-dependencies for the root-only
tests, since they will never be exercised in normal package builds.

Valentijn Sessink (valentijn) wrote :

Fair enough. (The reason I'm building it anyway is that grub2_2.02~beta2-7 wouldn't install - so I could not get past the install phase - hence no accounts; hence build as root :-S
So thanks again for beta2-8 - it makes things much easier :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments